Solved App Not Connecting With Tesla Car Problem

Solved App Not Connecting With Tesla Car Problem

Many are reporting a problem with sudden loss of the ability of the app to communicate with the car. A few have found that if they delete the app and reinstall it, the problem disappears. A few have reported it to be due to the car being in a location with no reception. I have had my Model S 100D for over a year with never a problem. Suddenly, after a home charge from a pretty low battery, my app could no longer communicate with the car. My wife's phone had the exact same problem at the exact same time.

I realized that there were no new app upgrades and both our phones (iPhone & Samsung) simultaneously lost the ability to communicate with the car, that it was a car based problem, not a phone or app based problem. As it was after a deep charge from a low state, most likely it was a "battery charge flux" related locking of the car software. I did a main console reset/reboot as follows:
1) Put in Park.
2) Press and hold both scroll wheels until main screen goes dark.
3) Wait for main console screen to come back up.

Then I tested the app and success! It worked flawlessly once again.

Have a happy new year!

DRFLGD | 1 janvier 2019

Thanks for the info.

Anthony J. Parisio | 1 janvier 2019


Bighorn | 1 janvier 2019

Too bad I can’t do that from 2,000 miles away!

LauraL | 2 janvier 2019

App was working fine till software update on the car. Then suddenly lost the ability to control the heated seats and steering wheel. App has a lot of trouble connecting to the car- can take over 10 minutes at times even with great wi-fi.
Tried the reboot, did nothing. Also uninstalled and reinstalled the app, rebooted my phone, sent 4 e-mails to customer support- finally got support on the phone after 30 minutes on hold. Tech is telling me that there is something wrong with my car's software that will not allow it to accept any updates, and he would have a tech call me right away to set up an appointment for them to come and do the update manually. Three hours later, still nothing

lopez.marios | 2 janvier 2019

New with model 3 (2 days). Installed Tesla App but not connecting with vehicle. Help

akikiki | 2 janvier 2019

Sounds like Remote Access is not enabled. Is this the same answer they gave you on the Model 3 side of the forum?

ileung4 | 24 avril 2019

An interruption during charging (power failure or surge) can cause phone app to loss communication with the car. Reset/reboot from the main console solves the problem.

wpautz | 3 juin 2019

Yes, reset worked. Press and hold both buttons on the steering wheel.

bkvivona | 11 juillet 2019

My app works but will not allow me to schedule service. When I click on schedule service I get the Tesla logo and nothing else,

Roger1 | 11 juillet 2019

I experienced the problem with my 2017 S100D. I reloaded software on the phone but the problem continued. I stopped by the Tesla store and asked service about the problem. They knew some customers where experiencing a problem but didn't have a solution and suggested I phone for support. The interesting part of the transaction was a check through their online system that showed the car was doing a software update that was incomplete.
At some point in the process I did the two button reset but that by itself did not immediately fix the problem, The problem eventually resolved by itself when 20.4.3 completed installation and the main display showed the update notes.

cmalan | 11 juillet 2019

I had the same experience after installing 2019.20.4.2. It turned out that I had to log back into the mobile access section. I originally thought that Tesla server’s were down, but didn’t see any indication on TMC or this forum. That was the first time I had to do that Since purchasing in 2017.

rnakhan | 8 août 2019

Lopez.marios are you able to connect now? How long did it take you and did you have to do anything special?
It is day 2 for me with model 3 and getting "vehicle connection error" after long waking up.

scjohnson | 2 septembre 2019

I am having the same problem with my Model x. I tried the reboot and that did not solve the problem

Bighorn | 2 septembre 2019

Back up

mark.niemann | 3 septembre 2019

I am having trouble with the car not connecting to WiFi as well as not connecting to the app. I tried the restarting of the screen on mine, but have not had any luck yet.

clayfenster | 25 septembre 2019

Just lost connection for the last 4 days on my Model S. Hard and soft car resets had no effect, nor turning mobile access off and back on. I finally signed out of the mobile app then back in and the app instantly connected.

clayfenster | 25 septembre 2019

Just lost connection for the last 4 days on my Model S. Hard and soft car resets had no effect, nor turning mobile access off and back on. I finally signed out of the mobile app then back in and the app instantly connected.

vijayl.gowda | 26 septembre 2019

Signing out of the app and re-logging in worked for me on an Android device.

miznish | 27 septembre 2019

Signing out and back in to the app worked for me to on Iphone

glovgren51 | 30 septembre 2019

I have reloaded the App and I am still unable to load, schedule service page.

rm760 | 30 septembre 2019

For those of you having issues with iPhones connecting to your Tesla via Bluetooth. Apple has just made IOS 13.1.2 available to address Bluetooth connectivity issues.

m20e | 8 octobre 2019

Mine hasn't connected since 9/2/19. I went into security settings and disabled mobile access. Then enabled mobile access and I received a connection.