Phone contacts not visible on the car

Phone contacts not visible on the car

My phone connects to the car and I can receive calls and use the dialer, I can see the calendar but my contacts dont show up neither does my call log. I checked my phone and the sync contacts in is checked on my phone.

Can someone help? | 22 juin 2017

Not sure what kind of phone you have (Apple, Android, something else), but often when you install the Tesla app, it asks if the app can have permission to access your contacts. If you said no, then the app can't get the contacts from the phone. Since I have no idea what phone you have or what version of the OS is on the phone, I suggest uninstalling the Tesla app, then reinstall and make sure you allow it to access contacts during the installation. There are ways to allow contacts without uninstall/reinstall, so if you know how to do those tricks, go ahead.

NKYTA | 22 juin 2017

There is also a checkbox on the cars screen when pairing a phone, whether you want contacts/recent calls also paired.

I just re-paired my phone after getting a new MCU, and had forgotten that fact.

nkondury | 22 juin 2017

it is iphone and I am on the latest version. It used to show me the contacts and then one find day it stopped after one of the OS upgrade on the car. I will try to reinstall the app

JayInJapan | 22 juin 2017

iOS Settings/Tesla-->toggle contacts on

nkondury | 25 juin 2017

I dont see iOS Settings/Tesla-->toggle contacts on in my settings as suggested. I also installed the app but still no change.

EVRider | 25 juin 2017

I don't see the iOS > Tesla > toggle contacts setting either, nor do I see anything on the touchscreen about allowing contacts to sync (17.11.10). Under iOS > Privacy > Contacts there are a few apps listed that have requested access to Contacts, but the Tesla app isn't one of them. However, my contacts are syncing correctly.

@nkondury: If you didn't already try this, delete the Bluetooth connection for you phone from the car and then re-pair it.

JayInJapan | 26 juin 2017

Well, I just looked at my iPhone with the latest iOS update, and I see what I wrote above to enable contacts.

EVRider | 26 juin 2017

@Jay: Which version of the Tesla app do you have? The version is displayed in iOS Settings > Tesla. I have version 3.1.3 (build 320), and the options under "Allow Tesla to Access" are Location, Calendars, Notifications, Background App Refresh, and Cellular Data; nothing about Contacts. I have the latest iOS version (10.3.2).

JayInJapan | 26 juin 2017

Same versions of both here.
Background App Refresh
Cellular Data

nkondury | 30 juin 2017

EVRider. I disconnected from the car and the deleted it from my phone and car. I started it all over as a new device and now it works.

Thank you all | 30 juin 2017

Glad you got it working and reported back what worked!

Owner2015 | 30 juin 2017

Wow good to know our cars are like cheep pcs. Just turn it off and back on and it should work this time. Wonder when we'll get hit with ransom ware where we have to pay to get our cars back.

EVRider | 30 juin 2017

@Jay: I'm guessing the iOS Tesla settings are dynamic, and the presence of the Contacts setting depends on whether or not you've updated the app or iOS since pairing your phone on Bluetooth. On my iPad, there's no Location option.

airwave80 | 30 septembre 2017

So after getting a new device and updating to iOS 11, my contacts don’t sync. I get stuck on preparing to sync contacts. I have deleted Bluetooth link on phone and car, restarted the car’s computer, deleted and reinstalled the tesla app, made sure the car selection is to sync contacts and made sure my Bluetooth settings are set to sync contacts. Any ideas on what I should try next?

NKYTA | 30 septembre 2017

Reboot your phone?

kerryglittle | 1 octobre 2017

Just for trouble shooting ideas. Can you try another phone if one is available? See if that works. At least it will show you if its your phone that has the problem or the car. If you have exhausted all other attempts take it into service and get them to figure it out. ;-)

rudie | 1 juin 2018

So this is an old thread but I just got my model 3 and had the same issue. What I had to do was go to settings -> Bluetooth-> Tesla Model 3 (click on the i) -> Sync Contacts.

tom168 | 1 juin 2018

Hmm.. I still have the same issue with iPhone 6 and Samsung S8. Service Center personnel tried and no luck. If I sync contact, the bluetooth connection will be in and out. So, I could call and receive calls but I cannot use the contact list to call.....

shivmanoj | 3 août 2018

settings -> Bluetooth-> Tesla Model 3 (click on the i) -> Sync Contacts.
did it for me! thx Rudie.

tom168 | 3 août 2018

I took both cars ( Model 3 and 2018 Model S ) to service center and they cannot make it work. The contact list and the history cannot be loaded. So, I cannot use voice dial, don't know who is calling.... It is a bug on the new MCU and as of last week, they still have not fixed it yet.

TaraTara | 30 septembre 2018

Rudie -- thanks so much for the update! I needed that info.

jhxyz2008 | 26 octobre 2018

settings -> Bluetooth-> Tesla Model 3 (click on the i) -> Sync Contacts.
did it for me! thx Rudie.

mike33 | 26 octobre 2018

Had same problem...contacts wouldn't sync in Ver 8.1 or Ver 9. Fixed by reducing the number of contacts. Either I had too many or perhaps a corrupted contact. In case you are wondering, I started with 2700 contacts and went down to 1700. I have an iphone XS Max V12 software. Works fine now.

sbpanda | 28 décembre 2018

Thanks, to the contributors of this forum. I had similar problem and was able to fix it by 2 steps (Android phone):
1. Settings-->Bluetooth-->Tesla Model 3--->Settings-->Contact Sharing
2. Tesla App-->App Info -->Permissions-->Contacts

tesla | 30 décembre 2018

sbpanda has the answer! Works on iPhone as well.

john | 16 janvier 2019

agreed - just did the same thing on my iPhone. I had to turn the bluetooth off and back on (as it didn't work first time), but worked after that.

jallan | 16 janvier 2019

I had the same problem. Simply telling it to sync my contacts didn't fix it. Deleting my iphone from the car and deleting the car from my iphone, and then reconnecting the two, fixed the problem.

Eugene | 24 janvier 2019

I tried all of these options but nothing is working. It always worked and yesterday, all of the sudden, my contacts were no longer visible. Any ideas why this happened now?

EVRider | 24 janvier 2019

@Eugene: Did you verify that your phone was paired with the car? Were you alone in the car? If your passenger’s phone has been paired with the car previously, their phone might have connected first.

jrice1 | 26 janvier 2019

Reinstalled Tesla app and deleted/repaired iphone fixed the contacts problem for me.

kjellf | 30 mars 2019

My Sony XZ2 Compact was unable to sync contacts with 2 BT devices. I stopped syncing my Huawei Watch . now my contacts show up in car and PHONE functions show up on bluetooth page.

marquis.smith | 18 avril 2019

Hello, If you are having trouble with your Galaxy-class Android phone not showing your contacts in your Tesla; I have a solution. I have been working with Tesla for months and they are working on a fix but no release date has been provided. So, do this easy fix.
Download Google Contacts App from the Play store ( The name is Contacts -Google LLC) after it has installed you will see a little red dot on the menu icon click it you may be asked to select from several sources of contacts select the one with your Google address ( others may work, but I did not try them) and then let the app merge all duplicates. Next from your phone under blue tooth unpair your phone from the car and reboot your phone. On the car "forget" your phone, and then push both roll button on your steering wheel mashing the brake pedal until you get the Tesla T. Now search for your phone from the car and say yes to both messages on your phone from the car wanting to pair and allow your calendar and contacts. Now you are good to go.