Help ?! Charging adapter is stuck

Help ?! Charging adapter is stuck


I'm on a road trip.

I used the 110v adapter on the charging cable last night. No problem.

Today I tried to take off the 110v adapter from the cable and cannot. It is stuck.

I really need to get it off to attach a NEMA plug.

When I push down on the release button the adapter will come out about 1/8" but no more.

I've tried pushing it back together, jiggling, pulling really hard, having a second person push the button while I pull.

I've tried when the other end is plugged into the Tesla and when it is not.

Is there some trick I'm missing?

The 110v adapter when right on - no problem - and it charges, but I'm 24 hours to a full charge with that - kind of a speedbump in the plans.

JPPTM | 3 mai 2015

Worried that you have had some kind of thermal issue and damage where the UMC connector attaches to the NEMA 5-15 adapter. If you have released the button and can slide the connection apart a bit, can you insert a flat bladed screwdriver and pry gently to see if you can separate the adapter. if so, carefully inspect the pins and receptacles for the connection and look for damage. In any event, contact TM Service and look into getting a replacement, and maybe hold off on using the UMC for now.

Grinnin'.VA | 4 mai 2015

OP: I noticed that the adapters aren't easy to remove.
You have to press the release button while pulling the adapter away from the mobile charging cable.

Good luck.

Tom.frantz49 | 30 mai 2015

Same problem. The pin release when using the 120 v adapter does not allow the adapter to pull off the cable. The pin does not fully retract when the button is pushed.

Stuck charging at 120 v now.

Any solution?

EcLectric | 1 juin 2015

I had the same problem with a new charging cable they gave me at the service center. That cable also had a problem that the pins going into the car were too long so it wouldn't seat into the car all the way to charge.

Tesla replaced the charging cable and now its fine. It seems this is a common problem.

EcLectric | 1 juin 2015

This was the 220v adapter that was stuck for me.

rajeev4444 | 17 mai 2019

I am still stuck