Navigation System loses position frequently

Navigation System loses position frequently

I just picked up my Model S Performance last week and love it. However, the navigation system frequently (50% of the time) loses it's position on the map and makes the directions incorrect. It's as if the arrow continues in a straight line when it gets lost and takes me off the road I'm on. I've reset the display twice with no improvements. I'm driving on major freeways in San Diego with full 3G signals. Has anyone else had this problem or should I take it in for service? | 2 septembre 2013

Sounds like a GPS problem. I've not seen this occur in my car, or heard of others encountering this issue.

Dripps | 2 septembre 2013

Yep, I'd be happier with 50% correct. I think it has my position correct about 20% of the time. Often it shows me pointing one way and moving sideways and a few times complete circles, nowhere near the road I'm actually on. Waiting for Tesla to get back to me with solution as the resets don't help. I think there is something wrong with hardware. Also the screen has big grey boxes (slow to draw) quite often. Keep in mind my husband drives a Model S also and his GPS works perfectly. I know how it's supposed to work.

GReese | 2 septembre 2013

I've not seen this occur before. In fact, I would rank the GPS/nav system the most accurate I've ever encountered.

In short, it sounds like you need to have this looked at.

earlyretirement | 2 septembre 2013

I'd have them look at it. I'm also in San Diego and the GPS has worked well. I've been out and about quite a bit and only noticed 1 or 2 times when the GPS got temporarily confused but it was at an intersection with several roads.

The only thing I wish it had the ability to change is to pick the shortest distance vs. fastest, etc. My GPS in my Audi Q7 gives that option.

Does anyone know by default if the GPS in the car goes by fastest time, shortest route, etc?

sxross | 2 septembre 2013

I'm in San Diego and it's never happened on my car. But... I had a loaner and just before I returned it, the nav system got clueless. If I hadn't known where I was going, I would have pulled over and rebooted the thing, but it was just weird.

kmalloy | 2 septembre 2013

Thanks everyone.
Greese - do you see any difference when you're using slacker vs not? I'm wondering if the Internet bandwidth is challenged. Otherwise it's got to be the GPS hardware. I have service coming to get the car from my office tomorrow to evaluate it. Ill let you know what they tell me.

kmalloy | 2 septembre 2013

Sorry I meant to ask drip that question not greese

davidcoleman81 | 2 septembre 2013

I have it happen and sometimes you can fix it by resetting the mail console by holding down the scroll wheels at the same time for about 10 seconds.

Brian H | 4 septembre 2013

mail main console? ;) (Do you use it a lot for email?)

ColoradoBlueS | 6 septembre 2013

We've had the same basic problem with our 1 week old Model S since the day we we received it. The Denver SC staff said this issue is believed to occur with (or is in some way related to) the current 5.0 software release and they hope to see a patch release available within a couple weeks. One of the odder things to watch is when ours is confused it sometimes spins the car's arrow icon in circles. Or, if we have the "car up" mode enabled, the whole map spins in circle around the car. You really notice how large the 17" screen is when the whole map is spinning in circles!

I'm convinced there is no relationship to the strength/weakness of the 3G signal, but I am a little suspicious of the new software version being solely to blame. The SC will tackle this for us next week when the car is in for a different reason.

SCCRENDO | 6 septembre 2013

Hasn't happened with my MS but previously had something similar this with a Lexus IS350. Kept losing the GPS signal but continued to navigate based some other sensor system. The map was way off but it kept going in the correct direction and jumped onto the nearest roads. Lexus needed to replace the GPS sensor and that solved the problem.

@Earlyretirement: The navigation definitely doesn't go my the fastest time. It tends to include as many freeways as possible and goes for the shortest route

Dripps | 8 septembre 2013

@ColoradoBlueS I had ranger look at my car for this same issue (I'm seeing same behavior you are in my 1 week old MS). He thought it might be antenna but the attempted fix did not solve my issue. I am also thinking it must be the GPS sensor. I've now seen about 4 of us with similar delivery window having same issue. Tesla must be aware there is a problem (not just me) by now. Waiting for their solution!

kmalloy | 8 septembre 2013

Thanks everyone. Definitely sounds like the same problem and it seems to be happening on the MS deliveries in the past 2 weeks. I have 5.0 - which was delivered with the car (never had an update since delivery). I have a service center appointment on the 16th for both squeaking/grinding brakes at low speed as well as the nav system problem. I'll update you all with whatever they tell me and would be grateful if you did the same.

Thanks again everyone!

ThorensP | 8 septembre 2013

We just took a drive up to Arcata from Fairfax, CA. We had the same problem. Sometimes it works, sometimes it doesn't I picked mine up on August 29 with 5.0.

Dripps | 9 septembre 2013

Has anyone has this problem fixed?

Devin B | 9 septembre 2013

I picked up my 60 on the 4th from the factory and this has been happening since the drive home. On the way home on the freeway it kept showing me jumping off the freeway and then back on, telling me to turn around, etc. On Friday it showed me way off the road driving through a park… I called Tesla and they told me to reboot the console the next time I stopped, by holding down both wheels, and I did but it still seems to have trouble.

MarioA | 9 septembre 2013

Just picked up an 85 a few days ago and the GPS system got me lost literally two minutes out of the service center. It has been completely unreliable. I did the reboot and it did not help. I consider it to be basically unusable. (Everything else about the car is great!)

Brian H | 11 septembre 2013

Recent issue. Seems to have arisen with 5.0. Maybe all that touchscreen spinning makes it dizzy.

Flick | 14 septembre 2013

I picked up my P85 earlier this week and also having the same issue, rendering maps and navigation useless - Waze on iPhone to the rescue.

SSFDON | 27 septembre 2013

I have had the same Nav location problems with mine. I have had the car a MS 85 with the Tech Package for about 4 weeks. It was in the Burlingame service department for this issue this week. They could not find a problem, they updated my firmware and told me there is no other fix currently available. The firmware update did not fix the problem. Oddly enough the loaner car that I had overnight (A P85+) did not have this problem at all, I drove the car on the same route that I always have location issues with mine. It happens to be along Interstate 280 between Daly City and San Francisco. I hope they find a fix soon!

mmutreja | 6 octobre 2013

I picked up my car yesterday and as soon as I got out of the service center it lost position. It keeps readjusting route and goes crazy trying to reroute. It even gets confused on the expressway. 3G signal was fine so it is something to do with the GPS and software. Mine came with 5.0.

Dripps | 6 octobre 2013

Interesting that they are still delivering cars with this issue. I am told my screen needs to be replaced and the part is on order. This doesn't give me much hope that they can supply the part soon. It has been a real inconveniene and yes, I can use my iPhone to get directions, but sure would be better if this worked as it should. My passengers are laughing at me and my near $100,000 car doesn't have working GPS.

donaldhmcclelland | 6 octobre 2013

Mine gets messed up frequently.. The most amusing (:-{) misdirection is when I am driving down the interstate and am told "You are on a dead end street. Please make a U-turn".

kmalloy | 6 octobre 2013

To close out this thread...I finally had my MCU (center display unit "Media Control Unit") replaced at the San Diego Service Center and this definitively fixed the problem. Anyone who has this problem should insist on the MCU replacement.

Fling | 7 octobre 2013

Just take the car to the service center and have them replace the touch panel. At least you get to test out the P85+ loaner which is a great trade off while the car is in the shop.

ColoradoBlueS | 7 octobre 2013

There are posts elsewhere

that the OTA software update that is coming soon may help minimize the problem by disabling the input from the gyro (hardware supposedly responsible for the odd behavior). Our local service center suggested that the update may be pushed out in the next week.

I have asked for clarification about what the "true fix" will be. Perhaps, in the longer term, the gyro may be able to be replaced without replacing the full MCU? Don't know if that is practical, but the MCU is an expensive part so it would seem to be in Tesla's interest to find a more cost effective route to the "true fix" if one is ultimately available.