Forums

Bluetooth Problems?

Bluetooth Problems?

Is anyone having trouble with their Bluetooth? I have an iPhone. Just downloaded the latest operating system updates. Even downloaded the remote Tesla App. Oddly, my phone works just fine in my 2012 BMW X5...bluetooth is great. But I can't get my MS to recognize the phone?! The same problem was occurring when I picked up the car, but we quickly surmised that my phone had an old operating system, and was probably just in need of an update. Even at that point, I interjected that the phone worked fine for my X5, so it seemed strange that the MS was having a problem. So now I've upgraded, and am still having connectivity issues. I've tried to reboot, turn on/off, etc. Can anyone provide any insight?
Incidentally, still, by far, the greatest car I've ever driven!!!!!!

jtwxlii | 13 septembre 2015

My Nexus 6 with the latest software seems to have a terribly weak BT signal as it drops out all the time while streaming audio...seems to be an antenna issue since when I grab the phone it stops dropping out. Anyone else have similar issues? It seems to be new. Also seems to minimize after a reboot of the screen.

TeslaTap.com | 13 septembre 2015

Bluetooth is on the same band as WiFi, Drones, Microwaves, cordless phones and countless other devices. It may be an interference problem, or the Nexus antenna is against some metal object. Check if the problem occurs at one location (likely interference). If it works fine if you lay the Nexus in the passenger seat it's likely an antenna placement issue.

rhbohl | 27 novembre 2016

Since loading Ver 8, I have a recurring glitch with my bluetooth audio. When starting the car after a "night's rest," I cannot get the audio from my iPhone to play through the car. However, the bluetooth connection is present, as the console screen shows the sketch corresponding to picture on the iPhone -- it is just the sound that doesn't come through. Tesla on-the-road help said they did not know of the glitch. I've tried rebooting the car, the iPhone, the bluetooth link, but nothing solves the problem consistently, but eventually -- after 10 or more minutes of effort -- the sound suddenly starts working.

Any similar experiences? Solutions?

paulfgoode | 27 novembre 2016

Yes. Just the other day. I did the same as you. I disconnected then reconnected phone via Bluetooth several times to no avail. Album cover of track playing shown on console but sound only from phone. I could stop and start the track via console. Only no sound. I rebooted console with no results. Activating Siri via phone I could hear her acknowledgement tone through the cars speakers. Ending Siri I could briefly hear the audio but then silence. I left the car for 40 minutes or so and everything returned to normal.

I've only resorted to playing music via iPhone because the USB support is worse now. Most times the USB must be loaded by the software which takes as long as 15 minutes. Even if I e exited for only a few minutes. Other times it is loaded and on last track played even if the car has sat overnight or longer. It's lost my favorites list twice. I now just let it play tracks randomly. But it's also replayed 10 or so tracks in the same order on different occasions. I have to skip forward to the first new track before it randomized again.

All of this has taken a large part of the pleasure of driving the car. Being the mobile refuge that it is.

SCCRENDO | 27 novembre 2016

@Paulfgoode. May be a dumb question but did you try deleting the old bluetooth connection from both phone and car. Besides the two screen car reboot did you shut off and restart your phone and set up a new bluetooth connection.

SKH90D2016 | 28 novembre 2016

I have had the same issue.......rest set phone and car to no avail.....

TeslaTap.com | 28 novembre 2016

With bluetooth problems, a reboot of the phone is often the best starting point. iPhones seem to be a little worse than Android, but both can get into weird states where the bluetooth phone hardware needs to be reset. Turning just bluetooth on/off does not seem to reset the hardware.

RichardKJ | 28 novembre 2016

I got 8.0 and iOS 10 about the same time and started having lots of bluetooth problems. It was unclear who was at fault. Mostly the car said the iPhone audio was connected but not the phone (for calls). I did not try the audio. It took lots of rebooting and delete/reconnecting to get it to work only to have it go away again the next day. Finally when I got iOS 10.1, which reportedly fixed some bluetooth problems, the phone-car connection stabilized.

Pages