Electronics Issues this morning w my Model S

Electronics Issues this morning w my Model S

I left my Model S on the street overnight last night on the dead end street where I live w about 200 miles of charge (though I know folks are told to leave their cars plugged in whenever possible). The temperature dipped down to about 43 degrees.

This morning I hopped into the car to run to a favorite coffee shop and immediately could see bunches of little issues with the computer system:
1) When putting the car in reverse, the rear camera would not automatically show on the display
2) I could not tune to any FM radio station (or get any audio to come from it whether in HD radio or not)
3) Blue tooth streaming of audio played with excessive choppiness if at all
4) No SFX on turn blinkers or hazard lights
5) My location on Google Maps could not keep up with my true location w/o being stopped and pressing to center the location of my car in the middle of the map
6) Unable to adjust the air suspension (it is greyed regardless of being in park or not, with brakes supressed or not).

I turned the power to the car completely off and back on again and cycled through the problems listed above that still persisted. I returned home and parked the car in the garage and plugged it in to my 240V plug there.

I hope the problems disappear when I check the car later on today -- but I'm a bit concerned.

Has anyone else experiences any issues like this or have any information about diagnosis or treatment before I call up Tesla (or anyone from Tesla reading this and know anything?).


david | 29 décembre 2012

Have you tried rebooting the displays?

Hold down both scroll buttons on the steering wheel to reboot the 17" display, and then hold down both top bottons on the steering wheel to reboot the speedo display.

hoffscot | 29 décembre 2012

i have repeated sporadic almost random software issues. when cold the other day the 17" display did not talk to the dash display, charge port would not open, daytime/nighttime auto setting not recognized. rebooting does help, usually. I'm running 4.1 but presume that all the annoying software issues will be fixed in first quarter '13. As said here before - we are the early adopters...

pbrulott | 29 décembre 2012

First time I hear this DLPrager.

Doesn't seem temperature related as 43F is pretty warm to have any impact on electronics. I plan to leave the S in temperature way lower than that. Down below 0F. Good luck

b.lafuente | 29 décembre 2012

Thanks for the advice on how to perform those reboot sequences. I rebooted both displays and as far as I can tell without driving the car and further, all of the problems seem resolved. Thanks again.

Jewsh | 29 décembre 2012

If we put the car into sleep mode, does it fully turn off the two computers? Would that help prevent this problem even if it's less convenient to wait a few moments?

b.lafuente | 29 décembre 2012

It seems a hard reboot will address most computer glitches quite quickly (as I experienced just this morning thanks to Dave's advice), but it isn't all that easy to do.

Selecting to turn the power off doesn't seem to do much more than put it into a light sleep mode. I've even turned the power off because I wanted to wipe down the 17" display w/o worrying about the touch screen responding to every nuance of the cloth. Unfortunately, the slightest touch on the display reactivates it immediately.

sergiyz | 29 décembre 2012

turning the power off preserves the state (think sleep function on your laptop), rebooting clears everything.

Larry Chanin | 29 décembre 2012

"I left my Model S on the street overnight last night on the dead end street where I live w about 200 miles of charge (though I know folks are told to leave their cars plugged in whenever possible). The temperature dipped down to about 43 degrees."


Do you happen to recall what range the car displayed in the morning?



Wayne3 | 29 décembre 2012

@DLPrager, I experienced the lack of audio you describe a few days ago when I was in a hurry to make a short errand. At the time, I attributed it to attempting to "start the car" (i.e. step on the brake pedal) before both displays fully came up. Can you recall whether that might have been the situation in your case as well?

tvntesla | 29 décembre 2012

I had a power glitch while charging (the NEMA 14-50 plug was loose when I wiggled the cable). There were a number of rapid clicks rattles in the car and at the charging port, then few seconds later, everything went dark, just like when you yank the power cord from the computer. There was no reaction to the key fob, no light, no display, completely dead. Luckily the door was still open, so I attempted the reboot sequence. Nothing happened. I retried holding the buttons longer and finally the car came backup, everything reset. Wow. So I now make sure that the power supply cord is not loose and when I plug and unplug, I do that with a quick action, no half way slow motion. I don't know if the computer has a watch dog timer to reboot itself after a crash or not, but I could imagine that if the car is lock, the only way to resolve is to call Tesla.

DanD | 29 décembre 2012

Holy mackerel. This is scary.

Robert22 | 29 décembre 2012

I have experienced some of the issues you've mentioned after flipping the range button on, which powers down the displays and reduces the efficacy of climate control as described in the 4.0 release notes. The car seems to be "groggy" and require a bit more time for full executive function to return despite display screens that appear fully "booted up". Full functioning of the radio with channel display can take up to a minute. I'm already on the road before my talk radio station suddenly springs to life. It will probably just require some tweaking of the wake-up algorithm.

Volker.Berlin | 30 décembre 2012

Holy mackerel. This is scary. (DanD)

Yeah. And it certainly wouldn't happen in a Maserati! :-P

vouteb | 30 décembre 2012

Its not a perfect computer yet

haansberger | 30 décembre 2012

Electronics can give you problems in all cars. My wife drives a Mitsubishi Outlander and we had it in the garage a week ago because the anti slip system showed a red flag and the engine hesitated every now and then to start smoothly. Turned out to be 2 faulty sensors : one on the steering axel transmitting wheel position and another on the engine cam passing it's position to the starting system. Two small sensors but a final bill of almost 2000$ due to the amount of labour and "collateral " parts needing to be replaced. I would say a simple reset is something I would prefer any day if that fixes the car !

dstiavnicky | 30 décembre 2012

I saw a similar issue when heading out on a test drive at Tesla Toronto. No matter what the rep did he could not get the car to unlock it's doors. It seemed confused.
Not a great way to start the demo...

He finally did something with the key that rolled down the windows half way, reached in, got in and pressed the 'unlock all' button on the screen. The car came back to life immediately.

With a stomach full of koolaid this didn't seem to add any hesitation to me making my reservation. I can't help wondering what I would have thought if I had a negative vibe of the brand to start with?

Hmmm... is it possible that Telsa has us under some kind of Jedi mind trick? Maybe that's where the Tesla grin originates!

Volker.Berlin | 30 décembre 2012

Reality distortion field? Does that sound familiar...?

stevenmaifert | 30 décembre 2012

I've experienced a few electronic oddities too. One required a hard reboot after the 4.1 update, the others self corrected. The most bizarre was the turn signals. The right one functioned normally, with a steady interval between blinks, the left was totally random, almost like it was sending Morse code. This was in the evening. I locked the car, let it sit overnight, and in the morning, both operated normally. Chalk it up to the growing pains of being an early adopter, but I hope TM gets all the software kinks worked out before they really start pushing the car to the mass market, which may not be so patient.

Brian H | 30 décembre 2012

The birth pangs of cartificial intelligence?

sbern18 | 30 décembre 2012

Had same issues this am after parking underground in garage without charging. I believe it's related to not charging, not the temperature outside. Fixed with screen reboot.

jolinastar | 30 décembre 2012

Looks like I'm in for quite an adventure when my march delivery comes up! I'm game.

stevenmaifert | 30 décembre 2012 - Maybe they will have a Ctrl+Alt+Delete button on the steering wheel by then :)

dtich | 30 décembre 2012

also, don't forget in the event of a power outage/locked-out situation, you can place the fob at the base of the passenger windshield wiper and press and open the passenger door. according to the manual, haven't tried it. page 30.

this may not work in your situation, maybe only for dead fob, but i don't know....

dstiavnicky | 30 décembre 2012

Hey Volker, you are right! I recognize it now! (I used to work at Apple...)

It is a reality distortion field!

docdac | 31 décembre 2012

I had the same problem tonight, 12/31. Backup camera did not display in reverse, radio had no sound and could not manually select channels (XM, FM, AM), and Nav would not stay up with current location. I have software 4.1.
I rebooted the two displays, as described at the beginning of the thread, and that fixed everything. Kind of glitchy, but at least I know the solution now.

one2mark | 31 décembre 2012

@docdac -Same thing this afternoon as I left my office. Rebooted and everything works fine. I love this car more every day!

aa012a | 31 décembre 2012

Has anyone called TM to report these issues (sleep vs. glitches)?

MrB | 1 janvier 2013

I had an issue this morning with my Model S, drove to Santa Cruz and noticed about halfway there that the energy meter wasn't updating (the rated range was), and the tip counters and total mileage where not moving either. Drove about 30 miles that didn't register on the odometer. I called tesla roadside assistance, the rep I spoke to told me to reset the main display and the driver display, and how to do so.

After pulling over I reset the main panel first. It now showed a warning asking me to contact Tesla for service. I then reset the drive displays. After this the odometer and trip counters and energy meters started updating again. Later this afternoon I reset the main display a second time and the service warning went away.

Very odd, given that if I hadn't reset the odometer wouldn't have updated no matter how much I drove!
(Running 4.1 but never hard reset before since the car was delivered with 4.0) | 1 janvier 2013

I got 4.1 installed last night. Had to come to a quick stop with a short cycle light- then got a warning that stability control and traction control were offline. Pulled off the road & did reset--warnings went away...

tvntesla | 1 janvier 2013

Just feel like I am driving a cellphone (software upgrade, battery symbol, 3G symbol, etc.) I rebooted my displays today, since the temperature showed -- instead of digits and the Trunk button was greyed out even in Park mode and the display was in Night Mode although it was bright sunny day outdoor. Everything came back working normally after reboot. I am used to reboot my cellphone when there is something that shows up as bugs, but I am not used to rebooting a car (yet) :) | 2 janvier 2013

This is not a 4.1 problem since I'm running 4.0 and I had the same issue last night.

1. No audio sounds
2. No reverse camera when putting the car in reverse
3. When charging, the charging screen on the 17" console would not update, only the dash would update.
4. Some buttons that should not be greyed out, were.

I rebooted both the 17" screen and the dash display. Everything seemed to be working correctly thereafter.

Max M.

tornyim | 2 janvier 2013

I also had the exact same problems yesterday after the car had been plugged in and fully charged:

1) No audio on FM/AM radio (internet radio worked but was breaking up).
2) Reverse camera did not come on automatically.
3) No audio on turn signals.
4) Suspension and Traction Control buttons were disabled when they shouldn't (in Park at a standstill with all doors closed).

Tried the Turn Off Car command via the console which didn't do anything. Left the car parked without being plugged in for about 3 hours, came back and everything was back to normal.


cerjor | 2 janvier 2013

Reminds me of Microsoft ME or Vista. Let's hope for XP or Win 7. | 2 janvier 2013

My issues of the day were:
1) Auto headlights on in bright daylight
2) Regen buttons greyed out (but regen clearly working)

I shut off the headlights manually & will check again tomorrow.

DigitalSavant | 2 janvier 2013

The only annoyance I have encountered thus far is a buggy charge port door. Sometimes the indicator flashes in the dash display that the charge port is open, when it's actually closed. Also, there have been a couple of instances when I park the car and press the button on the charging cable to open the charge port and nothing happens. One time that happened I was able to open the charge port from the touch panel control screen. The second time it happened, nothing would open the charge port until I did a "ctrl-alt-del" reboot. I'm not sure if I should call Tesla to report it as a problem or wait until warmer weather to see if the problem just goes away. Since a reboot seems to make it better, I tend to blame software more than hardware.. but who knows?

GLarwill | 3 janvier 2013

oh gosh, this is starting to remind me of an old joke...

See #3 and #9.

bbmertz | 3 janvier 2013

My car is running v4.0 and I have experienced the following minor bugs:

1. Auto headlights remain on in bright daylight
2. Bluetooth music stopping intermittently when playing from iPhone 5 (requiring me to re-press play button)
3. Navigation destination off by a few blocks when inputting my work address in northwest LA
4. XM radio cannot be activated (most likely an antenna issue)

Initially I could not save web browser bookmark favorites nor store navigation address history, however this was resolved after I rebooted the 17" screen. Nevertheless, I am generally pleased with the electronics/performance of the car and expected a few minor bugs as an early adopter.

DigitalSavant | 3 janvier 2013

@GLarwill: That's hilarious! The car is so fun to drive, I'm sure many people will just accept the fact that they will need to reboot their cars from time to time. Personally, I would kill to have my car's display "PC LOAD LETTER" just once when I get in to drive. :)

rlpm | 3 janvier 2013

PC LOAD LETTER? What the #%^* does that mean? ;)

PaceyWhitter | 3 janvier 2013


got a chuckle, it is funny that #12 is now true for most new ICE cars

majgill | 3 janvier 2013


I had to do reset also two days ago twice as my signals stopped working and rear camera stopped mornig. But today morning something new happened the moment i sat in the car and it gave me warning to contact tesla and some errors quickly showed up on odometer that 12v low battery and i had 198 miles left in the car and everything went blank and doors were opening. Called tesla service and they said service engineer will contact me once they open up at 9am pst. Luckily i still had my lease car which i am returning in feb so jumped in that car and dropped my kids to school and now i am waiting for their call what happened as they said they will have data before car went to sleep. I will update you guys what will be the outcome.

mohan | 3 janvier 2013

I had multiple issues, similar to this. I will detail them as much as I can remember.

Problem 1:
On 31st, I drove around for a while in the morning, came back home in the afternoon, plugged in to get ready to go for a party that night. At around 7pm, I unplugged (car almost fully charged), and got in the car getting ready to go on the road. The climate system started blowing cold air, and being in Bay Area, I thought that was odd. I looked at the dash and it reports that the temperature was 85 degrees (the temperature outside is around mid forties). The climate system temperaturs was set at HI. The temperature started going down slowly while I was still in the car port, but not enough for the heat to kick in. It took about 15-20 minutes of driving for the sensor to report correct outside temperature approximately.

Problem 2:
On 1st, headlights being on during the broad day light. I am not sure where the light sensor is in the car, so I wasn't sure if it is just dirty. Does anyone know where the light sensor is? It seems like there are two different ones, one for the head lights, and one for the internal dash/display.

Problem 3:
On 2nd, I had multiple issues. In the morning, I got in the car, the dash was on, but the 17 display was totally off. I waited for the big T to show up, but nothing. I touched the display, and it came on instantly. I thought, "it booted but it did not turn on, no biggie!" I have the habit of checking for suspension (it needs to be Very High) for me to back out of my car port on to the road over the curb. I saw that the button is greyed out on Standard. Did not know what to do. UI seemed to be fully responsive, except that button was greyed out.

I carefully backed out and started driving. I turned on the blinkers, and no sound. Then I started worrying, and rebooted the 17 inch display. Seemed to have fixed the suspension button problem and blinker sound problem.

In the afternoon, I noticed when I returned to the car, the door handles did not extend. I used the key, then they extended. So, I thought, "no biggie." As I was driving, I noticed that the energy app graph is not being updated both on dash and the display. When I parked and stepped out of the car, I noticed that the dash went off, but the display remained on. I used the key to lock the car, but the big display won't turn off. I got back in the car, rebooted both the dash and the display, everything went back to normal.

My guess is that the boot sequence in the morning had some problem, and therefore, there was an incomplete boot. My rebooting only the display probably fixed some, but broke others. I wish TESLA reports that there were problems during the boot sequence, and give me an option of complete rebooting.

These are way too many problems in 4.1. Hope they have a better way of testing.


mw | 3 janvier 2013

The Model S is several computer systems with wheels! Welcome to the technology shift in transportation. I have had some minor issues that all seem to resolve with the reboot sequence so I try that first. If issues persist I call my assigned service center (chicago - I'm in Ohio). They will open engineering tickets for anything they don't have an answer for. I suggest anyone having issues report them to their service center so that Tesla can work on them.

DigitalSavant | 3 janvier 2013

@rlpm: Ha ha! Yes, EXACTLY! :) :)

b.lafuente | 5 janvier 2013

Interesting updates to this thread since I originally posted it about a week ago (love the PC LOAD LETTER heh).

Since my original post, I have had my car exhibit the same symptoms from the original post in this thread and they manifested themselves after having left the car parked outside overnight. I do wonder if the car just likes to be plugged in or otherwise likes a clean and complete reboot. The most recent time I found that when I rebooted both the dashboard display and the 17" display, everything returned to normal.

Good to collect as many stats on this kinda stuff as possible. Hopefully more and more software updates are all that are required to make the car perform and function better and better (not to mention perhaps have it give itself a clean reboot every day and/or provide a better ctrl-alt-delete).


majgill | 5 janvier 2013

Called Tesla on Thursday as car won't srart and it was showing alot of errors and tesla sent ampm towing and they took the car. Got a call from Tesla Service center that seems like problem with 12v battery and it needs to be replaced so they said once they replace that battery then they have to program or rewrite the latest firmware ..Called friday 3pm and asked them if i can pick up the car and i was told as i called they got the old battery out and they are putting new one . Got a call at 6pm that they are having issues putting firmware on the car so we won't be able to give you the car today and we will call you on saturday even though service center is closed but there is someone who is working on my car. Waited till 1pm and i called them i was told we will check and get back to you! Someone called me at 3pm and left a message we are so sorry we are really having trouble putting firmware on this car and after that we need to put some miles on the car to make sure it is doing what is suppose. Oh man i hope they can fix this thing its been 3 days plus and all my friends are asking where is your car we want to see and i said the same thing i am also want to know what is going on! I just got the car two weeks ago!

mklcolvin | 5 janvier 2013

Wow, you guys are scaring me! I'm due to get my S within the next few weeks, and I don't want to have the problems that you're talking about... XP indeed!

rwang | 5 janvier 2013

Common issues in the morning...temperature independent...

1. 3G signal not working
2. Trip not working
3. 17" not registering a temperature but the dashboard is
4. Turn signal sound off
5. Rear camera not functioning

Model S p85

Mark K | 5 janvier 2013

Although they are annoying, these kind of early release issues with any software-intensive product are not unusual. Over the next quarter, you can expect most of the big ones to be ironed-out.

One thing that can help is for TM to have a crash log that can upload an audit trail of the conditions that lead to the anomaly. Lots of software (like browsers) has this, and we use this technique all the time on our products. It makes reproducing the failure very easy which greatly simplifies debugging. With the 3G link, your car can report all the details of a failure automatically without you doing anything.

Maybe TM already has this, but if not, it will really help organize the bug reports and speed up the corrections. It also can detect subtle problems (that users may not even notice or report) before they become visible enough to affect operation. In essence, TM can know exactly what happened while sparing you the hassle of providing a detailed description.

Majgill - really sucks to have down time when you're all excited about your new toy. It sounds like TM is working overtime to fix it but hasn't found the cause yet. Reminds me of an experience with one of my brand new Mercedes SL 100K sports cars where a central electrical failure killed it. 8 weeks into owning it, I lost my car for a month.

Mercedes stood up and loaned me another one while mine was fixed. If yours goes more than a few days, I think TM should do the same to bolster their reputation and cure the blues from any early glitches.

They are truly on a roll with this intro, and they must manage the refinement and correction process skillfully to protect their customers' satisfaction. Nothing should diminish the extraordinary success they've earned.

Robert22 | 5 janvier 2013

No 3G bars after a cold night in the garage. Slacker voice control working so I've got connectivity just no indicator.