Not recognizing flash drive for TeslaCam

Not recognizing flash drive for TeslaCam

I bought a wireless charger and got that set up to work easily. When the most recent update came out, I decided to install a flash drive for the dash cam and new security features. I partitioned the drive and formatted it properly (FAT32). I've checked and the file is TeslaCam not TESLACAM. I used the usb cable splitters that came with the wireless charger so I would have room for the flash drive. The car recognizes the music folder on the flash drive, but it is not displaying the camera icon. Does anyone have any advice? I tried installing the flash drive directly into the usb drive (bypassing the cable splitter, in case there was a problem there), but the car still did not seem to recognize the TeslaCam folder. Tnanks. Linda

Magic 8 Ball | 24 avril 2019

Try an unpartitioned drive with just the camera folder.

kaushal | 24 avril 2019

If you are partitioning the drive, make sure to use MBR partitioning scheme and not GUID

Also, there needs to be a directory in the root of the drive with the name TeslaCam

TARS92 | 24 avril 2019

Mind sharing the exact flash drive you have? Could be a speed issue.

kaushal | 24 avril 2019

I have exactly this

I initially got a "Volume size too big for FAT32" error when I used DISKPART in Windows 10, but, "Fix #1" from the following site worked.

jjgunn | 24 avril 2019

Use TeslaTap's article - it's excellent for all techie skill levels

johntran | 24 avril 2019


It's possible that your flash drive was format incorrectly. Maybe try formatting it again with the "GUIformat"app. Here's the link to it:

Pants | 24 avril 2019

Mine had been working flawlessly until I was updated to 2019.8.5 at a service appt yesterday. Todoay I noticed that I've got the grey X even though the drive is fine on my computer - even after "repairing" it with a diagnostic tool

- and wouldn't you know today - i get a notification that sentry mode alarm was activated. The first time i didn't actually have an operational drive in there. -

I'll go for the full re-format next.

I've experienced a ton of regressions in the 2019.8.5 build.... but I suppose that's for another thread.

2015P90DI | 25 avril 2019

Had the same issue after the last update. I put the flash drive in my computer, with file explorer, deleted all of the files on the flash drive, other than the "TeslaCam" folder. Deleted the cache items too. Put it back in and it worked.

Don't know if it got full and stopped recorded and if it will happen again when it gets full again or if the code just changed with the last updated and it wasn't able to automatically push out the old coded files. Time will tell. But, that's what worked for me.

derotam | 25 avril 2019

Don't try to use windows...yes you can usually technically get it done from the command prompt but it is excruciatingly slow because Microsoft doesn't want you to do it...get a 3rd party app to do it.

nquibar | 24 mai 2019

im currently using Sandisk Ultra dual USB drive 3.0. it is already formatted Fat32 by default. I plug it into the front usb ports and no teslacam icon. can someone help me through this?

JAD | 24 mai 2019

Did you make the TeslaCam folder?

rob | 25 mai 2019

Im using Samsung 128GB formated on a Mac using GUID partition map. These did not work out of the package and even after I formatted them. To get them to work I had to change from MBR to GUID.
I don't think the portion map is that important, but what is in the map that was keeping it from working.

Here is a good article about USBs for the Dashcam.

damiani | 28 mai 2019

why does the file name TeslaCam on memory drive keep showing TESLACAM even though I typed it correctly

kpl2544 | 28 mai 2019

My flash dive was working perfectly. Today my car stopped recognizing the drive. I don’t have anything else plugged into any other use plugs. I cleaned out the TeslaCam folder but no help.

kpl2544 | 29 mai 2019

Somehow. My flash drive got corrupted while plugged into the USP port in the car. I was able to restore it in my laptop and my Tesla 3 now recognizes it again????

Syed.Hosain | 29 mai 2019

If you have two partitions, the FIRST partition has to be the one with the TeslaCam folder in it. I discovered this after recently adding a very large drive. Bought the SanDisk 500GB external and have two partitions on it - first is for the dashcam and the second is for the music files.

I love that the FLAC format music files (uncompressed) are handled properly, all the way up to 192k /24bit and sound really great!

M3NOICE | 29 mai 2019

I have the wireless charger and the unpartitioned drive plugged in one of the splitters. The dashcam icon was ON and OFF every other drive.
Plugged the drive directly into the dash USB plug, and no more problems.

Seems like the splitters may lose connection and the dashcam software drops the drive.

Frank99 | 29 mai 2019

kpl2544 -
I've had that problem also - I tried using a 32 GB Samsung Pro Endurance micro-SD card, but three times in a row it worked for 3 days then got corrupted (had to reformat). So, I bought a new 64 GB Samsung Pro Endurance card, and it did the same thing. So now I have a Samsung Fit USB Flash Drive installed, and it works fine.

The Dashcam and Sentry mode features are not really ready for use - they're tremendously buggy, difficult to use, don't handle errors, and have compatibility issues with some flash. I love the fact that Tesla upgraded my car with them after I bought it, but I'm frustrated that they're so terrible when they have such promise. I figure sometime in the next couple of months, one of the Tesla updates will fix 90% of the problems (and sometime a couple of months after that, another update will fix 90% of the problems that still exist). In the meantime, I grit my teeth and try to keep it working.

Just this weekend, I got a chip in the paint from somebody in a white truck parked next to me opening their door into my car. I pulled the flash drive and reviewed it, hoping I'd find a license plate. Sentry mode had gone off and recorded it's 11 minutes of video - in files that were all 0 bytes long. Sigh.

rcs | 10 juin 2019

I thought I would post his as I hadn't seen it anywhere and tried a few things on how to format using Linux / Ubuntu.

The instructions here on formatting fat32 worked for me, specifically it seems important to use fdisk to create the partition table. Other ways did not.

2. Create the 'TeslaCam' folder as normally would after above complete.

Hope it helps someone, it took me several hours of trial and error.

SnoWaterSkier | 18 janvier 2020

I need to recommend that Tesla sell a pre-formatted Thumb drive that is plug and play. I experienced similar issues and spent several day's attempting to achieve a format that my Model 3 would accept, re-booting the car in-between unsuccessful attempts. It's not clear to me why it is working now and not sure how long it is going to last. Modern technology at its to love the challenge :}

Lonestar10_1999 | 18 janvier 2020

@SnoWaterSkier- I second that motion. Tesla should sell or endorse a game controller that is fully compatible with the entire Arcade.

FISHEV | 18 janvier 2020

"I need to recommend that Tesla sell a pre-formatted Thumb drive that is plug and play."

Should really come installed in the car considering Tesla has made it so problematic for owners to get it working.

My USB stopped working after last update 2019.50.x.x. I tried erasing and reformatting per several video instructions and it still doesn't work anymore.

I ordered this one and should have it today per USPS and give it a try. | 18 janvier 2020

Bad Idea to build in the flash drive. Small ones may only last a few months, while large ones - 128 GB size should last a year or two. Flash drives wear out, especially when doing massive continuous writes as occurs in any dashcam. More details here:

Also, cheap no-name drives tend to fail a lot quicker than better drives. The no-name drives and ones with brand names you have never heard of before are the worst - often with very short lives. There is a reason some are so cheap. Even a good 128 GB drive can be had for under $40, so paying for quality is not that big a deal.

Tesla2018 | 18 janvier 2020

I got a message that my thumb drive wasn't working anymore on the screen. I took it out and put it in my computer and it said something that it was write protected.I've found out that thumb drives only have a limited number of times that they can be written over, but mine was about a year old. One time I parked in a stadium parking lot and there were over a hundred incidents reported so I think that might have been what killed it. I installed another thumb drive that I have and it's been working fine for the last week. I never erase my old one monthly as some have suggested. Just wanted to give some people a heads-up in case they had the same problem | 18 janvier 2020

What usually causes the write-protect issue is pulling the drive without first turning it off. If you pull the drive in the middle of writing, as power fails to the drive it can randomly write anywhere on the drive. There is a one-time write-protect bit, that if written to, cannot be undone.

Before removing the drive, always turn it off, and wait 10 seconds or so for it to stop writing.

curenssy | 16 avril 2020

i have 2 issues and any help will be greatly appreciated.

i have a 32gb scan disk flash drive and my Tesla recognizes it and i can play music but the dash cam icon does'nt come up. It only comes up when i put the car in park.

Secondly i have a 128gb scan disk flash drive and I've formatted it to fat32 i have the folder name TeslaCam and i don't get the dash cam icon when trying to record either, now here's the strange thing and let me know if i'm doing something wrong but the Tesla recognizes the 128 flash drive but as soon as i put all my music on it the car doesn't recognize it anymore.

this is frustrating why can't this just be plug and play.

FISHEV | 16 avril 2020

curenssy | April 16, 202 "this is frustrating why can't this just be plug and play."

It can be.

Rosie1 | 16 avril 2020

I had the same issue as the OP. I I just rebooted the car and it works fine now. I also had the rear view camera go black with the steering lines visible. This too was fixed with the reboot. I’m now getting in the habit of rebooting after every software update.

httran26 | 16 avril 2020

Put your music and teslacam on separate USB drives. I use a cheap USB hub. Have not had any problems

EVRider | 17 avril 2020

@curenssy: If the car plays music from a USB but doesn't activate the dashcam, it means you don't have a TeslaCam folder on that USB. If you did, you would only get the dashcam, no music. I'm not sure what the issue is in your case, but use you computer verify that everything is set up and formatted correctly, and that there is free space on the dashcam USB (you might have to empty the trash folder depending on your OS).