Forums

WiFi Shuts off

WiFi Shuts off

When my car goes to 'sleep' at night, it loses the WiFi Connection. Anyone else have this problem?

DallasTxModelS | 11 janvier 2014

Is yours set on deep sleep? They told me that is not for daily use. Only to preserve power when you are on a trip and are parking overnight where it can't be charged you can put it on deep sleep and keep it from using power to heat and cool the battery or the inside of the cabin.

J.T. | 12 janvier 2014

@Dallas Are you saying that for normal everyday use we shouldn't be using the energy saving mode?

I thought that was what stopped the vampire drain of 8-14 miles at night.

David Trushin | 12 janvier 2014

Just out of curiosity, hoew do you know

Dwdnjck@ca | 12 janvier 2014

My car asks if I want to be connected on startup each morning. I wish I could tell it to stop asking.

AmpedRealtor | 12 janvier 2014

@ DallasTXModelS,

Energy Saving mode is not for trips or when the car is not plugged in. Energy Saving mode is used all the time in order to prevent your Model S from draining the battery while idle. It is this setting that reduces the vampire drain. You can certainly turn it off for normal daily operations, but then you are losing 8-10 miles per day in range to vampire loss and spending more electrons (and money) to feed the beast.

@ sdelucia,

I also am presented with the wifi nag screen every time I get into the car in the morning. It's quite annoying.

hotspark | 12 janvier 2014

I turn on the Wifi when I come home at night. when I leave in the morning, the WiFi is off. The car is plugged in all night long. I will reset the Energy Saving Mode and see if that helps.

rodhoffman | 12 janvier 2014

Mine is always connected after I put a booster in the garage. My guess is your signal is too weak. I also upgraded my router and it greatly improved speed. If your router is 2 years old - time to upgrade.

hotspark | 12 janvier 2014

I think the key is the Energy Saving Mode. I have switch it off while plugged in and will see if that solves the problem. Have New Router, and good signal in the garage.

rodhoffman | 12 janvier 2014

Mine is on Power Saving Mode all the time and when I power up it connects automatically with no screen prompts.

TeslaTap.com | 12 janvier 2014

@rodhoffman - Same for me. Works fine - no screen prompts.

I did add 35ft of cable from one of the antenna connection on the WiFi router to move the WiFi antenna to have it better placed in the house (and closer to the MS). It boosted the gain at the car by 15 db (a huge amount). I realize its sort of contrary to the whole idea of WiFi to run cables :)

dramingly | 12 janvier 2014

Mine disconnects automatically and I don't even get a prompt to reconnect when I start in the morning. Makes no difference, really, the 3g is fine for my purposes.

AmpedRealtor | 12 janvier 2014

I also have a strong signal in the garage (bars all the way to the top of the signal indicator), yet I'm still prompted to connect each morning. It's as if the car forgets after it goes to sleep. The annoying part is that I touch the blue button to connect, then the menu automatically drops down showing me all of the wifi networks to choose from, even though it tries to connect to my specific network. While this drop down menu is showing, putting the car into reverse results in no backup camera image on the screen until I touch the wifi signal icon to make the menu roll back up.

This is a minor, but daily annoyance.

TeslaTap.com | 12 janvier 2014

@AmpedRealtor (and others with the problem) - Since we all have the same MS software (5.8), could your router be preventing automatic re-connect? I don't know of such an option, but it would seem the only difference is the router not the car.

Do you use a hidden SSID (I don't)? How about the protocol you use? I use WAP2, but perhaps the older WEP has the problem? Just a few things I can think of to check.

wavehopper27 | 12 janvier 2014

If 3G is included, is connecting to wifi even needed except of course if you live in a no coverage area?

DallasTxModelS | 12 janvier 2014

@jtodman

Yep mine is set on normal and 5.8 firmware update. Mine charges to 234 everynight and turns off. In the morning it is normally on 233. I've never seen 8-14 miles loss. The coldest morning 13 degrees it was on 231 but my cabin temp was 68.

DallasTxModelS | 12 janvier 2014

@ampedrealtor

I've never experienced 8-14 miles of vampire drain.

hotspark | 12 janvier 2014

Turning off the Sleep mode solved the problem. Will only use when not plugged in.

DallasTxModelS | 12 janvier 2014

I read the release notes for 5.8 which said the new firmware has made the vampire drain almost not existant and that using energy saving mode will make it harder for Bluetooth, WiFi and app to connect.

hotspark | 12 janvier 2014

5.8 notes are correct...I sure found out the hard way. In my garage, plugged in, energy saving is off. Now my WiFi is working fine.

shs | 12 janvier 2014

My WiFi seems to connect when I drive into the garage (separate router there) and is on in the AM with no prompts when I start the car. My disappointment has been that I was expecting that with a WiFI connection (no cell signal at my home or nearby) I would be able to cache maps (Tech package). Maps of the area right around the house and driveway are there with WiFi in the garage, but the maps disappear within a quarter mile of the house, so if they are cached at all, they are not for a very wide area. Am I missing something other than map cacheing or course? Would this improve if I turned off energy saving mode?

DallasTxModelS | 12 janvier 2014

Mine stays connected all night. Someone asked why to have it on wifi, it says in release notes 5.8 priority for updates goes to wifi connected vehicles so if the doesn't matter to you I guess 3G is all you need.

Brian H | 12 janvier 2014

shs;
likely you have to be in range of your home wifi server to be able to cache.

shs | 12 janvier 2014

Thanks Brian, but I was expecting that while in the garage connected to WiFi it would download a wider area than the current map boundaries, like the whole county or state!. I can't see that just downloading the current display is "cacheing".

ChopinBlues | 13 janvier 2014

So with deep sleep turned off, why is there a vampire drain? My understanding was that if the car is plugged in, it draws the necessary power it needs for the electronics (wifi, heating, etc) from the power outlet, not the battery. However, I'm still seeing the vampire drain, even when plugged in, so perhaps this isn't the case?

Bighorn | 13 janvier 2014

@joes
The battery provides, and loses, power even when plugged in for some tasks ie electronics that are awake. Battery heating is powered by the outlet, if plugged in.

AmpedRealtor | 13 janvier 2014

There is nothing special about my router, the car automatically reconnects to my wifi when I pull into the garage. Only after going to sleep it prompts me to reconnect every time. I'm using a published SSID and WAP2 authentication. No other devices have issues connecting or reconnecting.

Oh well.

Captain_Zap | 13 janvier 2014

@joes - What battery pack do you have and what is the extent of your loss when in sleep mode and when you are not in sleep mode?

Please don't respond here. Instead, please create a new post or add to an existing sleep mode thread about your sleep mode concerns so that these people can continue troubleshooting their Wi-Fi issues.

TeslaTap.com | 13 janvier 2014

As for WiFi reconnect issues overnight, the only other thought is the Router itself. Please list your router vendor/model and state if it works or not.

Mine: TP-Link, TL-WR1043ND, Works fine

If we get enough responses as to the routers used, it might become apparent that one vendor's product has a problem (or requires a firmware update).

AmpedRealtor | 13 janvier 2014

Asus RT-AC66U

All my laptops and other devices have no issues reconnecting after sleep. Only Model S. No other issues with router with 16 other connected devices. It is a function of the car to connect to the wifi after waking, this is not a router function.

NKYTA | 13 janvier 2014

No issues here. Haven't got prompted to login in to WiFi since the 4.1 f/w days. It takes about 60 seconds to connect when I drive into the garage. The signal isn't super strong (Airport Extreme half a level above in my living room), but is sufficient. Currently on 5.8.4.

AmpedRealtor | 13 janvier 2014

Version 4.x did not have wifi capability, so...

NKYTA | 13 janvier 2014

@AR, yep, fumbled that. Meant 5.0.

AmpedRealtor | 24 janvier 2014

RESOLVED!

I sent a note to Ownership regarding my nag screen, they said they would look into it. I took my car to the service center to have my trunk liner fixed, apparently the service center already knew about my wifi complaint. They said they would test the wifi and let me know. When I picked up the car, they told me that it was working as designed and that there was nothing wrong with it.

However, now the nag screen situation has resolved itself! I don't know if the service center reset something on the back end, or if just a reboot of the car's computer resolved the situation. Anyway, happy camper here. No more nag screen!

LMB | 24 janvier 2014

(LMB spouse)

An old saying among my people: "When in doubt, reboot."

Mathew98 | 24 janvier 2014

@LMB - Are your people all related to R2D2?