Yelling at my Model S

Yelling at my Model S

Does anyone else have issues with their Model S not recognizing voice commands? I frequently find myself having to yell out my commands for my S to hear what I am saying and even then find it may not hear me. I have tried directing my commands to multiple different areas of the car and have turned the radio completely down, but still find it is very inconsistent with picking up my voice. I'm trying to determine if this is an isolated issue with my car, or if others have experienced this, and more importantly is their a suggested fix.

Thanks in advance,

kerryglittle | 27 juillet 2018

Shouldn't have to yell. Are your windows or sunroof open at the time? I always say if everything fails try a reboot.

Mathew98 | 27 juillet 2018

Did you try to treat her with kindness and respect? You know, more like a mistress and less like your wife???


Try pressing the command button for 2 seconds before speaking and keep the button depressed for another 2 seconds after the command.

wlhnlh | 27 juillet 2018

Windows are almost always up and sunroof closed as well.

@Mathew98; I didn't think I needed to keep the button depressed throughout the entire command. I typically press once, the status changes to "listening" and then I try to speak. Also I would say I am always asking respectfully right up until the time it fails, or does not recognize my command. If Tesla is logging what is said the entire time it could be quite humorous.

Mathew98 | 27 juillet 2018

Bingo. You need to keep the button depressed for the entire duration of the command.

RedJ | 27 juillet 2018

That’s not how I use it. I push it once to start taking the command (waiting for the beep to start speaking) and once again when I’ve finished. You don’t have to push it a second time, but then you have to wait for the car to recognize that you’re done speaking.

Boonedocks | 27 juillet 2018

Even with my southern drawl... :)- lmao.... my car never misses a word.

jjs | 27 juillet 2018

@wlhnlh I have the same problem. Both cars, 2013 Model S and 2016 Model S. They changed the way voice commands are recognized a while back. Originally you pressed and held the button. Now you should be able to press the button, wait for the beep, speak, then press the button to end.

If you try to hold the button during the entire duration, let us know how it works for you. I will do the same.

I have noticed that if I slow down (I don't talk particularly fast though) and carefully enunciate it reduces the number of times it misses the command. It also seems that it is looking for a key command first, (Drive, Navigate to, Play, Listen to...) before it will recognize anything else.

This is something that has always been an intermittent problem for me. In the past it was rare. Now it has grown to be quite frequent.

wlhnlh | 27 juillet 2018

Good to know I am not the only one and will play with holding the button on my 3 hour drive this afternoon. Thanks for the replies and suggestions.

carlk | 27 juillet 2018

It seems to work better in my S than wife's X which I rarely drive. I suspect there is some AI involved that remembers my habit or even my voice pattern.

Mathew98 | 27 juillet 2018

Try not to lead with "Beyotch, let's do this..."

jordanrichard | 27 juillet 2018

I too, since the last update, have been having problems with VC.

bishoppeak | 27 juillet 2018

You only have to worry when the car starts yelling back at you!

Mathew98 | 27 juillet 2018

My chair starts rocking whenever I start with the "Beyotch" command... | 27 juillet 2018

If you're not aware the microphone is in the center panel in the roof next to the rearview mirror. It shouldn't require any special orientation. There are actually two microphones, one to help cancel out adjacent noise.

If you find it works fine when stopped, but not when driving and you have the pano roof, if it is open, the air rush will interfere with the microphones. If closed, it's possible one of the rubber seals is not working and noise from that seal is interfering with the microphone.

I have a metal roof and very few problems (two cars, 2013 and 2016). Sometimes it doesn't quite understand an odd street name, but I chalk that up to not knowing how to pronounce it. Note that with the refresh S, the interior is a bit quieter when driving, so I suspect that can help too.

wlhnlh | 27 juillet 2018

I tested a few commands on my drive to lunch. Holding the VC button while giving the command worked flawless. I then tried it by just pushing the button and waiting for the beep and that worked as well, so will test again at higher speeds on the interstate later to see if there is in fact some wind noise interference.

Run4Waffles | 27 juillet 2018

Mathew98 | July 27, 2018
Bingo. You need to keep the button depressed for the entire duration of the command.

The need to hold the button done the entire time changed about a year ago.

It frees your hand up for other functions.


Mathew98 | 27 juillet 2018

I always have a free hand for other functions...


Tesla-David | 27 juillet 2018

5+ years and never had an issue with voice commands. However, my wife does, due to her Japanese accent.

MJP.75D | 27 juillet 2018

Mine worked flawlessly for two years until the most recent update (2018.26) — now, not so much. Hoping for a new update to remedy.

kerryglittle | 27 juillet 2018

I only press the button once and when it beeps I know it is listening. One thing though and I could be wrong, but if you are in a poor cell area that can effect it. I used mine several times today on a trip and never skipped a beat.