Forums

Any Tesla DashCam success?

Any Tesla DashCam success?

There have been numerous postings from people, including myself, who reported initial success getting the Tesla Dash Cam working with a FAT32 formatted USB Flash Drive with a folder \TeslaCam. But after a few trips, the drive gets corrupted and it no longer accepts recorded files.
My question: Is there anyone out there who is successfully using the Tesla Dash Cam day after day, on multiple trips, without it failing? If so, what make and model Flash Drive are you using, and how did you configure it so it does not get corrupted? Thank you.

varmahetal | 15 octobre 2018

Two days and counting. No issues.
SCANDISK 15GB drive formatted with FAT32.

gmr6415 | 15 octobre 2018

Yes to your question. I have had no real problems since formatting the USB drive.

I'm using a SanDisk Ultra 64GB. I formatted it on a Mac using the disk utility. I created the TeslaCam folder on the desktop and dragged to the empty, newly formatted USB drive.

Before exiting the car I hold the camera icon for 2 to 3 seconds to stop recording. I do the same before removing the drive if it's active.

I have noticed that every time I initiate recording it creates a file outside of the folder.

FSCK0000.REC
FSCK0001.REC
FSCK0002.REC
FSCK0003.REC

and so on.

The one issue I am having is when tapping the camera icon initiating the function to save the last 10 minutes from being overwritten the file created (saved-front-2018-10-14_10-10.mp4) doesn't seem to be a readable file. That said, the ten 1 minute segments prior to it are renamed to saved from recent, so I'm assuming that rather than creating a compiled single 10 minute segment it's simply marking the prior ten 1 minute files as saved, so they won't be overwritten.

I think this is more a learning curve than a glitch.

All said, I also had the same results using a micro SD card adapter and a 32GB micro SD card.

dedgar57 | 15 octobre 2018

I'm using a Sandisk 32 GB USB stick formatted with FAT32. It seems to be working after I scan and fix when it is inserted in the USB port on my Windows LapTop. Not sure what that's about. Is there something I'm doing wrong? I am pausing the camera before I remove it from the USB in the Tesla and can anybody tell me how to change the time of recording? I guess it's not a big deal,but It's out about 4 hours. Is there a setting? Clocks on the Telsa and Laptop are good. Thanks

Alex_SD | 15 octobre 2018

Everything seems ok with a SANDISK 16GB USB drive. However, unplugging the drive seems to corrupt some files because the Windows 10 machine I'm plugging into gives a warning about errors on the USB drive. I run the disk doctor to fix the issues and everything is back to normal. I do reformat the drive each time I unplug it to be safe..

I do recommend leaving the USB plugged in and not playing around with it too much. Also, after unplugging it, it is better to reformat it before reuse.

@gmr6415
yes, the "save" action actually renames the last 10 one-minute files with the word "saved". It also creates a .REC file at the root.

mehingle14 | 15 octobre 2018

Is there any benefit to having a larger flash drive? Would a 128 or a 256 GB potentially record more video?

george.keith | 15 octobre 2018

Interesting to see that one owner used a 64GB drive formatted on a MAC. I found that I could not easily format anything larger than a 32GB drive with FAT32 on either my Windows desktop or laptop. My only choices for the larger drives are NTFS (not permitted) and exFAT, which I found out does not work either. It was only when I attempted to format a 16GB drive that I got the FAT32 option. I had the car powered up in the driveway for a time while I was working on something else in the car. After I took the car around the block to see how the dash cam worked, I was amused by all of the 1 minute views of my front yard.
My PC initially rejected the USB because it thought it was corrupt. I ignored the warning and probed it anyway. There were several segments that were not recognized for whatever reason; otherwise the vast majority of files were easily viewed.

brianchi73 | 15 octobre 2018

Anyone know if you can pass the power through to a USB connected device? I ordered a Nomad wireless charger, but it requires both front USB ports. I'm hoping there's a way to use one to record onto a USB stick but also pass the power through to the wireless charger. :-/

seattlemag | 15 octobre 2018

I've had mixed results as well. It works great for about 1 day then stops recording (gray x above the camera icon). I didn't get any messages about a corrupted disk. I don't ever pause recording, so maybe that's causing corruption somehow. I have to reformat the drive to bring it back to working condition.

It's possible the drive has corrupted sectors as well, so I'll be trying again with a brand new drive that should be arriving from Amazon today.

dedgar57 | 15 octobre 2018

george,keith I had the same problem. I bought a Sandisk 64 GB yesterday(on sale) thinking bigger is better and I couldn't format to Fat32. only exFat. I returned it and got a 32GB and it is working but I have to scan and fix to get it to read. I'm having the same problem with some files that are not recognized.I'm not sure how some people are able to format a 128GB flash drive to work. These forums are great help. I'm an old guy learning every day. Thanks to all !!

Quinten | 15 octobre 2018

My failed and I had to use Win 10 to do a repair on it. I am thinking of using a flash micro SD reader and get one of those dash cam micro SD card of 128GB that was design to read and write file for long continues hours. This should help fix some of the issue.... I hope.

Quinten | 15 octobre 2018

@ seattlemag,

My 128GB USB micro size drive had the same issue. Dashcam icon changed from red dot to an "X' on the icon. Try using your Windows 10 OS laptop or PC to scan and fix the flash drive. My auto detect issue and Windows fixed and repaired the drive. It is working again now. Not sure if the flash drive has certain section that is bad.

Alex_SD | 15 octobre 2018

To All,
You need a different formatting tool to format FAT32 drives over 32GB:
https://www.howtogeek.com/316977/how-to-format-usb-drives-larger-than-32...

mizunosan | 15 octobre 2018

No problems after switching to 32GB Sandisk formatted to FAT 32
FAT 32 is only really reliable and for sizes up to 32GB. The Dashcam only records an hour of data and rewrites over the older files so anything more than a few GB is also overkill.
I had a 256GB USB and if you understand how that files format works FAT 32 is NOT the best way to format anything over 32GB anyway. I'm using the 256GB formatted back to exFAT for music files

djharrington | 15 octobre 2018

4 days and counting on an old Sandisk 16GB

charles.a.braun | 15 octobre 2018

I am using the 16GB Micro SD card that came with my BlackVue in a MicroSD to USB converter thumb drive. I put a 128GB card in my BlackVue so I had this lying around.

So far, no problems but have only had v9 for 3 full days at this point. Plenty of driving though.

gmr6415 | 15 octobre 2018

For those who are having problems of corruption and having to reformat. If you think about it any time you remove a USB drive or an external drive from a computer you have to properly eject the drive or you will get an error message. What that does is end the write process before you remove the drive.

You can stop the record process on the DashCam by holding the icon for a few seconds and you will see a circular light pulse around your finger. At that time the DashCam is no longer recording.

I've made the habit of stopping the camera before exiting the car and definitely before removing the drive. It only makes sense. So far I'm not having problems.

@mizunosan, Yesterday I had almost 2 hours of continuous recording with my 64GB USB drive and nothing was over written. It seems to need about 2GB per hour of recording. I have noticed though that anything I haven't saved from the previous day is either deleted or overwritten the next day.

gmr6415 | 15 octobre 2018

Maybe, just maybe Tesla will add a format button like every other digital camera on the market.

Alex_SD | 15 octobre 2018

@gmr6415
I do stop the recording before removing the USB and Windows 10 still detects corrupted files... I always reformat and repair before reuse... It always works if I do that...

bobola | 15 octobre 2018

If formatting a usb drive greater than 32 GB on a Mac using Disk Utility, format the usb drive with MS-DOS(FAT) instead of FAT32. This works fine for me with both music and TeslaCam on separate usb drives over the 32 GB limit.

seattlemag | 15 octobre 2018

Thanks, @Quinten. Will try that and all the other tips others have posted here.

ANTHONYROSEJR | 15 octobre 2018

Can you view the files from in the car?

gmr6415 | 15 octobre 2018

@bobola, formatting to MS-DOS(FAT) on a mac is FAT32. Control click in your drive and select get info or hit the command key and I at the same time. It will show it's FAT32. Otherwise select your drive go to file>get info and you will see the same.

RedTeslaModel3 | 15 octobre 2018

I got a 200gb sandisk wifi usb. These rec file isnt bad, its mean that file got interupted while recording. Tesla temp directory is in the root folder. Once record is completed, it moved to teslaCam folder. Been using my usb for a week now and no issue. Everytime I want to view or copy my file. I just disconnect the us and hit the wifi button. This allows me to grab file or view directly from my iphone.

200gb is over killed, grab 32gb. I used 200gb so that it’ll last a long time with a lower time of corruption due to a massive file size, considering tesla doesnt use more than 400mb.

sgehlhoff | 18 octobre 2018

I am getting recordings on the USB I bought. Mp4 flies in the teslacam folder and REC files outside that for each time I click save. I'm using a mac and not having any luck playing the rec files. The mp4's play fine, but not the toppy files. I've tried VLC, QT, and "elmedia" with no luck. Any thoughts?

sgehlhoff | 18 octobre 2018

I am getting recordings on the USB I bought. Mp4 flies in the teslacam folder and REC files outside that for each time I click save. I'm using a mac and not having any luck playing the rec files. The mp4's play fine, but not the toppy files. I've tried VLC, QT, and "elmedia" with no luck. Any thoughts?

OrangeinCO | 18 octobre 2018

I've had success the last few days, after manually reformatting the drive and adding the folder. The drive was formatted correctly before, but the car kept rejecting it. After the reformat, no issues so far. I haven't checked any footage or tried to pull the drive, but every time I've driven it shows the red dot for recording.

seattlemag | 18 octobre 2018

sgehlhoff , the "rec files" aren't supposed to be readable. the ones in the TeslaCam folder are one minute each, and when you "save" them by touching the camera icon, the names of the previous 10 files are changed to "saved" and presumably not overwritten when the hour buffer is overwritten.

rlwrw | 18 octobre 2018
rob | 25 octobre 2018

Has any thought been given to the capability of auto-saving a file in the event of a crash? If the driver were incapacitated in a crash, it would be invaluable to capture the previous 10 minutes leading up to the accident.

RP3 | 25 octobre 2018

from my perspective, for those that say they have success but have to pause the dashcam every time they get out of the car, that is a non-starter for me. I'd rather live without the dashcam until Tesla comes out with a more reliable dashcam than to have to pause every time I get out of my car. Guess I'll just wait...

M3NOICE | 25 octobre 2018

Now there are two threads about DashCam. Done these experiments on my two cars.

Like @RP3, having to long press the button every time I park is a non-starter. I am looking for a solution without having to do that. Unplugging the drive is a different story, it is fair to ensure it stops recording before unplug, like any other device.

I noticed that when formatting 128GB drive the allocation size was 32kb by default. When formatting the 4GB drive the allocation was 4kb by default. With these two formatting types, the 128GB did not get corrupted (red dot has been there for many days), but the 4GB stopped (gray x) after 1 day.

I have re-formatted the 4GB with 32kb allocation and the red dot was still there after two days. Progress. Maybe a coincidence? possible.

Today I changed the 4GB with another 128GB, formatted FAT32 and 32kb allocation. Now will monitor both cars with two 128GB (apples to apples).

My goal is to have the red dot always there, regardless of park, sleep, deep sleep, you name it.

2015P90DI | 25 octobre 2018

I found that the last saved file is the one that gets corrupted. For me, i just hit save/download twice back to back to move the file I want to the second last file instead of the last file. So far at least, seems to work. The last file is my throwaway file. And it comes out corrupted each time.

I'm sure Tesla will fix the issue eventually. In the meantime, this seems to be an easy way to protect the footage you want. Doesn't mean that's the actual fix though. Could just be that I've gotten lucky each time, but so far it's been consistent.

cmh95628 | 25 octobre 2018

@RP3, @Bullet. I do not do the "shut down USB prior to parking" each time. I pushed the camera icon until an "eject arrow" icon showed up, and the next time I drove the car, and all times since in the last week or so, have showed the red recording icon. In other words, this method is a one-time thing. I'm using a 32 GB Sandisk drive, formatted to FAT32 and creating the TeslaCam folder (both done via a batch script, I did about 10 drives thinking I would need them, but did not need them). I suspect that if I am ever in a crash, I will need to wait a minute or two (since the last file saved may be corrupted) and then press and hold the camera icon (to save 10 1-minute files). I hope I am able to do so, and able to remember to do so.

RIP ICE | 25 octobre 2018

The DashCam works perfectly. If you want to review your saved files, just touch and hold the icon until it glows around your fingertip indicating that it's safe to remove the drive. After you have reinstalled the drive, touch the icon again to start recording again. You don't need to turn it off or on again until you wish to review files again.

I reviewed a saved set today and found that, in addition to the time I manually saved, it had saved as "recent" the first and last ten minutes of my commute. Pretty dang cool.

RP3 | 25 octobre 2018

@cmh95628 - I'm confused by your mention of an "eject arrow". As I understand the UI, there are only 2 things you can do. quick push of the camera icon causes the last 10 minutes...and that's when the UI shows that "arrow" to indicate that it is saving 10 of the 1 minute clips and renames them as 'saved...'. However, when you hold the camera icon and it glows around your finger, that's when it is safe to remove the drive.

@RIP ICE - glad yours is working...mine works until it doesn't, which is usually about 1 or 2 days.

RP3 | 25 octobre 2018

"causes the last 10 minutes TO BE SAVED..."

Pbbjr | 27 novembre 2018

My car was delivered yesterday afternoon, and I tested the TeslaCam at lunch today. It recorded fine, except there are some missing frames in the recording if the cam was recording when the car is moving. I didn't notice a similar issue when the recording was taken while the car was stationary. A Model 3, Midrange is what I have.

nemethb5 | 28 mai 2019

One detail nobody mentions is the fact that the dash cam recording will only work in Model S older than 2016, mine is 2015, so it will not work, even though it has V9 software.

nemethb5 | 28 mai 2019

One detail nobody mentions is the fact that the dash cam recording will only work in Model S older than 2016, mine is 2015, so it will not work, even though it has V9 software.

lordmiller | 28 mai 2019

This is what it looks like when autopilot avoids a near crash. Front and side view. My car did this automatically. I've never had an issue with the dashcam footage. 256gig Sandisk

https://www.youtube.com/watch?v=sbrtsJXaVA4

https://www.youtube.com/watch?v=-VFp-N8XoDU

TeslaTap.com | 28 mai 2019

@nemethb5 - You're right the notes are not clear on this. To avoid confusing others on the Model 3 thread, all Model 3s can use the dashcam. For the Model S/X it has to do with cars with HW2.5 have the hardware for dashcams, and HW2.0 do not. HW2.5 cars were released in Oct-2016. For a lot more on versions, timelines and differences, I wrote this article a few weeks ago for the S/X and 3: https://teslatap.com/articles/autopilot-processors-and-hardware-mcu-hw-d...