Latest firmware 1.9.0-rc8-TH causing control issues

Latest firmware 1.9.0-rc8-TH causing control issues

After having one of my two PW2 units replaced due to cooling pump failure I found that I was unable to change the behavior of the PWs between backup and self-consumption modes and ancillary control settings.
After repeated calls to Tesla Powerwall support I got it elevated to their high level tech support but no feedback as to the issue. I was assured on Friday (10/20) that it just needed a software reset that could be done remotely but that it required some high level access among the support team and I would get a call back by Friday afternoon. Saturday morning and no call yet so I called in to PW support AGAIN. I got through to a very helpful young lady that confirmed that my case was elevated and she told me that the control issue is apparently related to the latest firmware release (1.9.0-rc8-TH) and they were working on it. Now that I know it's firmware related I'm thinking there's nothing more to do but wait.
As of now my batteries are at ~100% off of solar yesterday and I'm feeding solely off the grid. Oddly enough feeding off the grid feels pretty strange. In the weeks since the install and commisioning (8/14) I've managed to avoid using or selling anything to the grid with the exception of charging the Model S or not making enough room in the battery for excess solar by dumping into the Model S. In the last month I've used 190 kWh and sold back 59 kWh. I'm pretty happy with that.

sashton | 22 octobre 2017

Mine was updated to 1.9.0 this morning. It is functioning OK but for the fact that it appears to be permanently disconnected from Tesla so the app doesn't work - possibly a similar symptom to Chuck.
Hoping they can push a fix. I'll give it a day or so and if the problem persists put a call in.

sashton | 24 octobre 2017

OK I had a little look at the setup here and there seems to be a repeating issue with the gateway.
1) It does not seem to be able to retain (at least display) the DG setting when Ethernet/static is set in the config. If you exit and reconnect the DG field is blank. This has happened before so may not be the root cause of the connectivity issue - but it smells like it.
2) Today, completely out of the blue, the PW stopped charging despite having an excess being provided by the PV. It registered that it was exporting but didn't kick the charging into life.
I switched 1) the PW off /on 2) the isolator off/on 3)the gateway off/on and only when I powered the meters off and on did it recover.

I have no idea whether this is related to the new firmware but 1) the GW loses internet connectivity immediately after the update and 2) a day later the PW stops charging in the middle of the day despite reporting a substantial export at the time.

Seems too coincidental to me.

sashton | 26 octobre 2017

This morning the Tesla app connects fine. I can't see any obvious changes at my end so I can only assume the issue was with them. Browsing to the GW still says "Not connected to Tesla" but the flow info seems to be updating correctly. *shrug* would be nice to see some feedback ...

jimhoskinson | 29 octobre 2017

So my powerewall will charge fine and will discharge down to about 70% despite being set at 30% backup. Hasn't worke right since its been turned on. Is this a issue for everyone or just me?

Bigtanuki | 31 octobre 2017

#jimhoskinson If you are still on 1.9.0 you can try to go into the configuration wizard on the Tesla UI and you will be given a chance to change the setting (along with way too many others). Or you could wait until you get 1.9.1. I did it that way before I got 1.9.1 and it worked. I used all the other default settings that were input when my system was originally commisioned by the SolarCity tech. YMMV

Tony163 | 31 octobre 2017

Just checked my app and I'm on version 1.9.1. No issues so far. There is a delay between when you adjust your reserve and when the PW reacts, but I'm not sure what that is.

agiangone | 2 novembre 2017

1.9.1 solved that issue. chuckdunlap, when you say "go into the configuration wizard on the Tesla UI " do you mean to connect to the TEGXXX SSID and then browse to the configuration webpage? If so, you would need first the password for the WIFi connection and then one for the webpage. Do you have those?