Model S Android App

Model S Android App

Just downloaded the Tesla mobile app for Android. All I need now is my S.

Steve P5664 | 2 febbraio 2013

Hopefully my car is on the same truck as yours! Window feb3-17, told feb 11 will likely be my home delivery day, sayville, suffolk.

60kwh, blue,blk leather, pano, 19", air,tech

I have had one SSighting on long island so far, it was signature red in west islip.

mkh1437 | 2 febbraio 2013

Wondering if we should start a new wishlist thread for he mobile app? Here are the things I'd like to see added:

1) Notification in the app if the car alarm is triggered, and the ability to silence the alarm from the app.
2) Ability to SCHEDULE charging, not just start/stop it manually.
3) Ability to turn on seat warmers in addition to the HVAC.
4) Notification in the app of pending firmware updates and the ability to schedule them via the app
5) Ability to view the rear camera via the app (might come in handy if the alarm is triggered, or if your car is being towed).
6) Ability to open/close the trunk.

GoTeslaChicago | 2 febbraio 2013

Good wish list!

Also good idea for a dedicated thread.

DouglasR | 2 febbraio 2013

Using the app over Bluestacks/Windows, is there any way to zoom the map in "Location." I'm seeing the entire globe, although this morning I looked and it was zoomed to my neighborhood. I then clicked one of the buttons, and it zoomed out again to global.

mkh1437 | 2 febbraio 2013

@DouglasR it looks to me like Bluestack cannot determine YOUR location, but the app knows the car's location. So if you select the left hashed-circle icon (your current location) it zooms out to the global view, because it doesn't have your true location. But if you just have the Car icon selected, it does seem to (sometimes) zoom into the car's location, but it doesn't seem very stable. I'm writing this off as a quirk of Bluestacks in determining the apps location when running on a PC with no GPS. I can't seem to figure out how to zoom on the emulated app. I assume pinch-to-zoom works on the actual app, but I don't know how to simulate that on Bluestacks.

DouglasR | 2 febbraio 2013


I see. Yes, so long as I have only the car icon selected, the location page opens to a highly zoomed in map. It is also extremely accurate, putting my car right in my garage. My computer actually does have a GPS, if an app knows how to use it, but I think you are right that Bluestacks does not support this feature. Hopefully we'll see the iPhone app soon.

sandman | 2 febbraio 2013

I assumed the car firmware would have to support the charge scheduling. This app is not built to stay ON for eternity so a scheduler on the app would require it to either stay on forever and send the command to charge or wake up and do so. Given that the app can't guarantee access to the car it would not be a good idea for Tesla or a user to assume it could schedule at a later optimal time. The car needs to receive a TIMER command and be able to hold that request on its own, tell the owner "got it", and then be independent of the app/phone.

Imagine if the phone app was the primary scheduler, the phone loses power overnight and you wake up withan empty car battery because the time you set up was after the phone couldn't reach your car. Insert any number of phone connectivity issues and you can see why Tesla needs the scheduler in the car firmware first.

mbcaffe | 2 febbraio 2013


also ability to schedule turning on the HVAC

Shelmire | 2 febbraio 2013

I downloaded app but my car is getting ready to be put on a delivery truck, but the app still tried to find it.

should be here in ten days, wonder if I can watch it move across the country!

Michael39 | 2 febbraio 2013

Fabulous app. Thank you Tesla. Just installed app on Motorola Xoom tablet and Droid Mass. Works flawlessly.

Carefree | 2 febbraio 2013

On my Toshiba Thrive the app is frozen. I cannot even enter my log-on information. The App does not respond to any input.

DouglasR | 2 febbraio 2013


I think that charge scheduling will first be built into a new version of the car software. A new app version will then be offered to support this feature.

jat | 2 febbraio 2013

I have a proof-of-concept working to query the car for the charge status, calculate the time required to complete a full standard charge (I haven't actually done anything for handling the slowdown of charge rate at the end of the charge, but I don't think that has much of an impact on a standard charge), and issues a charge command to the car at the appropriate time. So, you say you want it charged by 7am, and it starts at the right time to complete the charge. You would still have to stop the charge that will automatically start right after you plug in, but that will have to do until Tesla adds the timed charging in the car itself. If you have more than one Model S in your account, you have to supply a VIN suffix to differentiate between them.

I'm not ready to release it yet for several reasons:
- it is a command-line tool written in perl on a Linux machine, and I am not particularly inclined to write a nice GUI or port it to Windows machines. Once I am ready to release it, I am happy to work with someone who wants to support Windows or Mac.
- The machine has to be on at the required time to issue the command, so if you turn your machine off at night that won't help.
- I need to clean it up and make it more robust for user input and error conditions, such as handling 60/40kWh cars and timezones properly.

It would also be easy to do the same thing for HVAC, though calculating how long it will take to change the cabin temperature will be harder.

reitmanr | 2 febbraio 2013

Great using the app today at the Gilroy Supercharger to know when the S was completely charged so we could finish our drive home. Met another Ms owner from S Ca at the station. He was anxious for the Apple version. If he reads this I hope he responds as he is moving to San Francisco to work for Uber Ware. Do meet the nicest people at the Sc stations.

dqb | 3 febbraio 2013

Anyone having luck with the app installed with bluestacks for mac? I installed it OK, but cannot enter login credentials (typing not possible)...

xenogeek | 3 febbraio 2013

I had just gotten a Nexus 4 to play with so it was great timing to download the Android app. The current set of features is really nice and I hope a preview to come for more additions to it.

I am getting this message quite a bit:

"A Connection to the Vehicle Could Not Be Made"

and need to hit "retry" to dismiss the dialog. This is with the Nexus 4 on a strong wifi only (sitting right next to the router) and the car has been either in my garage or when my wife took the car out for a spin in areas with good 3g coverage. Hard to tell if the problem is the app, Tesla's servers or the connection down to the car.

Also, I'm not sure what would happen if I suddenly changed the climate or honked the horn while my wife was out driving. For marital harmony I think I'll leave that one alone for now.

hoffscot | 3 febbraio 2013

dqb -

i had that as well, so i uninstalled then reinstalled the app. Did it twice, and then i could enter name and password BUT was rotated 90 degrees! So I had to set it up in tablet mode so I could use it and THEN go back to default. Now it works fine - just a lot of fiddling. Good Luck!

hoffscot | 3 febbraio 2013

dqb -

i had that as well, so i uninstalled then reinstalled the app. Did it twice, and then i could enter name and password BUT was rotated 90 degrees! So I had to set it up in tablet mode so I could use it and THEN go back to default. Now it works fine - just a lot of fiddling. Good Luck!

DickB | 3 febbraio 2013

I have to Nexus 7 and getting the same message as you on connection. The first day it work with no problems, but today it's getting the no connection message about every minute more or less. Also the map does not show now, just a black screen.

I did a shut down of the Nexus 7 and a reinstall of the app. This gave me the map back, but only last for a minute.

randall.einhorn | 3 febbraio 2013

does it work with iphone?
I cannot find it

djp | 3 febbraio 2013

Does the honk horn and flash lights command work while the MS is being driven, or just when parked?

reitmanr | 3 febbraio 2013

How do you get it working on android Samsung tablet with just Wifi? It does not seem to accept login key entries. Works great on Droid smart phone.

mkh1437 | 3 febbraio 2013

@randall.einhorn the iPhone version has not been released yet

jat | 3 febbraio 2013

@reitmanr - it worked fine on my Nexus 10 with just wifi.

@djp - don't know, I haven't tried it while driving yet.

Sudre_ | 3 febbraio 2013

Don't forget to review the app at the Google store. One person who does even own a car rated it at three stars. How does this person feel they can review the app? I marked it as spam.

Sudre_ | 3 febbraio 2013

does = doesn't

Superliner | 3 febbraio 2013

I suspect the app is geared more to hand held android devices as opposed to laptops, tablets etc. On my Droid Bionic went to play store downloaded the app. and viola! now all I need is my car to connect to. :-(

David Trushin | 3 febbraio 2013

Who is viola and does she have a model S

portia | 3 febbraio 2013

@dqb I had the same problem at first, I quit and restarted bluestacks a few times then it started to work.

Superliner | 3 febbraio 2013

@ David Trushin

Lol!! Not sure who Viola! is or if she has an S, But I don't .... yet !!!

dqb | 3 febbraio 2013

@hoffscot, @portia,
Thanks for the tips. Had to uninstall bluestacks from the Mac and reinstall. It was behaving strangely on it's own, outside of the Tesla app, and restarting wasn't successful. After the reinstall I needed to toggle the Tesla app "size" but after that was good to log in. Now to play!..

Schlermie | 4 febbraio 2013

Security with Lock/Unlock Feature

I noted when you press the Unlock button on the app, the car unlocks, the handles slide out and the interior lights turn on. Then after about a minute the handles slide back in and the interior lights turn off, but the car is still unlocked. You can press the handles and they'll slide out again. You can enter the car and the interior systems power on, but you cannot drive the car unless you have they key fob.

After I exited the car, the handles remained extended for a couple minutes and then retracted. The car remained unlocked though until I locked it again with the app.

suj17 | 4 febbraio 2013

Has anyone had trouble with the androind app? Mine is very inconsistent in connecting with the car.... more often not being able to connect

Schlermie | 4 febbraio 2013

I've only had trouble connecting when my car is parked someplace that has a limited 3G signal, but usually, I just tell it to try again, and it makes a connection. I assumed it was just due to the weak 3G signal though.

nickjhowe | 4 febbraio 2013

I'm finding it takes about 5-6 seconds for a change on the car (e.g., unlocking) to be registered on the app, and vice versa. Is that what other people are seeing?

Theresa | 4 febbraio 2013

nick, Yes I am experiencing the same things. I assumed it was the poor cell phone coverage for the Model S as AT&T is very poor in this area. There are times when I can't even connect to the car. One place is at my house. When the car is moving around town in areas that I know are better for reception then things respond quicker.

Del Mar | 4 febbraio 2013

We locked our key in the car (again!). This app let us back in the car in seconds. What a lifesaver! This is a must for all Tesla owners.

aaronw2 | 4 febbraio 2013

I'm in the same boat. I've downloaded the app but I won't be able to use it until the 23rd. I wonder if it will start working before I actually pick up the car.

Brian H | 5 febbraio 2013

For convenience, always leave the FOB in the car, and get in with the app!

DanD | 5 febbraio 2013

I've had lots of trouble having the app connect to the car. There can't be that many places with weak 3G (in which case 3G surely is the wrong answer for Tesla).

I wonder if its a server problem or just a plain old fashioned bug.

But it's a problem as it happens close to 50% of the time.

One thing to remember for those not able to access at all, there is a car setting you have to turn on to allow the app to communicate remotely.

alan | 5 febbraio 2013

Just downloaded the IOS app - I really expected the app to allow time of day control for charging, but I don't see that feature in the app. Does it exist? Seems like a critical feature for those of us that have time-of-use billing for our electricity: Less than 10 cents per kWh after midnight, but up to 40 during the day!

Brian H | 5 febbraio 2013

Major omission, available for the Roadster, rather puzzling. Current best workaround seems to be to start charging as late as possible at low amperage to finish up at about the right time. Or plug in, switch charging off, then turn it on again as late as possible, etc.

MandL | 6 febbraio 2013

@DanD - I find sometimes the app/car connection gets lost, especially when it goes to the background or you turn your phone off and on again. I find if I go into settings and force quit the app it connects right up when I launch it again.

Brian H | 6 febbraio 2013

Android update available. Check the BB.

bigez1 | 6 febbraio 2013

Thanks Brian H.

Just downloaded update. Couldn't find the changelog and I'm not sure what features were added/changed, but the app appears a bit snappier....

Superliner | 6 febbraio 2013

My Droid just popped up with an update to the Android App "Tesla Model S Beta" The update does not appear to include any additional functions over the first offering. Not sure what was changed.

Jason2 | 8 febbraio 2013

I've been using the app for a week or so and have found a problem.
I tried to turn off the charging because it was peak electric rate time which costs twice as much as off peak. With in minutes the car had begun to charge again. After about 4 try's it appeared to stay off. When peak rate time was over I went to turn the chargers back on and found that the car had resumed and completed charging on peak rate time. The cars charging system should have the capacity to stop charging for user defined for peak rate times and to restart later. The app should have that capacity as well. But, if there is a "stop charging" button in the app it should be able do that.
Also, when I turn on the cars heater in the morning I found it uses the battery power. Even though the car was plugged in. The car had charged to 236 miles and stopped charging when I turned on the heat. 20 minutes later went out to drive and found that my miles had dropped to 225 and the charger had not come on. When plugged in, the car's systems should not draw from the battery. One of the benefits of preheating or cooling the car is the access to plugin power.

jat | 8 febbraio 2013

@Jason2 - I haven't had problems stopping charging from the app. I have seen it sometimes draw from the battery and sometimes draw from line power when running HVAC, and I haven't figured out what drives that choice yet.

Brian H | 8 febbraio 2013

I think the best tactic is to start charging at the car, then use the screen to "End charging". Then start it later again with the app.

As for the HVAC, it's a 12V function, so ALWAYS runs off the battery. Sometimes the draw is being replaced concurrently by shore power, and sometimes not.

jat | 9 febbraio 2013

@BrianH - are you sure HVAC runs off 12V? On the LEAF, both the heater and AC run off the traction battery, and on the Camry Hybrid the AC runs off the traction battery (it didn't have a heater except for one using waste heat off the ICE). 1.5kW+ is a lot of current at 12V, so I would be exceptionally surprised if that were the case. The fan might run off 12V, but that is negligible power draw.