Rev 4.2 Downloaded Early Sunday

Rev 4.2 Downloaded Early Sunday

Well, we now are running rev 4.2
So far the changes have not been obvious in driving. Will update as we discover interesting differences from 4.0. Love to hear from those that see or know what we might be looking for in the latest update. It does feel really cool that all this happens while I and the car are " sleeping". VIN 2859, 85std with most options

ziggy | 21 gennaio 2013

Is there some sort of Change History which is common in software updates, offered with this new rev?

jat | 21 gennaio 2013

You can go to the revision notes from the "T" at the top of the display.

JoeFee | 21 gennaio 2013

To those who have gotten the new update: has it always come in the early morning hours?

Brian H | 21 gennaio 2013

It "comes" at any old time, but installs when driving is unlikely.

appljd | 21 gennaio 2013

Should mean that the iOS app will be released soon. Does it have a "charging" schedule option now ?

mkh1437 | 21 gennaio 2013

Ugh... I'm STILL running on 1.15.14. No updates for my Sig VIN 871. I go down to the garage every morning and every evening just to check if the update message is waiting.

Brian H | 21 gennaio 2013

I guess you just don't resemble a guinea pig enough. Mixed blessing ... ;)

lightly | 21 gennaio 2013

@appljd The DS at my friend's delivery last week sad the iOS will not be out until sometime in March. :(

mustangez | 21 gennaio 2013

Glad I'm not the only one still running 1.15.14. I wish there was a way to make the car request the update. I've been telling people about the update which makes the handles come out automatically as well as other features, What I really want to do is use and show off those features.

TINO F | 21 gennaio 2013

Commodore 64

Velo1 | 21 gennaio 2013

Is there not a feature to check for updates from the car?
My car was delivered 1/19 (VIN 3271) and I just checked my version, which shows: 4.1 (1.19.13). Does this sound like a newer version? I do know my door handles present whenever I approach the door (~3 feet from car).

jeeps17 | 21 gennaio 2013

One thing that was consistently mentioned as fixed in v4.2 on TMC is the pano roof opening when done from the touchscreen. In v4.1 and some previous builds, it would always stop at the vent position no matter what percentage opening was requested. When opened from the steering wheel scroll wheel, behaviour was correct.

v4.2 allows proper pano behaviour from the 17' screen.

A lot of the spurious error messages owners with v4.1 were getting (TPMS warnings, 12V battery fault, etc...) have also been addressed, and now occur only when true.

Tesla also removed the screen sleep option (was supposed to reduce battery drain while parked, but apparently caused other issues).

I am sure there are other tweaks, those are the ones a remember off-hand.

Robert22 | 21 gennaio 2013


The most current software is version 4.2 which addresses some of the bugs present in 4.1 and, according to people who have already updated, disables the "sleep" function previously accessed with the range toggle on the control panel (not to be confused with the range charge toggle found on the charging screen) and is designed to reduce the high single digit range loss that occurs overnight.This feature is generally believed to be the culprit behind a multitude of bugs which by all accounts seem to decrease after installation of the 4.2 update. Reportedly, Tesla will re-release this function if/ when it's ready for prime time. The update is being distributed randomly to batches of cars at a time.

The new Tesla Addicts Preferred Program for Early Distribution (TAPPED) provides access to software updates on the day they are released for a nominal fee of $800.00/ year. Any takers? ;)

bobinfla | 21 gennaio 2013

@mkh: Wait a minute..... I used to check the My Garage page incessantly looking for the time to configure. Then I used to check the My Garage page incessantly looking for the Design button. Currently I check my email incessantly looking for my final paperwork, and double check my phone for missed calls with a California area code (and just for good measure check the My Garage page in case I'm the first person who was ever notified of their VIN or Car has Completed Production via the website). Now you tell me that even after the car arrives I will probably obsess over software updates? When does the madness end?

Robert22 | 21 gennaio 2013

We're waiting for an update on that, please hold....

Brian H | 21 gennaio 2013

It's even better now. Now you have to go out to the car every hour to see if the update has requested permission to install, or check the release # to see if a stealth update has happened when you weren't looking. Provides much more exercise. Your doctor would approve.

SD Supercharger | 21 gennaio 2013

I think that cars due for release in the next few weeks will still be using 4.1. The main 4.2 feature is the removal of the sleep function which was causing numerous problems. The other feature that has been addressed in 4.2 is the windshield wipers which others say are now well behaved, and the door handles apparently are working better in 4.2. Hardware releases include new vents for defogging/defrosting. It sounds like they are trying to get the new vents into the northern climates first. Tesla has apparently announced that they are planning to re-release the sleep function again in the near future .

For those of you still not running all the features in 4.1--you got trapped in the "Bug world". Tesla was most likely planning a large release of 4.1 but cut it short based on all of the bugs. They then worked on a fix (4.2)--- released it slowly--and this continues to be the case. Have patience it is likely that most will have 4.2 and IOS by March.

@Bobinfla--the Madness is not likely to end anytime soon--but isn't it fun. Just think what version 104.2 will offer. Maybe a SpaceX ride!

My 2 personal requests would be the charge timer and recognizing the key FOB to adjust the personal profile before you enter the car

reitmanr | 21 gennaio 2013

Don't know if it's related, but after the update to 4.2, we were stopped at Harris Ranch to charge up and after starting to charge for a while, the charging stopped after some tens of miles. It still showed that it was charging, just no current flow- only voltage. I stopped it and restarted charging and this time it made it ok.

Then we stopped at Gilroy SCs and hoped to top it off before the last leg home. We never were able to get any current flow. A gentleman ( who got his car the same time we did!) in another white S offered us the Driver Experience phone number. We called and they were unable to resolve the issue- a service stop tomorrow at the Menlo Service center is called for.

We made it home with plenty of miles left and charging in our garage works fine.

It's a mystery. Will post any developments. Will see if any one else had similar problems.

Anthony H | 21 gennaio 2013


We are not alone.

ziggy | 21 gennaio 2013

At the risk of upsetting my fellow obsessives on this forum it is bothering me that everyone is calling it an "IOS". I am of course also an Apple fan boy so IOS (iPhone Operating System) is specifically for the Apple iPhone family (iPad and soon desktops).

So is Tesla really calling their OS (Operating System) an "IOS"?

Oaktowner | 21 gennaio 2013

@ziggy -- you can relax. Pretty sure everyone is referring to the iPhone/iPad app that is supposed to be showing up soon.

rlpm | 21 gennaio 2013

To be fully pedantic, the operating system on Apple iPhones, iPads, etc. is iOS, whereas IOS is the network infrastructure software that runs on Cisco routers & networking hardware.

/me ducks to avoid virtual tomatoes hurled at blinding speeds. ;)

jat | 21 gennaio 2013

@Oaktowner - I sure hope they ship an Android app at the same time. It would be a shame to ship an app for the phone that continues to slip in market share at the expense of the OS with a larger share (Apple is now the third manufacturer by volume of smartphones behind Samsung and LG, and there are tons of other Android manufacturers).

ziggy | 21 gennaio 2013

@rlpm - Right you are about Cisco. Cisco agreed to license the trademark to Apple. I am curious what Tesla calls their OS..
It would be nice if there were a blog or something where we could see the OS changes.. Maybe there is one?

rlpm | 22 gennaio 2013

@ziggy - If you have a Model S, release notes are available by tapping the Tesla logo at the top of the 17" screen. I'm not sure Tesla would be willing to post the release notes for everyone to see. But they could make it accessible only to those accounts on this website with an active reservation or a completed delivery. And I think the operating system running on the instrument panel and touchscreen is called linux. :)

@jat - I've not heard that Tesla intends to ship the iOS & Android apps at significantly different times. This links says in "a month or so" of Dec 21st. So that would be, uhm, today!

Brian H | 22 gennaio 2013

Watch out for those "or so" weasel words. They're awfully stretchy.

sergiyz | 22 gennaio 2013

next month of what year ? ;)

ziggy | 22 gennaio 2013

I have to say this whole Tesla car experience feels so much like a software development experience.

The people behind the Tesla think like app developers (about time in my opinion).. get the best thing out there that is reasonably done.. spend time where it counts.. fix the inevitable bugs and problems down the road because we came up with a really great way to update things.. Sure the early folks will suffer a bit but when we fix it they will love us.. don't worry ship it!

Car hooked to my phone.. hmm, geek nirvana..

rlpm | 22 gennaio 2013

@Brian H - I agree, or so. ;)

MitchellK | 22 gennaio 2013

Signature Performance VIN 277 - still on 1.15.14. I didn't mind not getting 4.0 and 4.1 with their bugs, but now that 4.2 is looking stable, I'm disappointed to still be on 1.15.14. I will add, though, that the car has been virtually flawless in the three months I've had it!

dtaubert | 22 gennaio 2013

The creep configuration switch went away after my car upgraded to 4.2.

Is there any documentation on the regen dynamically adjusting to driving style? A couple of times now, I've seen a dashed line appear on the dial which seems to limit the amount of regen.

mkh1437 | 22 gennaio 2013

@dtaubert, the dashed line limiting regen is normal, especially in cold weather. It will limit regen when cold, until the battery heats up sufficiently.

nickjhowe | 22 gennaio 2013

@dtaubert - Creep went away? It is still there on mine and I have 4.2. You have to be in Park to change the setting. If you are D it is greyed out.

dstiavnicky | 22 gennaio 2013

If your car is virtually flawless it sounds like everyone should go back to OS 3.9 !

Epley | 22 gennaio 2013

I'm still stuck at 1.15.14, too. but everything works just fine. Normally, I like to have the latest release, so it's bugging me a little, but I am enjoying bug-free driving!

dtaubert | 23 gennaio 2013

Ah, my bad - creep is still there. One of the switches was removed from the Vehicle->Settings screen, but I'm not sure which one.

mkh1437 | 23 gennaio 2013

I believe that was the Sleep function that was removed from Settings in 4.2.

TonyJ | 24 gennaio 2013

I just received my MS Jan 22, vin 3204 (performance, tech, stereo, twin chargers, no pano), on 23 jan. TPMS warning-tire psse too high on my commute home. I checked and tire pressure averaged 57 for my tires after they had cooled down about 2 hours. I had seen other posts regarding the high tire pressure on delivery, i bled off the pressure down to 42. On that evening I noted a small alarm clock on the top of my screen, pressed it and it stated I was scheduled an update. V4.2. I downloaded it last night. Not sure if I needed it, no pano and no issues except a proper TPMS light. Will update you on any issues. My daily driving is such that the 8mi/wk loss in range is not an issue, however given how new the car was I was afraid to skip downloads designed to fix bugs in the system (even if I did not note them yet)- must be a by-product of my military background, be vigilant.

MandL | 24 gennaio 2013

If you don't have 4.2 and want it, just ask. I emailed ownership yesterday morning and asked about the 4.2 update to fix radio/camera/etc. issues I've been seeing. They called me right back and said they were pushing the update to my car as we spoke. When I got in the car after work the update was there waiting for me.


I am 3146 | 24 gennaio 2013

4.2 was pushed to me this morning without me having to ask

Theresa | 24 gennaio 2013

I had an issue last night where the car would not take a charge. Symptoms included white charge ring would not change colors as is normal. Using a Nema 14-50 plug. I unplugged and re-plugged several times to no avail. Switched to the 110 adaptor. Lights appeared normal on charge port and dash showed voltage and current but no range increase.

Needless to say I was concerned and called support. What we did was to reset the main screen using the scroll wheels. Still appeared to operate the same way. We then unhooked everything, closed the charge port door, locked and unlocked the car and tried charging using my normal procedure of using the cable to open the charge port and plugged tha cable in. Everything then worked.

It might be a good thing to remember in case it ever happens to you. I had 1.15.14 installed. Assistant asked what I had and he seems quite surprised at how old it was so he immediately pushed out the update to me. I haven't had time to instal it yet. He did mention that the reason they don't push it out to all cars is their servers get overloaded. I sure hope there are plans to be upgrading that soon as it is apparent updates are going out very slowly.

I was one of those who had no real issues with the prior version and seeing how many issues 4.1 introduced I was not in a hurry to get any updates. We'll see how this one goes.

nickjhowe | 24 gennaio 2013

Theresa, just in case, and please don't go 'Duh!' on me, but sometimes the charge cable doesn't go in all the way and can need an extra push. It really feels like it is seated but it doesn't click all the way.

This has happened to me a couple of times and I thought something had gone wrong. It just needed it little extra encouragement.

jemartin | 24 gennaio 2013

Got the 4.2 upgrade last night (after OK-ing the notification box that popped up when I got into the car last evening). I've only had the car for a week, I had 4.0, and I didn't run into any issue or ask for the update. Seems to me that (a) 4.0 was in need of fixing - not just 4.1, and (b) they're going at it fairly randomly - I don't think I had the profile that qualifies for a priority upgrade...

Theresa | 24 gennaio 2013

nick, Note that I had port lights and dash indication voltage and current but no mileage charging with the 110 volt adaptor. That tells me that I was indeed fully inserted. And I would be really surprised if after over a month I would suddenly not be inserting the charger correctly when I never had an issue with it until last night.

Do your port lights turn blue and green when you don't have it all the way inserted? And does the charge screen show voltage and current but no mileage charging?

The first time I tried a J1772 connector I had somewhat similar results as far as charging but the indicators (lights and dash) indicated some type of issue. What happened last night was a totally different scenario.

nickjhowe | 24 gennaio 2013

Hi Theresa - that's really weird. No, definitely not seen your problem. Wow. Hope this was a one-off glitch.

jat | 24 gennaio 2013

I got the notice to schedule the software update, so presumably tomorrow morning I will have 4.2. I will miss sleep mode since I haven't had many problems with it, but hopefully they can add it back before I take another out-of-town trip where I can't just keep the car plugged in overnight.

mark_g | 24 gennaio 2013

Just received 4.2 in response to a glitch in 4.1 (faulty low 12v battery signal). In the 4.2 (and 4.1) release notes there is an indication of "location based" homelink which seems to indicate that based upon your immediate location, the appropriate HL icon will deploy. Am I reading this wrong as so far I see no difference in HL behavior regardless of my location.

jat | 24 gennaio 2013

@mferrazano - I had that in 4.1 -- when you are near the location you programmed a HomeLink, it will pop up the HomeLink menu for you to select. For me, it does it only right at my garage door and I want to open it at the bottom of my driveway, so I am thinking about clearing it and reprogramming it further away. | 24 gennaio 2013

I apparently update tonight -- VIN 2449

iholtzman | 24 gennaio 2013

I also got my 4.2 upgrade today vin# 1692