Best controller for Cuphead

Best controller for Cuphead

I saw another post saying that the Xbox One controller works and someone else mentioned that the PS4 controller works, but I would like to know if one controller is better than another. I have never played Cuphead before, so I don't know what pads/buttons are used most. Is the game best played with a D-pad and buttons? Then some version of PS controller seems like it would be best. Or is it best with an analog stick and buttons? Then the X-Box controller would probably be better. Or is there some other generic controller that is better for some particular reason?

Thanks in advance.

JAD | 27 settembre 2019

I just got a couple of cheap XBox controllers from Amazon which worked on other games, but with CupHead, I click through all the intro story and then I can't do anything when it says to go to the table. Anyone else have this issue? Not sure if it is the controller or software. Has happened both times I tried to play today.

andrewsjra | 27 settembre 2019

I’ve used both an Xbox one and a PS4 controller. Both work great but I prefer the feel of the PS4.

joselito_76 | 27 settembre 2019

it is a very hard game. I have it on my switch and I quit playing it. I hope is not as hard in the Tesla.

manuelromney | 28 settembre 2019

Has anyone used a wireless ps4 controller? and if so, what wireless adapter works with it?

SteveWin1 | 28 settembre 2019

Got on the forum to ask this exact same question. My old PS3 controllers don't work and my Steam controller doesn't work, so it looks like I'm going to have to buy a controller specifically for the car and want to make sure I get one that's actually going to work. Its a shame there isn't an official Tesla controller that we can buy directly from them that is guaranteed to work.

jamilworm | 28 settembre 2019

I'm thinking of getting the Logitech F310, but I'm just not sure if I should get an X-box stellar one instead with an analog stick as the primary control pad.

jamilworm | 28 settembre 2019

*X-box style

itsnice2be | 28 settembre 2019

Will the X-box wireless controller work?

kdgrotz | 28 settembre 2019

Just picked up my M3 on Wednesday and still figuring everything out. Where do you plug in a controller?

M3phan | 28 settembre 2019

@ kdgrotz, front usb inputs

rsingh05 | 28 settembre 2019

Has anyone tried a wired switch controller like this one -
HORI Nintendo Switch HORIPAD Wired Controller Officially Licensed by Nintendo - Nintendo Switch;

MYWBear | 29 settembre 2019

"JAD | September 27, 2019
I just got a couple of cheap XBox controllers from Amazon which worked on other games, but with CupHead, I click through all the intro story and then I can't do anything when it says to go to the table. Anyone else have this issue? Not sure if it is the controller or software. Has happened both times I tried to play today."

Yep. I had the exact same issue with PlayStation Classic USB controllers. The triangle button let me scroll through the introduction. Then, I couldn't do anything after that. But, I just received uploaded a new firmware version tonight. Haven't tried it yet. Maybe they fixed this issue.

If not, maybe the Amazon $18 wired Xbox controllers are the best choice. But, Xbox controllers are bulkier than the PlayStation Classic controllers. I'd rather have smaller controllers taking up space in the center console.

regis.santonja | 29 settembre 2019

@JAD, same for me. I can go up to the potion from the old kettle and can't go further. I bought the xfuny controller after some people reported it worked with cuphead.

Taffy | 29 settembre 2019

I got a XBox One wired controller from Walmart and with the new update it works great with almost all of the games!!!

82bert | 29 settembre 2019

@jad and @regis. Same exact issue for me with controllers. Has to be something with cup head. Got 32.11 last night. Hopefully it fixed the issue.

kevin_rf | 29 settembre 2019

Using an XBox controller, most of it works okay. It's a hard game (for me), but can not figure out some of the button combinations. For instance the lock and aim combination.

Enjoyed the the little I played, but weill most likely never quite matter the game.

I did find the Xbox controller to be a total bust with Tempest.

Mike83 | 29 settembre 2019

Anyone try PS3 controller?

82bert | 29 settembre 2019

Still not working with Xbox wired controller and latest update

SteveWin1 | 29 settembre 2019

Yeah, @mike83. The car just keeps saying to plug in a controller in order to play cuphead. Sucks, cause I have a bunch of extra PS3 controllers. Steam controller also doesn't work.

Tesla tested these games, right? Would it be that hard for them to tell us what controller will work best?

herrmdogg | 29 settembre 2019

I have tried to plug my PS4 controllers into the car and they don’t work, same message says “plug in a compatible controller”.

I see people saying they’re using PS4 controllers, so my question

SteveWin1 | 29 settembre 2019

Yeah, it's weird that we're getting conflicting reports about controllers working vs not working.

jebinc | 29 settembre 2019

Disclaimer: I didn’t read all the posts in this thread, but suggest you take a look at the “Amazon basics” Xbox controller. Good Teslanowner reviews and I found it works great with BB2 and Cuphead. Got the white one to match my white interior.

herrmdogg | 30 settembre 2019

@jebinc can you please provide a link to the one you purchased?

cmh95628 | 30 settembre 2019

Does anyone have a good recommendation for a controller that works well with Missile Command? TIA.

meoncomp | 30 settembre 2019

@jad and @regis adn @82bert. I am having the same issue in my Model X. All other games work with my controller but I have no control after cuphead starts and gets to the old kettle. I also can't navigate the control settings window on the start screen.

Mtonatiuh | 30 settembre 2019

@jad and @regis @82ber and @meoncomp same here. Stuck after old kettle gives the potion (also control settings is stuck). I'm using this controller on a Model 3:

It would be great if someone can post a link to a controller that works with Cuphead and Model 3.

82bert | 30 settembre 2019

@meoncomp. Same issue for me in the control settings as well. Gotta be a Software issue.

Copterguy | 30 settembre 2019

Anyone use one of those classic SNES controllers? Bunch on Amazon for $10.

karlziemer27 | 30 settembre 2019

Same issue, the controller works fine for Asteroids. In the cup head game only a few buttons work, and then stop working as soon as the intro is over

karlziemer27 | 30 settembre 2019

Same issue, the controller works fine for Asteroids. In the cup head game only a few buttons work, and then stop working as soon as the intro is over

jamilworm | 30 settembre 2019

I bought a controller from Amazon which I just received tonight and it works perfectly for Cuphead (I didn't try any other games). The buttons assignment is pretty much perfect out of the box.

Wired Gaming Controller, EasySMX PC Game Controller

jamilworm | 30 settembre 2019

Oh, and they have a wireless version too but I have no idea if that one works, I bought the wired version.

SteveWin1 | 1 ottobre 2019

@Copterguy, I ordered some. Supposed to arrive tomorrow. Fingers crossed.

herrmdogg | 1 ottobre 2019

I ordered this one after someone had said it works perfectly for Cuphead and Beach Buggy Racing 2.

AmazonBasics Xbox One Wired Controller - 9.8 Foot USB Cable, White, Version 2

It arrives today so I’ll post an update after I try it out!

wanche | 1 ottobre 2019

Bought this:
But not working on Model 3....

However, it worked on Windows 10 PC.

@Tesla, please provide list of compatible game pad...

bddaughe | 1 ottobre 2019

I had recently purchased a GameCube controller with USB adapter for use with the Nintendo Switch for the Super Smash Bros Ultimate game. I tried it in the car (on the PC setting) and it worked perfectly fine for Cuphead and also Beach Buggy Racing. I didn't try other games, but assume it would work for them too.

USB Adapter:

If you already have a gamecube, you may only need the adapter.

ODWms | 1 ottobre 2019

This is the XBox controller shown in the Tesla ad. Can anyone tell which one it is?

82bert | 1 ottobre 2019

Pretty certain that’s the pdp one others have listed and works for them but not me. I think my issue is a software issue that should be corrected sooner than later.

JAD | 1 ottobre 2019

Seems like a big enough issue that Tesla will fix it as it isn't an isolated issue.

82bert | 1 ottobre 2019


jebinc | 1 ottobre 2019

@herrmdogg - Sorry for the late reply as I've been tied up the past two days. I see you purchased the same controller as I did. The cord is long, but the controller works as you would hope - at least it does for me in my M3.

herrmdogg | 1 ottobre 2019

Thanks @jebinc

I can confirm that this controller works perfectly for Cuphead in my car as well. Just received it today and played the game without any issues!

ODWms | 1 ottobre 2019

Does anyone know if 2 controllers can work, 1 in each port?

herrmdogg | 1 ottobre 2019

Does anyone have a working wireless solution? The controller I bought (linked above) works just fine but I’d prefer to not have 8.5 feet of cable layimg around.

jebinc | 1 ottobre 2019

@herrmdogg - Glad to hear it! I was surprised it works with Missile Command as well!

jebinc | 1 ottobre 2019

@herrmdogg - 9.6 feet of cable!

herrmdogg | 1 ottobre 2019

@jebinc lol, oops

Homegrown | 2 ottobre 2019

@herrmdogg This thread on page 2 had a wireless setup using Xbox One controllers. Others have confirmed that it works.

herrmdogg | 2 ottobre 2019

Thanks Homegrown! I already have multiple Xbox One and PS4 controllers so I just ordered the Mayflash adapter to try! I’ll report back when I receive it Friday to let people know if it works with PS4 and/or Xbox One controllers!

SteveWin1 | 2 ottobre 2019

@Copterguy, I bought and tried these for $9.99 (I think these are the ones you were talking about):

They work for exactly 0.5 games. The 0.5 is because its a little bit of a game trying to figure out which way to plug the USB A plugs in with that dark felt in the background. You've got to feel for the little square hole, put it in the wrong way, flip it over and then realize you actually had it right the first time and then flip it again before you learn that the controller doesn't work. USB-A is a game in itself. So 0.5 games work! Not horrible for $9.99...?