Forums

Using the Sandisk iXpand USB stick for the Tesla Dashcam (128GB) - tips

Using the Sandisk iXpand USB stick for the Tesla Dashcam (128GB) - tips

I purchased the Sandisk iXpand USB stick (128GB) because it has a Lightning adapter integrated right into the USB stick, so if there's a fender bender accident, I can immediately copy the dashcam footage to the iPhone and upload to the cloud.

Some tips:
- you need to reformat the USB drive from the NTFS format to the FAT32 format
- if you are formatting from a Mac, make sure you keep the scheme to be "Master Boot Record," not GUID. If you set it to GUID, you won't be able to access the files from your iPhone.
- don't forget to create a folder called "TeslaCam."
- you need to access the USB files from the iPhone using the Sandisk iXpand app.
- with the new Sentry Mode, you need a USB stick that is at least 8 GB, because the Sentry Mode requires at least 6GB of buffer space. But keep in mind every "save" will cost you 1GB. So having a somewhat large USB is a good idea.

JIWONY | 13 marzo 2019

Hello everyone.

j.nichol | 13 marzo 2019

I tried to respond to this, and it wouldn't let me the first time. Trying again.

I just posted something similar but with my own experience setting up my USB. Yours is more streamlined.

Also, did you not have any problems with the larger drive? Did you format it with a Mac or Windows? I'd read many people complaining that they couldn't format the larger drives in FAT32.

tli0720 | 29 aprile 2019

I bought a 256GB Sandisk iXpand, icon appears with grey x, folder is created properly. Not sure why, plan to return it

johntran | 30 aprile 2019

For anyone need help with formatting, I've written step-by-step instruction (with pictures) that you can easily follow. Hope it'll be helpful for those who are not familiar with it. I've written for Micro SD card, but the process is the same for USB. It's just a removable drive from a computer perspective.

Mac:
https://hellovteq.com/blogs/tesla-news-and-tips/how-to-format-a-micro-sd...

PC:
https://hellovteq.com/blogs/tesla-news-and-tips/how-to-format-a-micro-sd...

scherer326 | 30 aprile 2019

If you are still getting the gray X after deleting old teslacam videos then use this tool to get the record feature to work again:

https://www.sdcard.org/downloads/formatter/eula_windows/index.html

this worked for my ixpand and I no longer get the X unless my usb is full. I then just delete old videos and I get the red recording image once again.

ColonyGolfer | 30 aprile 2019

I bought a Tesla FAT32 formatted Sandisk drive on EBay for $29.99 and it works flawlessly. Not iPhone cloud-connected, but for the price, it is great.

Alameda EV Guy | 30 aprile 2019

Purchased the 128GB iXpand, formatted to FAT32 on windows pc, works just fine in Tesla 3.

But, it is not recognized by app on iPhone, which of course, defeats the whole point of having this USB.

Anyone else successfully get the whole process to work and verified?

derotam | 30 aprile 2019

@ColonyGolfer...what size was it. 1GB at $29 isn't a good price for example... also you get what you pay for....and there are a lot of counterfeits thumb drives out there so watch out.

Not trying to say anything bad about what you bought, just want to basically say that it might work flawlessly now but if it is not a high quality product, it could fail faster, hence the you get what you pay for statement.

I know too much about bad/counterfeit thumb drives...I personally would never go to Ebay for one...Amazon isn't really much better.

hzb | 30 aprile 2019

I've been using a 16gb for music and 32 gb flash drives for dashcam. I tried replacing them with a single 256 gb flash drive. all 3 are sandisk and fairly recently purchased. the 256 flash drive is not recognized by my m3. is there a official tesla information on the largest flash drive you can use?

TeslaTap.com | 30 aprile 2019

Yep - Lots of fakes. I wrote up how to test your drive if you suspect it is a fake or counterfeit: https://teslatap.com/articles/usb-flash-drives-for-tesla-dashcam/#fake_c...

Even then, most no-name or "cheap" drives are crap. If they work at all, they will not last long when used to record video.

TeslaTap.com | 30 aprile 2019

@hzb - Limit is around 2TB. 256 GB is fine.

derotam | 30 aprile 2019

@TeslaTap, is that from experience, or do you have a reference for your statement?

TeslaTap.com | 30 aprile 2019

@@hzb - To expand, you can't have music and the dashcam on the same partition. You have to go through a fairly long process to properly partition a flash drive - not for the weak at heart :) With two partitions, once can be for music and one for the dashcam. Both partitions need to be FAT32 (not exFAT or NTFS). They also could ge ext4 if you're using Linux.

hzb | 30 aprile 2019

thanks teslatap. mine may be formatted efat, i'll check. good to know that 256gb isn't the issue.

Alameda EV Guy | 30 aprile 2019

Here is my testing:
iXpand 128GB. Formatted to FAT32 using the guiformat tool (Windows 10 PC). Created TeslaCam folder, placed into Tesla 3...everything works great to record videos.

Take thumb drive to iPhone Xs Max (everything is up to date), the iXpand app continues to state plug in your iXpand Drive to get started, but, nothing happens when plugged in.

Experiment:
Took iXpand drive back to PC, reformatted to exFAT32, placed a video file on it (for fun), tried again to reconnect iXpand to iPhone...works fine, it is recognized, and the file is played without issue.

So, from my perspective, iXpand app on iOS does not seem to support FAT32 formatted iXpand thumb drive.

PS. I also ensured that it was formatted to MBR as it was noted by the OP.

Anyone else successfully using iXpand drive, formatted to FAT32, on both Tesla 3 AND iPhone?

Thanks.

Azulejo | 9 maggio 2019

e a new 64GB iXpand. It came formatted in FAT32 and worked fine with phone and PC. I added TeslaCam folder, but the drive was invisible to my M3. I reformatted multiple times with the GUI utility and still no luck. I reformatted with a MAC (MS-DOS and MBR) and now it works both in the car and on my iPhone. The only problem is that some of the recorded videos from Sentry won’t play and it says the file format is not supported. Others play just fine. The error is not specific to a camera, but appears with some files for all of them. Progress, but still not quite right.

Azulejo | 9 maggio 2019

I have...

josia75 | 9 maggio 2019

@Azulejo I purchased a 32GB iXpand and I’m running into the issue that you were having. My iphone and computer recognize the flash drive just fine but my M3 does not. I only have a windows computer on hand and I tried formatting it multiple ways through various software and no luck. I will try your Mac method on my brothers Mac and see if I get lucky then

Alameda EV Guy | 9 maggio 2019

I posted earlier, but, I went to friends house who has Mac, formatted on Mac, and now works on iPhone, PC, and and Tesla.

There is something different about how PC formats, and I used GUI format, and the utility from sdcard site.

Syed.Hosain | 9 maggio 2019

@derotam "@TeslaTap, is that from experience, or do you have a reference for your statement?"

TeslaTap is right - the upper limit for a FAT32 drive is 2TB (with a max file size limit of 4GB too).

However, the stock Microsoft Windows format program only allows a max of 32GB for FAT32 for some silly reason. So, you have to use a third-party tool to do the format, or use the Windows command line program "format" in a Powershell if you know how to do so.

johntran | 10 maggio 2019

For anyone still having issue with Dashcam not working, this is a perfect solution, which has been tested and verified: http://bit.ly/2YfLhna

lingzhou125 | 11 maggio 2019

Hi all - I found a solution that works!
The tip about formatting with a Mac lead me to believe that there was something going on with guiformat. I tried Easeus which didn't work but finally got it to work with another free program called RMPrepUSB. Make sure you check the option to 'Set partition as non-bootable'
Good luck!

Daryl | 11 maggio 2019

I bought a USB-C to USB-A adapter for my Pixel 3XL (Amazon; 2 units for $6), so I can pull the flash drive out of the car and plug it into my phone. It works fine to just play back the videos, but it would be nice to be able to play them directly on the car's screen, fast, slow, etc. Wading through several clips to find the incident you are looking for is a little tedious on the phone.

Boosh | 26 maggio 2019

Thanks Johntran, just ordered from that link

jason.harris | 30 maggio 2019

I bought the Sandisk 32 GB iXpand Flash Drive SDIX30C-032G-GN6NN) which is the one the has a Lighting Plug curled up on the other end so you can plug it into your iPhone to view the videos. I formatted it 32FAT, created folder called Teslacam but it does not get detected when I plug it into the front ports of my Model S. I have a couple small cheap 8GB thumb drives that work, but they are filling up all in one day now due to Sentry Mode's current firmare (didnt fill up everyday before...). I have tried multiple times to format. I have compared all the info on the cheap drives that work with this iXpand one, and everything is identical.

Do I return this one and try another one? It sounds like others have been able to get this one to work, I think (this thread started with how to make this one work, but it was a 128GB stick). Is mine a dud, or just doesnt work for Tesla (it worked fine before I formatted it so it works, just not being detected by the Tesla)

Any help would be appreciated,

rob | 31 maggio 2019

If it doesn't work and you have it formatted FAT32 and the TeslaCam directory on it, then it is probably the boot sector. I have 128GB Samsung. Formatted it FAT32 but it didn't work. Changed the boot sector from MBR to GUID and it worked. Heard others say it works with MBR. I think changing it from one to the other clears the boot sector and either will work.

maduong | 10 giugno 2019

Need help...I have a 128G iXpand...I used a MAC to format it to FAT32....works fine and will record. I have the iXpand app on my phone however, it will not play the videos. I have verified that there are indeed videos on the usb drive because I plugged it into my computer and was able to view the videos.

Have read that if I change it to MBR then it can work. It is currently GUID, but I can't seem to figure out how to do this from disk utility in the MAC.

Can anyone help?

kwan.kenneth | 23 giugno 2019

I got the 64GB iXpand, had hard time formatting it properly to FAT32 using Windows 10 so the Tesla would recognize it. I tried Eassos, Windows PowerShell, Ridgecrop Consultants, all 3 of those options did not work. It was frustrating me and was going to return it.

I saw in the thread lingzhou125 suggestion, the free program called RMPrepUSB. I tried it out and it worked. I set the option to 'Set partition as non-bootable', WinPEv2, FAT32, then prepared the drive.

The Tesla now properly recognizes it, records properly. I can also connect it to my iPhone and view the files. Thanks!

johngsc | 24 giugno 2019

I put in my FAt32 flash drive into my car but a get a solid dark large dot. It all goes away when I drive. Any suggestions?

TeslaTap.com | 24 giugno 2019

@johngsc - That's the sentry option. It is only available when parked. Tap it to turn it on. If your car is HW2.0, then there are no dashcam features available and you don't need the flash drive.

NRKamau | 24 giugno 2019

@johngsc ~ Make sure you create a folder on the flashdrive and name it TeslaCam

lcoop96 | 30 giugno 2019

@maduong - I have the same problem. I can see the videos on my Mac but when I put the IXpand in my iPhone it sees nothing. Deleted app, reinstalled, etc. Did you figure out anything that works?

rcabrale | 2 luglio 2019

Hello All, I had the same issues with a SanDisk 256GB micro sd card in a type "3" USB reader. I then read kwan.kenneth, post on June 23, 2019, the link is below for your convenience.

https://teslatap.com/articles/usb-flash-drives-for-tesla-dashcam/

It was a bit stressful but was able to download and figure out the settings. My main issue was the RMPrepUSB was not recognizing the sd card bc, it was formatted to fat32 using other methods (that did not work in the teslam3. I simply reformatted it using windows 10 to default settings. Went back to RMPrepUSB and it found the SD card. Followed the steps, I placed the Teslam3 but again it did not see it!!!!! I then used an older (type "1" or "2") USB reader and inserted into the Tesla, didn't see it at first (on the screen). Then about 30 sec later it saw it but was gray. I long pressed it and it turned to red for a sec, then back to gray. I long pressed again (too one or two tries) then staid red.

I went back a few hrs later and it was still red! Let's hope this works as I don't want to do this every time! Tesla must fix this in an update!