Car going to sleep and not triggering sentry

Car going to sleep and not triggering sentry

Since 2019.40.2, my car is going to sleep even when sentry is enabled. I have done multiple reboots, power off/on and also format memory cards but doesn't. When I enable standby mode (under summon) it's staying awake and sentry works normally. Anyone else seeing this problem? I guess sentry mode is supposed to work even when standby mode is off.


davidpereirocortes | 28 marzo 2020

Same issue here mate! No one at Tesla seems to be able to diagnose the problem. I just got today the 2020.8.2 update and the same thing. The car goes to sleep when it shouldn't. Do you think is a faulty hardware? Does anybody solved the issue?

EVRider | 28 marzo 2020

Is Sentry Mode supposed to be enabled wherever you're parking? How are you enabling it?

Note that Sentry Mode automatically turns off if your state of charge drops to 20%.

davidpereirocortes | 28 marzo 2020

My car is beyond the 55 % os SOC and yes, it is supposed to be enabled as soon as you engage P and leave the vehicle and it worked like this up until the 8.1 update. I have to mention that I have unchecked all the disabling locations but still not working. I mean, I know how the system works but for some reason now is not working and seems that is difficult to diagnose for Tesla.

The thing is that a contradiction in the CAN messages should occur since it is supposed that the sentry mode is a stay awake condition that is not accomplished.

Whatever is happening, nobody knows how to fix it, and everyone at Tesla is telling me that the next update will fix the bug but is not.

davidpereirocortes | 31 marzo 2020

Just for you to know, tesla confirmed today that there are more vehicles with this issue and is under engineering investigation.

I think that is a bug related to the MCU but if all the vehicles have the same software or at least the same version, why only are a few cars with this bug?

Whatever, do you have experience with a Tesla engineering investigation? How long it should take?

earlstamford | 4 aprile 2020

I’ve had the same problem for several weeks now, after 6 months of it working perfectly. Even when Sentry Mode is activate, the car goes to sleep (noticeable because the battery drain is minimal!). Walking around the car no longer produces the “Red Eye” Sentry notification on the screen or makes the lights flash. If you pull on the handle, it takes around 5 seconds to wake itself and the screen shows the “Tap Key Card To Unlock” message. I have verified there are not issues with the SD card, excluded locations, my phone being on etc.

davidpereirocortes | 5 aprile 2020

Hello earlstamford!

It seems to be a software bug, but who knows is it is something related to the MCU memory or whatever. I had the same issue from 4 weeks ago until yesterday. I realized that I did all the resets that you can imagine except the "factory reset". So yesterday I did that one, I lost almost every configuration that I had in the vehicle but it was worth it! Now it is working from yesterday when all these weeks only worked for 3 or 4 minutes after closing the car. I don't know if it will fail in the next hours but so far so good.

So try to perform a factory reset and tell us your results!

More info here:

Good luck!

earlstamford | 7 aprile 2020

Thanks davidpereirocortes - before I try that, has this solution lasted for you?

earlstamford | 8 aprile 2020

I went ahead and tried the factory reset - and it seems to have worked! Thanks again.

davidpereirocortes | 13 aprile 2020

Hey earlstamford super glad to hear that the factory reset worked for you as well!! My car now is working properly since I did it. What about you? Hope this won't happen again in the future.

Stay safe & healthy!

defade01 | 13 aprile 2020

I tried Factory Reset, but does not work for similar problem.

davidpereirocortes | 14 aprile 2020

What it is your problem about?

defade01 | 15 aprile 2020

More than 5 weeks ago, my phone app can't connect to Model 3 when the car was parked for more than 40min or 1-2hours. Called service center(Hong Kong), they received several similar reports from Model 3 owners, was under investigation, the software was upgraded to 2020.8.2, 2020.8.3 and 2020.12.5, not solution yet.