Tesla app crashing with ios8, iPhone 6, and 6.0?

Tesla app crashing with ios8, iPhone 6, and 6.0?

Has anyone else had problems with the Tesla app continually crashing recently? I have an iPhone 6 with ios8 and my Tesla firmware is 6.0. The first couple of times I used the app it worked fine, but for days now, every time I try to run the app it crashes shortly after the big red T screen comes up. I've tried turning the phone off and on, and uninstalling and reinstalling the app, to no avail.

Fins | 24 september 2014

No issues here try deleting and reinstalling the app

dcpalmer | 24 september 2014

Crashes all the time on my iPhone 4S running iOS 8. It used to work fine - started crashing yesterday. Tried reinstalling, but makes no difference.

aarnold | 24 september 2014

Looks like Apple has stopped the release of iOS8...seems that there are bugs with the Bluetooth and with finding service. Could be messing with the Tesla app as well. Evan, you mention that you are on 6.0...No way you are running 6.0 on an iPhone can only have 8 on an iphone 6.

johncrab | 24 september 2014

No problems here. iOS8 release has not stopped. They pushed out iOS8.0.1 this morning and it had some problems so they withdrew it to sort out the problems.

diegoPasadena | 24 september 2014

I'm guessing Evan meant his *car* is on 6.0

kenj | 24 september 2014

Version 6 - since 9/11, IOS 8 - since 9/17, iPhone 6 - since 9/19

No problems with Tesla app.

@johncrab is correct, IOS 8.0.1 was pulled after an hour due to no service and touch ID errors.

dcpalmer | 25 september 2014

I have a partial solution to this problem - or at least, my problem with the app not working at all on my iPhone 4S running iOS 8: Turn off calendar sharing (Settings > Model S > Privacy > Calendars [OFF]).

By way of background, I tried uninstalling the app - twice - and that didn't fix the problem. I then tried turning off all options: no Background Refresh, no Notifications, no Calendar Access, and the app started up fine, connected to my car, and seemed to work. Turning on Notifications and Background Refresh worked fine - it was only when I allowed Calendar Access that the app crashed. Turning this off caused the app to work fine.

Interestingly, I am able to run the Tesla app on my iPad 3 (also running iOS 8) - and here Calendar Access works fine (for now). So, there is something messed up with the Calendar access on my iPhone. Not sure how to fix this - but at least other iPhone owners with a similar issue have a workaround.

kenj | 25 september 2014

FYI There are actually individual versions of IOS for every device - so it is entirely possible that the Tesla app works on one type of device (iPad, iPhone 6-4s).

If that one app is is crashing here is what you should do:

delete the app, reinstall app then test to see if problem is resolved

if problem not resolved:
delete app, reset all settings (settings -> general -> reset -> reset all settings) this does not delete any data but you will need to reconnect to wi-fi, bluetooth then test to see if problem is resolved

if problem not resolved:
backup (iCloud or iTunes), delete app, erase all content and settings (settings -> general -> reset -> erase all content and settings) this does delete all data and you will need to restore data from backup then test to see if problem is resolved

dcpalmer | 25 september 2014

@kenj: Your "solution" sounds rather too draconian (Windows-ish?) for most users. How many people really want to reset all their settings?!

What we do know - and I pointed this out in my earlier post - is that deleting the app and reinstalling does not work: the problem remains.

What we also know is that the problem appears to be related to calendar sharing. That should provide a clue for a more realistic solution - short of your proposed thermonuclear one. Let's hope someone can come up with something.

dortor | 25 september 2014

this is happening for me also.

dortor | 25 september 2014

on my iOS device - Turn off calendar sharing (Settings > Model S > Privacy > Calendars [OFF])

this worked for me and stopped the application from crashing on launch.

Evanston | 25 september 2014

Thanks for the feedback. I spoke with Tesla service yesterday and they also mentioned reports of crashing and that many are related to the Calendar sharing. They said they think this occurs for people who have multiple calendars on the iphone, because the Tesla app doesn't know how to deal with multiple calendars. Unfortunately, this doesn't do much for me for a couple of reasons:

1. I don't have multiple calendars.

2. My app is crashing immediately on startup, almost as soon as the red screen with the T comes up. I turned off calendar sharing in the privacy section, and that didn't make a difference. I've deleted and reinstalled multiple times, with no success. They said they'd have to "elevate" the issue, but as of now (and for several days), the Tesla app is now completely unavailable to me.

I should say that I've also noticed a lot of other apps that used to work fine -- Facebook, Linkedin, WSJ -- crashing more frequently, so my hope is that this is an ios8-related issue that will be resolved in the near future either by an ios8 update, or a Tesla app update, or both. In the meantime, I'm SOL.

kenj | 25 september 2014


Reset all settings is not draconian, doesn't delete any data. Erasing the phone - draconian.

Maybe the IOS 8.0.2 update will fix the issue. My issue was fixed having to "upgrade" to version 8.0 after the 8.0.1 mess.

My bluetooth was not working for the calls with the iPhone 6. IOS 8.0.1 - no touch ID and no cell service. I was one of the lucky 40,000 -- just like a Tesla owner.

Newampster | 25 september 2014

My results for version 6.0, iOS8 and iPhone 6 are the same as kenj. Tesla app works quite well.

Brian H | 26 september 2014

Happening on many makes of cars. Rollback to 8.0 seems to be current best option.

Evanston | 26 september 2014

@kenj, I reset the settings as suggested above, and that seems to have worked for both the Tesla app and Map My Run (which also was crashing). Thanks!

Techlin2.0 | 15 januari 2015

For me it is the crashing as well, for 5 days now. Tesla is not able to help, Apple (iOS 8.1.2 on iphone 6plus) tells me it is Tesla and Tesla has no idea.

I reset, reinstalled, changes calendar settings, rebooted the S85 screens in all possible settings, turned off phone and MS ....

Any help here?

Thanks a lot!

Chunky Jr. | 15 januari 2015

Does it crash if you put your app into airplane mode? That would tell you if it is something network related. Maybe there is something weird with Tesla's servers that it is returning data that the app doesn't expect.

nathan.dudley | 25 maart 2015

Yes, same problem here. Was able to get it to work by going to Settings -> Model S and turning off Background App Refresh.

shawenswift06 | 24 september 2019

I have met the similar problem that game app keeps crashing on my iPhone. All common methods that I try fail to work well. So, I search Sci-tech Forum for a solution. In the forum, I have found a repairing tool called Joyoshare UltFix. It is said that this tool can cause no damage to your iPhone data while fixing the issue. Therefore, I just have a try with it. Indeed, it does solve the iPhone app crashing issue without any trouble. Just share with you and hope it can help you as well!