Forums

Dashcam icon does not show up on screen

Dashcam icon does not show up on screen

I bought a new flash drive, configured it to MS-DOS (Fat) and added a folder called TeslaCam and it will still not show up in the status Bar. I don't know what I am doing wrong Anyone else having problems and any suggestions? I have the new software version 9.6

hokiegir1 | 11 oktober 2018

Where do you have it plugged in?

M3BlueGeorgia | 11 oktober 2018

Is it FAT(16) or FAT-32 ? Has to be FAT-32
https://www.asus.com/us/support/FAQ/1012303/

Also see hokiegirl1's question...

rtanov | 11 oktober 2018

Looks like MS-DOS (Fat) might not be the same as FAT32 (what the car expects) depending on your machine:
https://discussions.apple.com/thread/3682181
Maybe try formatting on a Windows machine.

EVRider | 11 oktober 2018

Only works in the front USB ports, so make sure you tried it there.

itsnice2be | 11 oktober 2018

I do have it installed in a front USB port. I will now check if I can configure to FAT32 instead of MS-DOS(Fat). I just checked and I do not have an option to Format it to FAT 32. My 4 Format options are Ex Fat, Mac OS Extended (Journaled), Mac OS Extended (case-sensitive, Journaled), and MS-DOS (FAT) I do not have access to a Windows PC. Thanks for the above suggestions. Any other suggestions?

skippydog | 11 oktober 2018

Make sure you make that folder as well. It might be case sensitive as well. Folder name TeslaCam

itsnice2be | 11 oktober 2018

I still can't get it to work. When I type in folder name, TeslaCam, it appears in all Capital Letters and will not let me type it in without using all capital letters. TESLACAM Perhaps that is the problem, but I'm not sure how to get around it showing up in all capital letters. Thanks again for your suggestions.

M3BlueGeorgia | 11 oktober 2018

@itsnice2be

Under the skin, the Telsa is running Linux, and in the Linux world, file and folder names are case sensitive, therefore "TESLACAM" != "TeslaCam"

itsnice2be | 11 oktober 2018

I finally got it working ! ! ! ! Thank you M3BlueGeorgia. The key was being case sensitive. My PC would only let me use capital letters, but I was able to rename the folder after it was created with all capital letters to the correct name TeslaCam. Hopefully this will help other owners in the future as I'm sure this problem will surface again. :-)

mleonard1 | 11 oktober 2018

Are you trying to name the drive TeslaCam? You need to create a folder inside the drive called "TeslaCam".

mleonard1 | 11 oktober 2018

Nevermind! Glad you figured it out.

itsnice2be | 11 oktober 2018

Thank you mleonard1

eschase5 | 14 oktober 2018

I have tried all these suggestions and I still can't get it to work. I am on a Mac and have formatted a 32GB USB 3.0 drive to MS-DOS FAT 32, created a subfolder and named it "TeslaCam" (no quotes) and the icon still does not show up on my MS with V9. Does anyone have any suggestions?

efuseakay | 14 oktober 2018

Are you plugging it in in one of the data ports?

gmr6415 | 14 oktober 2018

@eschase5, Maybe you have a bad USB drive. I formatted mine on a Mac and I've had no problem.

Go to applications>utilities>disk utility app>select the USB drive on the left hand side>erase>MS Dos (Fat), (which is Fat 32)>name it>hit erase

After you finish the erase go to to your Finder, select the drive, hold down the control key and select get info. It will show it's FAT 32.

If it still doesn't work open up the disk utility again and select the USB drive in the left hand window, but this time select the partition that you named. In the lower right side of the center window select "repair disk" and let it run.

Try it again. If that doesn't work you've probably got a write issue with the USB drive.

gmr6415 | 14 oktober 2018

@eschase5, I forgot. Create a new folder on your desktop and name it TeslaCam (exactly). Drag that folder to the USB drive after you have named it.

robmagee100 | 14 oktober 2018

I had the same problem. Tried reformatting the drive using DiskUtility and MSDOS FAT, but still didn't recognize the drive. I think that DiskUtil dropped the Master Boot Record part of the formatting for some reason, so we have to do it manually via the Command Line.

Convert/format USB flash drive to FAT32 by using Mac Command Line

1. Connect your USB flash drive to your Mac computer.
2. Hit cmd + space to run Spotlight, type: terminal and hit Enter.

Bring up Terminal to run Command Line for USB formatting.

Type:diskutil list and find out which disk is your USB drive.
In the below picture, you can see that /dev/disk2 is the USB drive.
Type: sudo diskutil eraseDisk FAT32 MYDISKNM MBRFormat /dev/disk2.

sudo gives you user right.
Diskutil calls disk utility program.
eraseDisk commands to format.
FAT32 sets the file system.
Drive name that you want to call it. Must be 8 characters max, and all uppercase
MBRFormat tells disk utility to format with a Master Boot Record.
/dev/disk2 is probably the location of the USB drive.

I added the TeslaCam folder in Finder, then inserted the drive in the USB port... It took a couple of minutes before the icon showed up on the screen.

tmonteiro | 14 oktober 2018

@gmr6415, thanks for that tip. Creating the folder on your desktop and then dragging it to the USB drive folder was the trick. This allows you to name it on your desktop as TeslaCam since it defaults to uppercase on a Mac.

eschase5 | 14 oktober 2018

Thanks everybody, I have tried reformatting and creating the TeslaCam folder on the desktop and dragging it to the USB drive. I tried robmagee100's suggestion using the command line. All a no go. I have attempted on two different drives, one USB 2.0 and one USB 3.1. Nothing seems to work. I have a 2017 Model S and yes I am putting the drive in the USB slots next to the driver. I have also tried driving around to give it time to initiate.

eschase5 | 14 oktober 2018

Thanks everybody, I have tried reformatting and creating the TeslaCam folder on the desktop and dragging it to the USB drive. I tried robmagee100's suggestion using the command line. All a no go. I have attempted on two different drives, one USB 2.0 and one USB 3.1. Nothing seems to work. I have a 2017 Model S and yes I am putting the drive in the USB slots next to the driver. I have also tried driving around to give it time to initiate.

eschase5 | 14 oktober 2018

Thanks everybody, I have tried reformatting and creating the TeslaCam folder on the desktop and dragging it to the USB drive. I tried robmagee100's suggestion using the command line. All a no go. I have attempted on two different drives, one USB 2.0 and one USB 3.1. Nothing seems to work. I have a 2017 Model S and yes I am putting the drive in the USB slots next to the driver. I have also tried driving around to give it time to initiate.

gcklo | 14 oktober 2018

I formatted with MS-DOS FAT from my Mac and it is working fine. No problem.

gmr6415 | 15 oktober 2018

@eschase5, A couple of questions:

Is the folder named TeslaCam the only thing on the USB drive?

If you select the USB drive in the Finder window, hold down the control key and select "get info" in the pop up window when looking all the way at the bottom of the get info window does "sharing & permissions" say you may read and write? If not either the drive manufacturer locked the drive or at least a partition on the drive, or their is a partition on the drive still formatted in NTSF rather than FAT32.

When formatting are you leaving "security options" set to default? If that selection is set to anywhere except all the way to the left (fastest) you are encrypting the USB drive while formatting.

ODWms | 15 oktober 2018

I bought a 30GB thumb drive online and received it Friday. It came already formatted as FAT 32. I put a bunch of music on it, named a folder I created on my desktop TeslaCam, popped it in the USB slot, and it’s been working fine ever since. The music doesn’t play from the USB as long as it’s in dash cam mode though.

Bdfst8 | 16 oktober 2018

Does anyone know what a dash cam icon without a grey dog and an x in the corner means? When I touch it it does nothing. I briefly had the icon with a red dot this am but not now. Have a 16GB drive formatted to FAT32 in the front USB port of my model 3. Thanks

Bdfst8 | 16 oktober 2018

Sorry, grey dot not dog. Thanks

rsm097 | 16 oktober 2018

@Bdfst8: Had the same grey dot+x dashcam icon issue and the Dashcam stopped working (the Red button disappeared. Basically, I am assuming that there was some issue with the USB drive. So, I have reformatted the USB again (per some forum feedback) and will retry today.

John E Johnston | 21 oktober 2018

Thanks all - same issue. Fixed by running First Aid in Disk Utility for Mac OS X. Didn't need to competely reformat drive. It's rediculous that Tesla released this feature with such a fundamental bug.

LikeEVs | 23 oktober 2018

Everything works on the driver side data port for me but not the passenger side, including just usb stick with music files. Waiting for Tesla Mobile Service to come out. My passenger side front USB port can charge my phones, but data does not work.

georgehawley.fl.us | 23 oktober 2018

Ordered a SanDisk 32 Gb USB thumb drive from Amazon for $10.49. Stuck it in the Mac, found out it was already formatted for fat32. Trashed the encryption folders and created a folder "TeslaCam". Stuck it in the Model 3 right hand front USB port. Dashcam icon appeared in seconds. Easy-Peasy.

sowa.greg | 23 oktober 2018

@eschase5 you mention you have a 2017 Model S; is it an AP 2 car or AP 2.5? TeslaCam isn't supported on AP 2, so that could be the source of your problem (if you have AP 2 hardware).

CorkChop | 23 oktober 2018

@tmonteiro, the only way ‘it defaults to uppercase on a Mac” would be if you were renaming the drive, not renaming the folder on the root of the drive.

Sagarvr | 28 oktober 2018

PROBLEM FIXED!
I too had difficulty getting my MS to recognize the dashcam USB. At first, it worked well. Then after a few days I saw the 'x' symbol on the dashcam icon. Previously, I would reformat the drive, recreate the TeslaCam folder and it would start working again. Went through this exercise multiple days. Yesterday, the reformatting trick did not work. The MS just did not recognize the USB drive which is a SanDisk 32GB mini drive, about thumb-nail size.

I rebooted the MCU and the dashboard computer and that too did not help. Finally, I used a suggestion of a contributor on this blog (SoCal Buzz) and reformatted the USB using the most secure option. On a Mac, it is under security options in Erase. The 'strongest' version (drag button to far right) will rewrite the USB seven times. Be aware that it can take a very very long time to complete, over an hour in my case. Then created the TeslaCam folder and voila! The MS recognized the USB and started recording. Now it is yet to be seen how long it will keep functioning. Fingers crossed!

wallybenson | 1 november 2018

[ IMHO] most USB thumb drives are not fast enough for video, use a mini-flash card V-10 or faster [V-30] in a USB adapter.

jithesh | 2 november 2018

I used a cheap USB drive of MicroCenter brand and formatted on my Mac. I have to say MicroCenter drives are very reliable. It worked fine, never had any issues with folder name case. The only issue I have is once the car goes to sleep I think it somehow corrupts the drive. I have read in forums that many are facing this issue and solution is to stop the dashcam and remove before getting out of the car. I find that inconvenient so hoping the issue will be fixed with next update.

PeteB Lake Oswego | 2 november 2018

@sowa.greg, you mention that Dashcam isn't supported for V2.0. I think I'd heard that somewhere, but I'm not finding any description of limitations in the Tesla instructions regarding Dash Cam, or other places. Do you remember where they would have mentioned it? All the other v9 features, including NOA, work just fine..

https://www.tesla.com/support/software-v9#dashcam

thx

PeteB Lake Oswego | 2 november 2018

Nevermind...Just found the sentence in the online manual where it says "may not be available in certain regions or in vehicles built before Aug 2017" Sucks....mine is Feb '17.

dondatanagan | 29 augustus 2019

How do the pre-Aug 17 vehicles with Sentry mode access the recordings if USB doesn't work?

TeslaTap.com | 29 augustus 2019

@dondatanagan - There are no recordings. Think of Sentry mode as a fake on HW2.0 cars. To the outside, it operates the same (lights flash, the screen appears) when triggered, but nothing is getting recorded. Initially, Tesla didn't provide Sentry mode for HW2.0 cars, but they were able to add "Sentry mode lite", which is better than not having it at all.

tluv3k | 31 oktober 2019

Sigh... I've had no luck with my 2019 TM3 v10 dash cam / Sentry features. I bought a 128GB micro disk inserted into a 3.1 USB mini reader. I've formatted it on a PC to FAT32 leaving all the formatting defaults in place as suggested. I created a TeslaCam folder and STILL no dash camrea icon on my screen. I've placed the car into Sentry mode, the red dot shows up but nothing's been recorded. If Tesla is going to add this feature and CHARGE for it, it oughtta freakin' work a lot easier than this. So frustrating!

hokiegir1 | 31 oktober 2019

@tluv3k - Tesla doesn't charge for this feature.

I know you didn't say, but did you happen to partition your drive for music, or try to put music on it as well? Some people have tried this, and while it will work with partitions (not if it's all together), it's a bit finicky, and requires that the TeslaCam folder be on the first partition, with music on the 2nd.

SnoWaterSkier | 18 januari 2020

@tluv3k - I just went through this process and wish I could tell you exactly what made it work but I was not able to narrow it down. What I can tell you is that I went through a series of quick format / car reboot / re-inserting the flash drive and the last time I inserted, it worked. I am leaving it in for now and will not take it out unless I have an event or it stops working.

rehutton777 | 18 januari 2020

tluv3k: Sentry cam isn't going to record just because the red light shows on the camera icon. There needs to be a specific event (someone close to or touching the car after you leave the car) in order for it to start recording. Next time, have someone who does not have a phone key actually go up to the car when you are out of range. Let us know what happens.

choddy | 9 februari 2020

so if my 2017 Model S was manaufactured on 12/16 according the door sticker, there is no way for the DashCam to work?

EVRider | 10 februari 2020

@choddy: That’s correct. You need HW2.5, which was introduced in August 2017.

@rehurron777: Sentry Mode does record continuously, but it only saves footage in SentryClips if there’s an event.

SigTau9 | 13 maart 2020

Ok Teslafam!!! Y'all are freakin' BRILLIANT!! I have been working on this for days and this was the game changer!! My Model 3 is good to go, with Sentry and TeslaCam!!!! So excited to see what it picks up. I already downloaded the DashView app, so that will be another undertaking to tackle. Thanks again for all the great info... Trial and error, trial and error, but in the end VICTORIOUS!!!! (Time to make a drink....) Cheers!