2019.40.1.1 available, but can't load.

2019.40.1.1 available, but can't load.

This version shows up on my phone as available, but when I click it I get an error message "No software update available".

I do see on the TeslaFi tracker that it is real and starting to go out. I don't know what is going on with mine.

stingray.don | 28 november 2019

Same here. I got a notification of an available software update on my iPhone. Check the iPhone app and nothing showing. Go out to the car and check the software and says software is up to date. Very strange.

teslamazing | 28 november 2019

Be patient.

stingray.don | 28 november 2019

Yeah, I was never very good with patience. :)

teslamazing | 28 november 2019

Happened to me with a prior update. It came back hours later, same day. It may have been pulled temporarily.

NateC | 28 november 2019

I was able to get it last night. It has automatic wiper improvements and "Mad Max" mode for more assertive automatic lane changes.

M3phan | 28 november 2019

If this improves lane change assertiveness, that would be awesome. Eliminate the lag in initiating and make the change confidently.

Sarah R | 28 november 2019

Mine came with it. Yay!

WhiteWind | 28 november 2019

Sarah R, feeling envy )

Devilstower | 28 november 2019

v2019.40.1.1 supposedly contains a feature to address an issue many, MANY owners have complained about. It has a new AI-based, neural network-driven, highly intricate program ... to make the damn wipers run correctly.

Not kidding. Tesla calls the new code “Deep Rain.”

jebinc | 28 november 2019

Installing 40.1.1 now....

melmartin | 28 november 2019

Installing too but it's been strange. It did the download, and I started the update... update seems slow... about 20 minutes into the update my phone asked if I wanted to install it, but it is installing. Checked the car, and it said it was about 1/3 done, and then it said 'updating autopilot'. Now, a few minutes later it says 'updating electronic control units'. Haven't seen that level of detail before on screen... meanwhile iPhone is still suggesting I install the update. Pretty crazy..

Magic 8 Ball | 28 november 2019

Deep Rain must be a play on "Deep Thought", I smell Easter Egg in this one.

coselectric | 28 november 2019

Sweet. The auto wipers definitely haven't worked very well since I got the vehicle, but I figured it was just a matter of time until they improved it with an update. I'm looking forward to hearing some opinions about the updated wiper behavior.

Auto wipers on my old BMW X5 work poorly too, but I won't be holding my breath that BMW will ever fix them. Yay Tesla OTA updates.

Frank99 | 28 november 2019

Just installed 40.1.1. Natec called it - improved wipers and lane changes in NOA.

EVRider | 29 november 2019

According to Electrek, 40.1.1 also adds faster supercharging to some Model 3’s:

Bighorn | 29 november 2019

You need a strong WiFi connection if it hasn’t already downloaded.

Magic 8 Ball | 1 december 2019

Did another wiper drive this morning and they work great. I also noticed voice command to "play" a song or artist is back to working for me.

mrburke | 1 december 2019

@Magic - “ I also noticed voice command”

How do you notice a voice command ?

Magic 8 Ball | 1 december 2019

I simply tried using the voice command that was previously not working and when it worked I noticed it actually worked.

Sarah R | 1 december 2019

I noticed this in the owner's manual:

Note: Software updates can not be performed
when Dog Mode or Keep Climate On is active.

Magic 8 Ball | 1 december 2019

I don't think having Dog Mode or Climate is an issue with getting the OTA updates but having them on, Sentry Mode also, will prevent them from loading once received.

Silver Ronin | 1 december 2019

I'm confused by the fact that I got a software update a few days ago, but when I got into the car the release notes were for the previous release. And now my vehicle says it's on 2019.36.2.3, but people are talking about the .40 release. Am I several releases behind or does it jump from .36 to .40?

M3phan | 1 december 2019

Jumps from 36 to 40
When notes are same as previous it’s a bug fix update.

leo33 | 2 december 2019

@silver According to teslafi, today most people are still on 36.2.1, and most who are receiving updates are being updated to 36.2.3, with a few being updated to 40.1 and 36.2.1.

Any particular car may be one of the first to receive one update, one of the last to receive another, and may skip certain updates along the way. A little confusion about it is understandable, but not being on the very highest revision number is no cause for worry.

St☰v☰ | 2 december 2019

So other than the super charge benny, .40 only really applies to those with FSD?

Daryl | 2 december 2019

I'm the OP. I've been through many updates since I got my Model 3 a year and a half ago, but this is different, with my phone continuing to tell me an update is available. When I select the feature and say to Install, it pops back and says "No update is available".

Rebooted the car and the phone, wiped the cache on the app, and it continues to tease me with an available update that is not really available.

I'm not complaining; glitches happen and I'll get it when I get it. But I was wondering if anyone else had seen this kind of situation and had a way to either force the update or remove the tease. Apparently not.

ajgianoli | 2 december 2019

I got 40.1.1 yesterday. But for the first time, I didn’t get the normal update notification banner when first turning on my phone. That’s ALWAYS happened. The app itself, then the car’s screen told me. Different.

Same notes: better wiper and lane-changing functions.

JAD | 2 december 2019

Daryl, the app was just updated, did you get that update?

82bert | 2 december 2019

Assertive lane changing with 40.1.1 is a significant and welcomed improvement. Very much liking this style of NOA/AP.

Daryl | 2 december 2019

@JAD "Daryl, the app was just updated, did you get that update?"

I hadn't noticed that the Android app was updated, and just installed the new version now.

Unfortunately nothing has changed, and it still teases me that the car update is available, but really isn't.

Joshan | 2 december 2019

jump in chat and talk to them. I had an update get stuck once and they cleared it for me.

rehutton777 | 2 december 2019

I'm envious! I'm still on V36.2.1. I have not had problems getting software updates in the past - - just wondering where the recent updates for my car went? Others out there with delays in getting up to 40.1?

M3phan | 2 december 2019

Am on 36.2.3, no sign of 40 yet. : )
Software updates set to Advance, tickled it 5 times 5 times 5 times 5, nada on that placebo.
All good. It’ll come soon.

Patronus | 2 december 2019

It looks like 40.1.1 has stalled.

I'd anticipate another 40.X update in the next few days that might reach mass distribution. This happened with 36.2.X.

Daryl | 5 december 2019

I am the OP. I read on the Model 3 Owners Club forum that several other people had the same problem of an update notification that won't go away, though nothing is available.

My car finally downloaded and installed version 2019.36.2.4 and the bogus "Update Available" notification finally disappeared.

Still hoping to get 40.2 soon, but it is coming out slowly.