Outdoor temperature/thermometer issue

Outdoor temperature/thermometer issue

For the last two days, my read out (instrument cluster) for my outdoor temperature has either been "---" or has jumped around to some varying inaccurate negative temperature. The outdoor temperature has ACTUALLY only been between about 20 and 30 degrees Fahrenheit.

Tesla customer support advised me to reset both the instrument cluster display and center touch screen display. I have tried both to no avail.

It is winter in Iowa and I'm wondering if there is some kind of dirt/ice/snow buildup on the outside thermometer on the car. Has anyone had this experience or can anyone point me to where the thermometer is? An old post from around 2016 states it is near the bottom driver side of the front end of the car. However, this was for the previous Model S front end style.


tes-s | 21 februari 2018

Have it fixed next time your are in for service. Yours is not the first MS to experience winter.

EVRider | 21 februari 2018

Try taking your car to a touchless carwash that has an undercarriage wash and see if that helps.

Bill_75D | 21 februari 2018

Your Tesla is telling you that it hates Iowa and wants to go home to California.

Silver2K | 21 februari 2018

have you tried resetting with the brake pedal down all the way?

try that if you haven't. the procedure does a deeper reboot. it's not noted (from what ive seen) anywhere, but i think that process clears the short term memory.

jaykasperbauer | 21 februari 2018

Bill_75D Very true. Someday I may wake up only to find an empty garage and that my Tesla has driven itself to some place warmer.

Silver2K I have not tried the break pedal hard reboot. I will try that, thank you!

Stay tuned.

jaykasperbauer | 22 februari 2018

Still no luck, even with the hard reboot. I'll wash the car and pay close attention to the front end when the temperature warms up. Hopefully that does the trick. If not, I'll be bringing it to a service center.

p.c.mcavoy | 22 februari 2018

Sounds like an electrical short to the temperature sensor. GIven it flips between no reading and a low negative value, I’m guessing an intermittent connection with it going open circuit. I’d contact service. Given you don’t have a service center in Iowa, hopefully they can send out a ranger/mobile service to address it for you.

Just curious, where you at in Iowa? I grew up in SE corner of the state, my wife’s family in CR area, and both my wife and I are Cyclone grads.

Silver2K | 23 februari 2018

i looked through the fuses and did not run into a fuse for outside temp sensor either. unless i missed something?

DonS | 23 februari 2018

The temperature sensor is probably a thermistor, but could be a thermocouple. In either case, there would not be a fuse in the circuit. There is probably corrosion where salt water seeped into the sensor or a connector. Less likely, it could be a broken wire between the sensor and where it is measured.
I suppose Tesla service would replace the sensor as the easiest thing to try. If that doesn't work, then troubleshooting gets more difficult.

patrick.holliday | 17 april 2019

Any lucky getting it fixed? Mine is now showing “- -“