Forums

Tesla, please fix you ordering page..

Tesla, please fix you ordering page..

I will never think a Tech company has so much problems with their ordering web site.

This morning all pictures from Model 3 configurator page disappeared, and now the pictures comes back.

After ordering, I try to register two owners. While I try to upload 2nd owners driver license, it keep saying uploading. I tried few different browsers, the problem is the same.

spuzzz123 | 27. april 2018

It's a tech test. If you can't pass it, you shouldn't be driving one.

andy.connor.e | 27. april 2018

Tesla please check your horderving page.

seanxushen | 27. april 2018

I was working in High Tech companies, and I know what is I am talking about,,

andy.connor.e | 27. april 2018

I worked in a High Tech company, which gives me authentication to tell someone else what to do! Perhaps some more horderves.

JuJo0 | 27. april 2018

It could be your internet connection... Try resetting your router, or connect elsewhere to a different network and see if that works?

JuJo0 | 27. april 2018

Sorry, not router, your modem.

seanxushen | 27. april 2018

The 1st owner driver license picture (front and back) and 2nd owner driver license back page uploaded fine. Just 2nd owner driver license front page could not be uploaded. I try the three different browser, same problem. I tried reset Cable modem as well as even try to VPN to US, all same..

andy.connor.e | 27. april 2018

@sean

Wait a day, try again.

Xerogas | 27. april 2018

It's always good news when their ordering page starts acting up -- it means they're modifying it in preparation for some new options! AWD, white interior, etc. could be on the horizon!

LostInTx | 27. april 2018

True story - the day I was invited to configure, I dislocated a finger playing basketball. When you're positioned for a rebound and the guy's shot barely grazes the front of the rim, the ball comes straight down and inevitably finds your finger. Each and every time.

Where was I going with this? Oh yea, configuration.

Between painkillers and, uh, pain the painkillers failed to manage, my early 20's daughter, tech-savvy as all get out, configured my car for, plugging in the insurance, driver's license, and trade-in information.

It took her about 3 minutes to do it all but while walking away, said: " hope the car is cooler than the website because the website sucks".

Who am I to argue with that level of logic?

spockagain34 | 27. april 2018

You tried a VPN to the US? where are you ordering from?

seanxushen | 27. april 2018

I am a Canadian BTW.

jefjes | 27. april 2018

What andy said. Uploading the info shouldn't delay your order as long as you have configured and paid the additional $2500. Just try again another day to complete the process of uploading the stuff they ask for. I'm still waiting to upload the insurance info and I need a VIN to complete the insurance buying task to do that, so I called and they reassured me that I have plenty of time to do all the upload task before getting the car and it wouldn't delay the process as long as it is done prior to the delivery day. I've seen other post where buyers suggested using their cell phone to complete the tasks as it simplifies the picture taking and then uploading without having to scan or send the pictures to another device.

maintreqd | 27. april 2018

@seanxushen take a new picture of the 2nd license. Your picture may be corrupt or, for any litany of other reasons is giving the site trouble. It may be too big. It may be wrong format. Make sure it's jpg and small (under 1MB)

If you're unsure email it to a computer and check file size.

If you're using a computer, try your smart phone. If using a smart phone, try your computer.

If none of this works, I'm sure you can likely register the 2nd owner when you pick up the car.

FifthOnLeft | 27. april 2018

I recently configured and am waiting for VIN. I live in the Bay Area near Fremont and have the luxury to choose from 2 delivery locations. I remember choosing Fremont delivery center, but my account web page doesn't show that info. Anyone knows how to check or is this a bug?Thanks

greg-desandro | 27. april 2018

I'm having the same problem. I have tried multiple computers, smartphones, browsers, modem and router reset, etc.

riverFox | 27. april 2018

I ordered on 4/15. The Tesla site said my payment failed, but upon further inspection my credit card was charged. Tesla is aware of the issue and they're still working on syncing my payment to an order for my account. It's been 12 days with no resolution...

I was told it happened to a number of accounts and that I should still expect delivery in 3-6 weeks from when order was placed. We'll see :)

elliott353 | 19. juli 2018

I'm on deck to take delivery of a Model 3 in about a week. I have a trade-in. The text was forwarded to me for the Trade-in Self Evaluation. When I get to the Submit button after taking all of the pictures it won't upload. It keeps giving me the message"Unable to save your data at this time. Please report this issue or try again later.". Now I did submit the same photos to the guy who (I guess) is my sales advisor by email. He said they just decided they don't need them anymore. It has me a bit concerned.

rolandhordos | 14. mars 2019

SOLUTION: Click the Canadian flag at the bottom of the browser and change to US. Upload the 2nd image and switch it back.

Still a bug Mar 2019 on Canadian orders with 2 registrants, mobile and desktop browsers. I'm a software engineer and this is a weird bug.

tesla | 27. august 2019

still broken....