No Lane change when Using EAP

No Lane change when Using EAP

When I was using EAP yesterday, it turned off every time I put on the turn signal instead of changing lanes. Is this a bug in the system or just with my car?

pjalan | 09. august 2018

Just your car?

COrich | 09. august 2018

Auto lane change is not supported on all roads. You will get an indication on the driver's display that auto-lane change is available. It will show an additional lane line to the side of the vehicle that you can use for auto lane change. In other words, you should see an additional lane to the side, not just the lane edge for your current lane.

jimglas | 09. august 2018

no second line, this was on interstate and has worked on that section of road in past. I will try re-booting the car.

jimglas | 09. august 2018

FWIW: Re-booting car did not help. Still no lane change. Problem sent in to Tesla

jjgunn | 09. august 2018

@jimglas - Try disabling Auto-Lane Change, EXIT the menu, then re-enter & re-enable Lane Change

jjgunn | 09. august 2018

It may even be turned off - happened on 1 of the firmware updates

ek993 | 09. august 2018

Lane change doesn't work on my car either. Took delivery of the car last Friday. Tried it on I287 in NY and I95 in CT. Am on 2018.21.9 75bdbc11

jimglas | 09. august 2018

@jjgunn: Was turned on. I followed your suggestions. Shuld get a chance to try out on the interstate this weekend.

jjgunn | 09. august 2018

Stating the obvious here - but make sure you're clear of traffic when executing the lane change. If any cars are too close the car won't move. Most people set their following distance at 3 or 4.

markcohen | 10. august 2018

@jimglas, I have had and reported intermittent and version dependent issues with auto lane change not working, but I've never experienced a "solid" fail like you are describing. Reading through your posts, it looks like it used to work for you so I'm assuming that you know how and when to use it. If you need help here, please feel free to ask.

If you haven't already done so, report the issue when it happens by activating the voice reco and saying something like "Bug report auto lane change failed and disabled EAP". Ironically I have found "Bug Report" itself to be buggy.... If it works you should see it recognize something reasonably close to what you said AND in the center of the dash display it should say that the bug report was accepted. I would also recommend going into the manage your vehicle page and sending them an email about the issue. If you do, note the approximate time and the fact that you sent a bug report from the car.

jimglas | 10. august 2018

@jjgunn: nobody in the lane I am changing too. Very rural interstate which makes EAP very relaxing. Only change lanes when I happen to come upon another vehicle.

@MarkCohen: Failure has been reported thru manage your vehicle page, thanks for the "bug report" suggestion. I will do that also.

ek993 | 10. august 2018

Same with me - absolutely no cars in the lane next to me. The setting is enabled in the settings | 10. august 2018

There are also GPS areas that are locked out for auto lane changes. For example, in California, route 5 freeway in some rural areas has unmarked a dirt road "intersections", perhaps for farm equipment. These are almost never used and don't appear on the map. Lane change is locked out about 1 mile on either side of these unmarked intersections. Took me a while to discover this.

Vawlkus | 10. august 2018

When you try, does the lines on your display go to dashed lines or stay solid?

If they stay solid, it means the car is referencing the map of the area, and that road is not delineated as more than one lane.

jimglas | 11. august 2018

Tesla Résponse, done, I will try later today:
Thank you for contacting Tesla Customer Support. I checked on your Model X information and found that the car recently received a firmware update. Occasionally the firmware update will complete but the car doesn't complete a full restart and sometimes that can cause other issues. Please follow the below steps to troubleshoot and that should resolve any issues.

Please follow the steps outlined below to perform a reset / reboot of your vehicle’s touchscreen and instrument cluster (dashboard screen). After the reboots have been completed please follow the steps to complete a power cycle reboot.

1. Place your vehicle in park at a safe location.
2. Unplug any USB Devices from the center console.
3. Place your foot on the brake pedal and hold it down for the duration of the reboot.
4. Press and hold both the left and right top buttons on the steering wheel until the small screen goes off, and continue to hold until you see a gray screen with a Tesla logo.
5. Press and hold both the left and right scrolling wheel buttons on the steering wheel until the instrument cluster screen goes off, and continue to hold until you the touchscreen illuminates and displays the Tesla logo in the center.

Power Cycle reboot
1. Place your vehicle in park at a safe location. Please ensure that all the doors are closed and that the Car is not charging.
2. On the touchscreen please press on 'controls'
3. Press on 'E-break / Power off'
4. Press on 'Power off'
there should be a message that asks you, are you sure you would like to power off, please press yes.
Once the car powers off, set a timer for 3 minutes.
Once the 3 minutes have expired, press your foot to the break to re-awaken the car.

If the above troubleshooting steps don't resolve your problem please call us at 877-79-TESLA and our Vehicle support team can assist you further.

jimglas | 11. august 2018

"Press and hold both the left and right top buttons on the steering wheel"
I couldnt find any "top buttons" that did anything when I held them down so I pushed the scrollwheels (twice)
I hope this works

markcohen | 11. august 2018

If you press and hold the up buttons (the ones just above the scroll wheels) with your foot on the break and hold them til the dashboard display first goes off then gets the T logo... that is what they are looking for you to do.

jjgunn | 11. august 2018

Just press the area 1 inch above both scroll wheels.

These are buttons too

jimglas | 11. august 2018


jimglas | 11. august 2018

When trying to follow the instructions:

4. Press and hold both the left and right top buttons on the steering wheel until the small screen goes off, and continue to hold until you see a gray screen with a Tesla logo.

No matter how long I hold both the left and right top buttons on the steering wheel, the small screen never goes off.

When I Press and hold both the left and right scrolling wheel buttons on the steering wheel both screens go off and then return.

Any suggestions?

markcohen | 12. august 2018

Do you have your foot on the brake at the same time you are pressing the top buttons on the wheel?

jimglas | 12. august 2018


markcohen | 12. august 2018

@jimglas, I've done it before but did the reboot on my car again so that I could tell you what to expect. I depressed the brake and held it while sitting in the car with the doors closed. I pressed the upper buttons and held them. It took about 15 seconds for the dashboard display to go black. After another 10 seconds a T appeared. I let go of the buttons at that point and kept my foot on the brake. Pretty quickly after that the display came back.

gajani1057 | 17. februar 2020

Katmoviehd Website 2020: KatmovieHD is a movie downloading website, where you can watch and download the latest Bollywood and Hollywood movies free. Check KatmovieHD website daily for new content. Link: