Navigate on Autopilot disappeared from my car

Navigate on Autopilot disappeared from my car

I purchased FSD about 3 weeks and since then I have been using Navigate on Autopilot daily. As late as this morning, I used it. This afternoon on my way back home, I first noticed that on the map it no longer showed the option. I thought maybe it was due to the location I started the route and NoA was not available. I tried a couple of times on the highway by changing the destination, it still did not show. After I got home, I reset the screen, again no help. Then I checked the AutoPilot setting, I noticed the option "Navigate on AutoPilot" no longer exists as if I did not purchase the option.

Does anyone else have the Navigate on Autopilot gone?

DermMD | 11. april 2019

Same here

Mwoosley71 | 11. april 2019

I have noticed that the “Navigate on AutoPilot” is grayed out if you haven’t selected it before initiating the drive, but the option has never disappeared altogether.

RoadDevil | 11. april 2019

Mine came back after the recent software update 2019.8.5.

Czardmitri | 11. april 2019

Mine disappeared yesterday afternoon along with cruise control. Did a reset and then a hard reset. Still missing. Drive most of way home without it. Picked up daughter at school, still gone. Drove home, went in house briefly. When I got back in car a few minutes later NOA and cruise control were back. Weird.

johnmagyar | 20. april 2019

Mine disappeared yesterday. Soft reset and hard reset multiple times - didn’t help. Support told me to schedule service, so I set an appointment. Today, it’s all back. Canceled service appointment.

louiselouis1 | 04. kan 2019

Same happened to me this morning. No more nav on auto. Also the app doesn’t display the summon or sentry option. Any insight is appreciated

raffidesigns | 04. kan 2019

I have noticed this as well. I believe this is a way for Tesla to weed out owners with FSD and those with just autopilot. Similar to the premium connectivity. After a year it disappear until you pay monthly.

Or maybe I’m wrong and our cars are glitching out.

EVRider | 04. kan 2019

@raffidesigns: Yes, you're wrong. :-) The people who are temporarily losing navigate on autopilot already paid for it. No one with the new basic AP ever had navigate on autopilot or Summon.

louiselouis1 | 04. kan 2019

I just find it interesting that the free 14 day trial had it on the car and app as of yesterday. That’s why I opted for the upgrade to AP. in addition the sentry is gone and i haven’t checked dog mode yet. I know the games are still there. And sentry and basic summon was on the regular update and working until I purchased AP.

In a business environment we would call that false advertisement.

Thx again for ur responses

louiselouis1 | 04. kan 2019

Just read the Tesla info about the trial. They mention the trial was for FSD and the upgrade was for AP. pretty sneaky in my book. Always helps to read something before a purchase.

Still does not explain summon and sentry. Still ha e 2019.12.1.2 showing and that was working in 12.1.1.

Davindersekhon | 05. kan 2019

I am having the same issue. Was told by the service centre that map update need to happen via WiFi but it is still haven’t kicked in after 4 days. Scheduled an appointment to get it fixed.

Howieshagen | 17. kan 2019

Davindersekhon, did you get it fixed? My autopilot disappeared after 2019.16. Just made an appt with the service center. Did they help you?

danwassink | 19. kan 2019

I had the same issue - no cruise, cameras, or autopilot. I tried resetting and powering off numerous times. Didn’t fix it. I talked to Tesla, they couldn’t fix it. They wanted me to schedule a service appt. I then went and did some research and I read in a forum that the car does diagnostics upon waking up from a sleep. If it finds anything wrong, it shuts everything down. So the key is to let it sleep and when it wakes up, it will do another diagnostic run and, if all is OK, everything will be back. This is what I did and my cameras, cruise, and Autopilot came back. Why wasn’t it able to sleep in the first place? I had a few third-party apps connected to my car. This kept my car awake. I looked at the log files and it has been days, if not weeks, since she slept. So I needed to disconnect all the apps and start over. To do this, I just changed my password to Tesla. Once I did this, all the 3rd-party apps were disconnected. Now I needed wait a few hours so my car could go to sleep, I waited overnight. When I went back to my car the next morning, everything was working once again. I had a 10 hour drive back home, I was glad to see it all back! Now I can’t say this is for sure this is what fixed it, but I tried everything, including resetting and powering off. Nothing worked, until I changed the password. Could be coincidence, but if you are having the same issue, give it a shot, change your Tesla password, let it sleep for a few hours. It may work for you too.

Marvelones | 01. juni 2019

I had the same issue since I received the car in May. Talked with the programming team and it turns out the issue is related to Sentry Mode. They know about the issue and have been working on it. Now it is an issue with the current 16.2 update as well. They had me disable the sentry mode, remove the flash drive and allow the car to sleep.Letting the car sleep will temporarily fix the issue but if you don't disable the sentry mode and remove the flash drive it will just keep re-occurring. This restored everything for me. Now I just have to wait until the fix is available. They say they are close.

markr7 | 01. juni 2019

Try this:
Posted elsewhere on this forum...


1. Make sure you vehicle is not plugged in or charging, make sure the vehicle stays parked, make sure the doors are closed, make sure the windows are up, keep your feet off the brake and acceleration, and try not to move around in your seat too much.

2. Hold in the scroll wheels on the steering wheel until the screens go blank and then release.

3. When the MCU reboots, select controls, safety and security, power the vehicle off.

4. Wait for 3 full minutes. (if the vehicle powers itself on during this time, double check that all the conditions from step 1 are met and start again).

5. Power the vehicle back by opening and closing the door.

bcmusik | 09. juli 2019

Wow, having the same issue. I'm on 20.4.2.
Navigate on Auto Pilot no longer shows up but all the options/settings are still available in the menu and even summons still works. I'll wait until tomorrow and see what's up, Tesla must be doing something and it'll sort itself out.

bcmusik | 13. juli 2019

It came back the next day just slightly different. Navigate on autopilot used to show up no matter what nav destination I chose (somewhere down the street or somewhere that required getting on the freeway). Now it just shows up if a freeway is part of the navigation. No Freeway then no option to navigate on autopilot.

EVRider | 14. juli 2019

@bcmusik: I think Navigate on Autopilot has been like that for a while. Which firmware version did you have before the update?

UL8 | 14. juli 2019

It seems like it is my turn now,- Navigate On Autopilot option disappear from my model 3, Like I would never even bought it. I am on 2019.20.4.2
Multiple restarts (removed usb) didn’t help. My Tesla Model 3 account shows FSD option is available for purchase! Sent message to Tesla support and waiting for their explanation.

EVRider | 15. juli 2019

@UL8: Did you read the previous replies?

UL8 | 15. juli 2019

Yes, but it doesn’t explain why this is so random happens. I tried to disable Sentry mode and remove USB, reboot it multiple times without much help. So, I’ve been waiting for model technician come to my house and take a look at it.

ccq | 17. september 2019

This happened to me last night - no autopilot, etc. I had just upgraded to FSD on my new Model 3 about 12 hours prior, and there also might have been a software update. That said, I followed the full power off procedure that markr7 posted above and it worked like a charm. All set now.