Max Battery Power Missing - Firmware 2019.8.3

Max Battery Power Missing - Firmware 2019.8.3

Anyone else with a Performance model missing Max Battery Power after the latest firmware update?

The Ludicrous+ tab is there, however Max Battery Power is not displayed and the fans don't come on at all. Launch Mode also doesn't work.

My Screen

Someone Else's | 01. april 2019

I don't have the feature, but I thought I saw something about it changed names or operation in the current 2019.8.x version. I suspect instructions are in the release notes (hopefully). | 02. april 2019

@larrydavidow - after the install did you reboot holding the brake and pushing the scroll wheels?

larrydavidow | 02. april 2019 yes, I did. Multiple times., yes they have changed the location of Max Battery Power. It now shows as Ludicrous+ (You can see that in my screenshot). The issue is it does not show the battery heating which means it is not in Max Battery Power mode. Launch Mode doesn't work either.

The Service Center pushed 8.4 to my car and it did not fix this. I have an appointment this coming Monday to take it in so I guess I will have to wait until then for them to look at it.

ryanautry | 02. april 2019

Larry, I'm having the same issue with my P90DL. 2019.8.3 took away my max battery power and launch control. I have the Ludicrous+ button, but it doesn't do anything.

Please keep us updated.


larrydavidow | 16. april 2019

Sorry I didn't update this thread. I have a few others going. Since this post, nothing has changed. Updated firmware to 8.5 and things are even more buggy. Random main screen reboots while I'm driving, very poor Bluetooth performance - phone call just stops playing through the car's audio system and i have to quickly switch it back to the handset to continue the call. It shows connected to Bluetooth on the phone but there is no audio. Interestingly, the other party can hear me.

Before my appointment, I did a factory reset to see if that would help. It actually broke it even more. After the factory reset, when I held the two scroll wheels down, the whole system would crash and factory reset. The tech said a number of files and directories were missing from the operating system and they had to copy them back from another image. Quite a cluster f...

When I picked up my car, the SC tech said they couldn't fix max battery power/launch mode and I have to just wait for engineering to fix it in a future firmware. I didn't like that answer so I met with the manager. I expressed my dissatisfaction with this whole situation. She took my info and gave me her personal cell phone number. She called me back a few days later to inform me that an official bug has been logged with engineering as they have received multiple reports globally for this issue. She said they are working on a fix but there's no ETA. I'm giving them two weeks and then will take a different approach.

zubinanary | 17. april 2019

The way I understand it starting with 2019.5.x is this (I can only speak to the Model S P100D here, not the previous P90DL):

(1) Max Battery has been replaced with a Ludicrous + Accelerator Mode which is why we see that now. The Release Notes also make reference to this. When you pick that acceleration mode, you will still get the older Max Battery dialog box, however this is not showing up for everyone so that's one of th bugs I believe. I do get the Max Battery dialog box and when I then tap on the Max Battery button, it then tells me how long it will take to reach the right temperature.

(2) There is also the older "Ludicrous +" Easter egg Mode, which changes the instrument cluster by showing more detailed telemetry. That is still there and is found by a Tap+Hold on the Ludicrous + Acceleration Mode button, or going through the Easter egg menu. When you do either one, on m P100D you do get the "Bring it On / No, I want my Mommy" dialog box, and then when it reaches the right temperature, you see all of the telemetry on the left side of your instrument cluster.

There is clearly a problem here, and I wish they would make them one in the same, Ludicrous + (formally Max Battery) and the Ludicrous + (Easter egg), Maybe that was their incomplete attempt in the 2019.8.5 software update. I don't know if anyone who is on 2019.12 (Early Access Program) can tell us if it's fixed or not, but hopefully soon we'll find out.

larrydavidow | 17. april 2019

So here's where I believe the code bug is. P85D and P90D (insane/ludicrous) never got the prompt (no I want my mommy/yes bring it on) in any previous firmware. That was reserved for the P100D. I believe that the max battery code has a dependency on that dialog box snippet of code being there which means when we select ludicrous plus, there's no prompt, hence no max battery power hence no launch mode.

If someone can confirm my suspicions that P85D and P90D owner's never got that prompt (ever), then I have a good amount of certainty that's where the issue is.

Razorx1337x | 18. april 2019

I didn’t get the prompt before the firmware update. Still waiting for my precious max battery/launch mode to come back :(

ryanautry | 25. april 2019

Was anyone (P90DL owners) able to get an answer or update from Tesla?

larrydavidow | 27. april 2019

From my SC...
"The performance and launch control issues are still under investigation"

jlhm | 30. april 2019

Just got 2019.12.1.1 for my P90DL and no max battery.

kurfer | 01. kan 2019

My SC said this feature was most likely not coming back for AP1 users. This was a shady attempt to take away from AP1 in hopes to phase them out. Terrible way to run a company, at least gives us 5 fking years to pay this crap off before you rip us of features on a car we laid down $120k+ on.

My trust in Tesla is 100% gone.

jlhm | 01. kan 2019

@kurfer if that is true tesla can forget me to upgrade to the P100D.

kurfer | 01. kan 2019

It’s crap timing for me too as we JUST sold my wife’s Wrangler to place and order on a new m3 sport for her. I am going to give her my p90l and go back to BMW. I’ll hold off on EV until a reputable company invests in EV.
The shady thing about all this is that the SC are in the dark and Tesla won’t make a statement as it’s been a month now

Sonofman | 01. kan 2019

I can't believe so many are mad over a bug. You're not using launch mode daily, most of us haven't used it unless you're giving a ride to a friend since we bought the car. They'll fix it and it will be OTA.

I can post a million recalls from BMW and the like and they aren't OTA fixes, but Tesla seems to be held to a different standard.

They just sent the big update so relax.

JohnnyG | 01. kan 2019

The problem is, it's been broken for multiple releases now, yet I just got a new Atari game... yay (sarcasm).

Delivering new features is nice, for sure, but breaking existing features is not acceptable. This goes for all industries. Your priority should be to return the item back to it's last usable state. Then go back to the drawing board and figure out what you did wrong.

Tesla is not held to a different standard... The difference is that they have been pushing many defects to the vehicles over the past 6-9 months, which is beginning to wear on people. If you add a new feature, and it doesn't work, okay, fine, go fix your bug. However, if you break an existing feature, then you better move quick to fix it, or blackout the change until you can. It's just that simple.

ST70 | 01. kan 2019

@Sonofman- My doctor prescribes me to do at least 5 Ludicrous launches a day...don't need a chiropractor anymore

larrydavidow | 01. kan 2019

@Sonofman while I understand your perspective, it's somewhat irrelevant. This issue is not impacting you. I promise you, if you lost 100hp over night, you'd have a different perspective. I bought my car a month ago and paid for the 570KW it was making. It's now making 510KW.

On top of that, my main screen crashes daily while driving. The AC shuts off when this happens and it's very disconcerting to drive like that not to mention a bit embarrassing trying to explain to friends and family that this is a temporary issue and will be fixed.

Also, when receiving or making a call over Bluetooth, there's no audio for 15 seconds, so I have to manually switch to the handset to take my call until the audio comes back. That's another safety issue.

My homelink doesn't work at all.

My nav system resets every week and looses home/work and history

Various vehicle settings (door lock on walk away) reset themselves to default randomly which is another security issue. I'm expecting the car to lock and it doesn't.

This was ALL working perfectly fine on 2018.50.x, so it's not some kind of hardware/storage issue. This is straight garbage code. And yes, I'm running the latest firmware 2019.12.1.1 and nothing has been resolved.

So yes, I understand your perspective however it's not relevant.

larrydavidow | 01. kan 2019

I've created a poll to track this. Feel free to add your issues

Kka | 02. kan 2019

any update it it is by design that we dont have a launch mode, or a bug

kurfer | 02. kan 2019

Has anyone tried tweeting out to Elon and Tesla for an update? Even if no response it may raise awareness. After speaking to my service manager I feel they are clueless and there is a horrible communication chain between service centers and Tesla engineers, almost like it’s two different companies.

Sonofman | 02. kan 2019


It sounds like you're having other MCU issues beyond missing Max Battery. My P90L did loose the same HP yours did, but it's phantom as you're not using it daily and they will patch it back. That issue isn't any different than issues from Apple for example.

To fix the phone thing, I've had the issue since day one where I would call someone but I couldn't hear them. Bump your left volume wheel up when you make a call and it will switch to call audio. It's pretty easy and is quicker than trying to hit the phone button.

I'm on 2019.1.1 with my P90DL and my wife's P85+ and homelink is perfect, maps are fine, vehicle settings fine, MCU rebooted once on the 90 but has been fine since a hard reset. I think you're needing an MCU fix.

Kka | 02. kan 2019

ok , but i gues you launch dont work ?

larrydavidow | 02. kan 2019

@sonofman thank you. I tried the scroll wheel trick and that worked perfectly. I realized someone else on the TMC forums had mentioned the same thing but I think I was blind with rage :).

I guess it's plausible that I have MCU issues, however this just started when I upgraded to 2019.8.x. I've been a systems engineer for over 20 years (Storage, Virtualization, Network, Windows, Linux, IBM Power) and now manage a team of engineers, so I've had my fair share of exposure to firmware and how it can render hardware completely useless. One of the first things you ask yourself when troubleshooting something is "what changed?". I didn't make any hardware changes. It was all firmware. I have to stick by that approach and make the assumption that all of my issues are firmware related until there's evidence it's hardware related.

Here's some ongoing results from the poll that are quite interesting. It seems like we all share most of the larger issues.

Excel -
Web Based (IE) -
Google Apps -

Razorx1337x | 02. kan 2019

Still missing launch and max battery. Are they going to refund the $20k it costs for those features specifically?

larrydavidow | 02. kan 2019

@razorx1337x I asked the manager at my SC that exact question and I did not get a straight answer - other than she was logging an issue with engineering.

Silver2K | 03. kan 2019

kurfer | May 1, 2019
It’s crap timing for me too as we JUST sold my wife’s Wrangler to place and order on a new m3 sport for her. I am going to give her my p90l and go back to BMW. I’ll hold off on EV until a reputable company invests in EV.
The shady thing about all this is that the SC are in the dark and Tesla won’t make a statement as it’s been a month now

Why not get a Jaguar ipace, Audi Etron SUV or other evs? Are you telling me those are not reputable or are you just being an ass?

Silver2K | 03. kan 2019

larrydavidow | April 27, 2019
From my SC...
"The performance and launch control issues are still under investigation"

That's code for stop bothering us with nonsense

No mystery about it.. it's been removed!!AihnWpuO55swiPJNgoHvw18QRFi2_w

Silver2K | 03. kan 2019

Ooops.. forgot to add

Acceleration has changed and so has other options, but if enough complain they will bring it back.

larrydavidow | 07. kan 2019

Bumping this so folks that have not yet upgraded see this thread and don't end up in the same place seeing as Tesla is not notifying its P85D and P90D customers of this issue or withholding the update from those vehicles.

kerryglittle | 07. kan 2019

Same here.

jlhm | 07. kan 2019

FYI, latest update I’ve from Tesla to get it fixed.

“I have submitted this to be escalated, likely that will be fixed with an update so we appreciate your patience while we work through it.”

Razorx1337x | 08. kan 2019

maybe if we all tweet Mr. Musk he'll be drunk/high enough one night to respond ;)

kerryglittle | 09. kan 2019

Elon does like a little nip now and then. Also been know to smoke the Devil's Lettuce too now and then.

kerryglittle | 09. kan 2019

Good article @Boonedocks. So wouldn't an easy fix be for Tesla to push out the previous update to correct this problem? I mean most people don't need or even use launch but when we paid for that feature it should be available.

Boonedocks | 09. kan 2019

@kerryglittle I sure hope so!! My P100D +L is on order and should be delivered “soon”

Sonofman | 09. kan 2019

@kerryglittle The update carried a lot more improvements so loading a 2018 version is worse than missing launch mode.

I like having a better browser, dog mode, GPS mirrors, faster supercharging, update tab etc.
I didn't see anything in the notes but my auto park has been more responsive as well.

Hopefully they push a fix soon though.

kerryglittle | 09. kan 2019

Yeah there are so good stuff there Sonofman. Loving the folding mirrors option. I don't have a dog and if he did it would go in my wife's Chevy. Some how sharp claws and dog hair and drool from having its head sticking out the window don't appeal to me. LOL.

MilesMD88 | 09. kan 2019

After reading this, I went and checked. Sure enough, my P85D no longer has Max Bat. But it does have insane mode and insane + mode.
There are no update notes.
Owners manual has no reference to “Insane +”
If anyone knows what insane+ is, chime in.

kerryglittle | 10. kan 2019

Its been gone for awhile MilesMD88. Stay tuned. :-)

Silver2K | 10. kan 2019

Insane+ replaced max battery power. You don't have to wait for the pack to warm up any longer. I posted a pick on the notes

ktslab | 10. kan 2019

It appears you are losing horsepower. Tesla has to address this.

See first page at TMC.

kerryglittle | 10. kan 2019

Now if Space X couldn't launch they would get right on it. LOL. Sometimes I crack myself up. :-)

heartbeat | 10. kan 2019

My new Ludicrous+ should have been labeled Ludicrous- as my P85DL is slower than before. The Ludicrous+ button does nothing even though it is supposed to replace maximum battery. I proved it last night at the 1/8 mile dragstrip as my car is now at least 0.2-second slower and more than 1 mile slower at the top end. I was excited that the last upgrade showed Ludicrous+ but now I am disappointed.

kerryglittle | 11. kan 2019

Thanks for getting back to us @heartbeat. I was wondering how you made out at the track. Now I know it just isn't me that thought their car was a bit slower. If ludicrous plus didn't need the battery warmed up in the first place then why are they saying it isn't needed now. I ran my car today for awhile and left it in plus mode to see if it would heat up the battery. An hour later I stopped on a back road to see if it would go into launch mode and it wouldn't. Just get the message that both pedals are pressed. Maybe Tesla is discovering how hard it is on the cars doing a launch on the drive train and other components so trying to ease away from it. Its not a deal breaker for me as I haven't had mine to the drag strip. Think the main point is that people paid good money for that function and its not available now. So far.

Silver2K | 11. kan 2019

I feel the difference when switching from insane to insane plus. I hold the pedal at 70 and switch to plus and I feel the power difference. The reaction is better with similar pressure.

heartbeat | 11. kan 2019

What do you mean? 70 mph? Of course, I paid an extra $5,000 for Ludicrous.

larrydavidow | 11. kan 2019

I bought a dragy just to see where the car is at. A few days after picking up my car, a had a few runs with a fairly new P100DL and to about 70mph, we were neck and neck. Both of us had max battery power enabled and used launch mode.

The best I could get out of my car was a 3.15 0-60 at 92% SOC @ 91 degrees F outside temp. Don't know what the battery temps were but it was my 7th run.

I expected in the 2's but after about 14 runs, there was no way.