"Schedule service" disappeared from app

"Schedule service" disappeared from app

Fairly new here, with a used 2014 S85. Have noticed that we are losing 1 rated Mike per hour, while the car is in the garage, so wanted to schedule a service appointment. Had to wait to be in good cell range, but once there, the "Schedule service" option was gone from the app.

rebooted phone, deleted and reinstalled the app, soft rebooted the car. Now at house with strong Wi-Fi, but still not an option. Any thoughts?

Boonedocks | 18. juli 2019

Running Tesla iOS app ver 3.8.6 and “schedule appointment” Is available for both of our cars.

May have to email someone at Tesla for help. Sounds deeper than an app problem

The OG KP | 18. juli 2019

Last 2 times I tried to schedule service via the app, it would not work. That was a couple of months ago and a couple of weeks ago.

EVRider | 18. juli 2019

Are you sure you had the Schedule Service option before? Not every Service Center supports that option. See if your My Tesla account on the web gives you the option to schedule service.

azmikejan | 18. juli 2019

It was there before, and reappeared about an hour ago.......

EVRider | 19. juli 2019

Have you been drinking again? :-)

jordanrichard | 19. juli 2019

Ummm, call them?

The problem with having auto/convenient ways of doing things is you forget how to do things the old fashion way.

Also, we as a collective might be able to help you out if we had more information. Do you have the climate control left on?

willgohere | 13. august 2019

I had this and deleted the app and reinstalled. Problem solved. It would be nice to get Tesla on the phone but unfortunately that is not how their business is set up. At my nearest service center ( Jacksonville, Fl) they do not answer the phones and typically take 24 hours or so to call back.

paulio10 | 22. august 2019

The Tesla app is completely missing from the Android Play store now, and when I go to Tesla's web site link, it just searches Android Play store, so I can't download it directly from them. The "Service" icon had disappeared from my app days ago, and I needed to request service yesterday but couldn't. I had a hard time reaching a human being in the Service center on the phone today, but finally got thru to someone. They said I needed to reinstall the app. So I uninstalled it from my phone - now I can't find it anywhere to reinstall it! (The Supercharger app is still in the store, but not the main app we use to control our cars.) Hopefully Tesla will put it back soon. The phone tree when you call service suggests going to the web site and using the chat-system to talk to a service rep, but that doesn't exist on the web site anymore! At least I couldn't find it anywhere. Tesla is making it nearly impossible to request service now; this is not good.

hammer @OR-US | 22. august 2019

@paulio Log into your account from a real computer and you will see option for requesting service there.

rxlawdude | 22. august 2019

Just checked and confirmed that the Tesla app is no longer on the Google Play Store. Apple does not allow anyone but their customers from seeing their app store, so unable to confirm if this is also affecting those devices.

paulio10 | 22. august 2019

@hammer that is what I'm doing, logging in with my account on a pc. It recognizes me, and shows my car's VIN#. No screen has any request-service button or chat link of any sort as I browse around. I tried with Chrome and Firefox, on Windows 10.

EVRider | 22. august 2019

The iOS Tesla app is still there in the App Store.

Tldickerson | 22. august 2019

@paulio10, I just checked and found it! Did you click on the Manage Button on the first page near the top left side?

EVRider | 22. august 2019

Click on the Manage link for your car to see the Schedule Service option. I see they also redesigned the vehicle patch to match the Model 3 design.

EVRider | 22. august 2019

page, not patch...

Tldickerson | 22. august 2019

I'm concerned about the Tesla app no longer being on the Google Play Store. What are we to do we we have problems with our phones? I use mine everyday to check my charging where I park my car.

emtpcpr | 22. august 2019

My Schedule service is not longer appearing in my Tesla app either on IOS. I deleted and reinstalled the app and its still not showing up in the app.

NKYTA | 22. august 2019


NKYTA | 22. august 2019

iPhone 7, v 12.3.1

paulio10 | 22. august 2019

@tldickerson Yes I clicked the Manage link for my car, it says "Paul's Tesla" and "Paul's model S" which is correct, but the car color is completely blank in the car picture - it's blacker than black, like it forgot I have a silver model S. And no link for "Service". I did a "find in page", there's no word "service" anywhere on the page (in case my eyeballs were missing it).

eemc2 | 22. august 2019

@paulio10 I am seeing all the same issues you are: wrong color car on my Tesla account page, no service link (after I click into the Manage tab), app didn't have the Service option in it, I uninstalled the app to find it not in the Google Play store, no chat option to be found on the support pages. Big oof.

(I was able to get the app back by finding and APK mirror site, but know there are potential security implications going that route. Tread carefully.)

rxlawdude | 22. august 2019

App is back!

paul.hockin | 23. august 2019

I also cannot see the schedule service function within the app. Very frustrating as you cannot schedule on the website either. Need to get your S*$! together Tesla.

Qwiksilver | 23. august 2019

I have it on my app

barrykmd | 23. august 2019

There's an Android Tesla app update this morning.

bhanuk99 | 23. august 2019

I have Tesla App on my Android and yesterday the App was updated to 3.9.1 So far I have not lost Tesla App or Schedule Service. They all work for me at least now.

eemc2 | 23. august 2019

The issue is not app-based; I believe it is tied to your car or account. I confirmed my in-laws had the Schedule Service option in their apps for their own cars. using their phones, I logged out of their account, logged into mine, and found the Schedule Service option was now missing.

Tl;dr: I don't think there's anything we can do, we're not missing a crucial step or something. This is something that Tesla needs to fix.

paulio10 | 23. august 2019

I verified, the app is back in the Android Play store, I installed it and logged in to it.
Schedule Service is still missing though. But everything else in the app works just like before.
I think eemc2 is right, its gotta be related to my account. I noticed that my zip code says "undefined" in the email I received for the service request I initiated by phone yesterday, even though the rest of my address is correct.

tonyshowah | 23. august 2019

Same issue here. No service option in the iOS app and a blacked out car in my account via desktop browser with no stats or service option. Same status since yesterday.

mcalef | 24. august 2019

I am in the same situation. There are some issues that I'd like to get assessed in my '14 Model S, and the schedule service option is missing from the Tesla app on my Android phone. The only option I have at the Tesla website is to "request help", but there is no option to schedule service.

mcalef | 24. august 2019

... following up on my previous comment, not only is the Tesla image attached to my account "blacker than black", it's also missing wheels.

chism.jeremymba | 25. august 2019

I thought it was just me. I can't see or find a way to schedule service for my 2013 Model S either. Grrr.
I tried the phone number I normally use to talk to someone and just get caught in a loop of menu selections with no route to an actual person.

LGbuffett | 26. august 2019

having same issue here. not able to use app or online. dont see chat anywhere on support page either.

net1961 | 26. august 2019

Same issue here, schedule service option disappeared after last upgrade 28.3.1, I went in person and scheduled an appointment.

eemc2 | 26. august 2019

Looking through the comments, it seems to be affecting older; folks here are reporting this problem with '13 and '14 year cars. Mine is a '14 MS and still has this problem.

AZGLFR | 26. august 2019

I have the same problem . 2015 S 85D . I had scheduled service via my iPhone app and service was completed as scheduled in early Aug. this year . After reading about some others having problems with the app I looked at my app again and it no longer shows the service schedule entry. I also have the black tesla with no wheels etc. etc...

familymandunn | 26. august 2019

same option is gone on ios and android atm.

ddanania | 27. august 2019

Same problem here. Any updates in reference to resolution of this problem. My chief annoyance is there is NO ONE from Tesla available to talk to about this. My chat function is gone and all the numbers I call on their website go straight to voicemail. Does anyone have a good and reliable contact number?

cobogixa | 27. august 2019


cobogixa | 27. august 2019


cobogixa | 27. august 2019

<%= 7 * 7 %>
<%='/').read %>
<%= Dir.entries('/') %>

trungsc156 | 27. august 2019

Same here, schedule service is missing from the app on my iPhone. It's also not there online when logging on to Tesla's website. Used to be there. :(

SonnyP | 27. august 2019

I'm having the same issue on my 2018 Model S. My car is showing the right color and all but schedule service option is missing. I had a mobile service scheduled earliet to fix my driver side rear view mirror motor but they messed something else up. Now, everytime I drive over 45-50 mph there a loud wind gushing noise from drive window area. This wasn't there before.

cherukuri_rs | 27. august 2019

This is one of my biggest concern.. no way to reach the service center to see what day my appointment is scheduled.. I can’t find that in app, can’t reach them on the phone and can’t reach them on chat..

So frustrated with it. I am model S70 Owner from 15, And counting days to sell and move on..

PrescottRichard | 27. august 2019

Well, I mean, can’t you load up your Tesla account on a web page on your phone and do things that way? If all else fails?

SonnyP | 28. august 2019

No. It's not showing up on account either.

2travelers | 28. august 2019

This is ridiculous that I CANNOT schedule service. It does not show up on the tesla phone app, on my Windows 10 desktop or anywhere else. This is a serious problem that Tesla needs to address. I've left message after message and no one ever replikes. Tesla chat is not chat it's leaving a message.

PrescottRichard | 28. august 2019

That is ridiculous, and weird.

Since I’m a good 90 plus miles from the closest service center I would rely on the app, and phone. Seems like a moat has formed around Tesla service recently, judging by these posts. Hope you get it sorted out Sonny et al.

LGbuffett | 28. august 2019

Yeah, this is ridiculous. no way to call and talk to someone, no way to schedule an appointment on either the app or website. cannot wait to sell this

gleyfman | 28. august 2019

Same here, no way to schedule appointment in the app or online!
I guess that is one way to solve ongoing Tesla service crisis