Micro SD Card not recognized

Micro SD Card not recognized


I bought a microSDXC Card (SanDisk 128GB High Endurance Video) + microSD Card Reader (SanDisk MobileMate USB 3.0). I did the formatting of the card to FAT32 (I'm using a Mac), created the TeslaCam folder. But when I plug it, either dashcam and sentry mode is not working. If I used my old flash drive, it's working correctly.
I tried to do the formatting a few times with the same result. The MicroSD card is working, as I've been able to transfer a file on it and read it correctly.
Any idea why my car doesn't recognize it?

EVRider | 16. oktober 2019

Verify that the format is actually FAT32 and make sure there’s no typo in the folder name. If everything looks right try rebooting.

NKYTA | 16. oktober 2019

...try rebooting WITHOUT it plugged in, yes @EVRider?
:-) | 16. oktober 2019

@davoliver - On the mac, are you using the same adapter to format and set the folder name? Not sure it should matter, but if you're using some other holder for the SD card on the Mac, it could be the adapter is not working properly.

jimglas | 16. oktober 2019

GUID mapping?

EVRider | 17. oktober 2019

Doesn’t matter if you leave a non-bootable USB inserted when rebooting. GUID mapping vs. MBR shouldn’t matter either.

I have noticed that V10 sometimes “loses” my music USB, and I have to remove and reinsert it to fix it. That could be happening with the video USB also, though I haven’t noticed that happening to me.

davoliver | 21. oktober 2019

I tried the rebooting without it plugged in and it worked :) Thanks for your help! | 21. oktober 2019

@NKYTA - Good suggestion - added it to my dashcam troubleshooting list. Here's the latest list I have:

davoliver | 03. november 2019

It actually worked once, then stopped working again. Every time I reboot the car with the stick unplugged, it works once and stops working :(

TheMorgans | 04. november 2019

I have a San Disk Ultra micro SDXC UHS-1 128GB that has been formatted correctly on a PC using several downloaded programs Tests confirm it is working correctly. When used with the dash Cam it is not recognized. A San Disk 128GB flash drive is recognized.


Kingb3 | 27. november 2019

I have the same card. Windows 10 will only give you the options for larger capacity cards to format in exFAT or NTFS. I tried the exFAT format and that didn't work. Ended up formatting using AOMEI Partition Assistant (free), added the TeslaCam folder after format and all was well. I believe there is also a Windows command line that will format to FAT32 (I did not try this and am not responsible for outcome): format /FS:FAT32 /Q X: (X: being the drive letter of the card you want to format)