Significant issues with voice command

Significant issues with voice command

Hi folks,

I recently obtained a model x about 10 days ago. I’ve had a model 3 prior to this. Part of the reason I had obtained a Tesla was what I had thought was good voice command.

However, I’ve had really poor performance with voice command on the model x. It does not appreciate what I say nor does it even recognize any voices uttered about 75% of the time. I’ve done at least 10 resets throughout this time.

Does anyone have any suggestions.

Vawlkus | 06. januar 2020

Software version?

Mrotr565 | 06. januar 2020


JPPTM | 06. januar 2020

Latest release is buggy....

Jrla | 06. januar 2020

Mine too. But mine also has a host of other issues. Unfortunately took delivery on 12/24/19 and still dealing with unresolved issues that service center claimed to have fixed. Some issues started after the SC visit.

Mrotr565 | 06. januar 2020

dude I took delivery on 12/23. And it’s just been a glitchy ride.

ttohumcu | 08. januar 2020

I took delivery of my Model X on Black Friday. I am on the latest 2019.40.50.7 and almost 90% of my voice commands do not work. I am hoping its just a software bug and will be fixed. Unless could it be my microphone in the car that does not work. I am going to call Tesla Support to find out. I do have a few other issues as well.

vitaman | 08. januar 2020

Took delivery 12-23 and other than a scuff mark on the hood that they polished out in 3 minutes, the car has been perfect.

Bighorn | 08. januar 2020

I’m not in the habit of using voice for Nav or music since 2013, but I tried it yesterday on the 3 for the new slew of voice commands and not only is the catalog comprehensive now, it got everything right.
Do you have an accent it might have difficulty with?

sillyleann | 09. januar 2020

Took delivery Dec 17. Voice worked great. Updated a couple of days in and have had nothing but trouble. In fact, my button no longer works. When I push the voice button nothing happens. However, if I honk the horn, I can do voice commands. NO JOKE!! And it will also come on when I unplug the Tesla. It is frustrating a bit and completely humorous! My kids laugh when I honk the horn. I don't care. I need to get somewhere and my Tesla is going to listen to me one way or the other.

Mrotr565 | 09. januar 2020

Negative. I have no accent issue.

sunsinstudios | 09. januar 2020

Hi OP - you are not alone.

I think the model X just has a glitchy voice command issue with the latest update. Is this inconvenient? Yes.

BUT I trust it will be fixed in the next update.

The reason I don't mind this happening to a 100K car is that
1) in just the 3 months I've owned the car it has "learned" to play Netflix, youtube, drive with one pedal, increase regen efficiency, merge and switch lanes better, see stop signs and lights, and now I can (kinda) talk to it.
2) most issues I've encountered have been minor 1-time-glitches (it lost GPS for a few hours, the seat wanted to fold me like a dollar bill 1 day, the screen randomly restarted once,
3) the safety features have never failed me!
4) I'm saving hella gas money

yabouzaid | 09. januar 2020

Speaking of accent , i got a big one, but 90% of my voice command are understandable, try to make my long story short, driving Lexus for 20 years, never able to use the command, even my kids with no accent. Last year after driving the Tesla, and couldn’t find any thing to tell the show room, i tried to embarrass the girl by using the voice command for navigation it took my command 10 out 10 , i got bought the car on the spot, right now my new voice command work fine except open the glove box [ it says not available yet]. I got X 2018 with 25k miles

Vawlkus | 10. januar 2020

You need .7
.6 is faulty.

tampascott | 12. januar 2020

Took delivery on 12/03/19 and have ver .7 installed. I went on a planed vacation 2500 miles away for 3 weeks after delivery after only putting 300 miles on it, but voice commands were working well. I was doing updates while on vacation. When I returned, voice command functionality was much poorer. However, being new to Tesla I am still learning myself and I read the trick is one click on the vc button. I don't know why that's significant, or if it used to be 2 clicks or something, but it did the trick and is working much better now. When I asked it to open the glove box it understood the command, but gave the message that the option was not available yet. I've seen vids of M3s where the command works, but perhaps just not yet in the MX (real big deal, I know, having to push a button on the 2 times a year I'll even open the glove box).

ruthieX | 05. februar 2020

Was notified of software update available today. Yay! Maybe voice command issue would be resolved and I could go back to using voice commands. Read release notes after software installed (says version 2020.4.1) and they looked identical to the release notes that were shown the last time I accepted a software upgrade (which is when voice commands stopped working).