Any way to force an update

Any way to force an update

I have a rental Model S, 75D, while my Model 3 is in the shop hopefully being totaled so I can order new one. The screen says that an update is available and to connect to WiFi. I do that but the software never downloads. I know I'm on Wifi as the browser works. The car only has Standard Connectivity. I have also tried hotspotting my phone. Any ideas?

rschindewolf | January 17, 2020

Same exact thing happened to me. Same Model and battery but I have premium connectivity and still no luck. Tried powering off and rebooting and still the same message and no update.

Captain_Zap | January 18, 2020

Better yet, we need a rollback option.

barrykmd | January 18, 2020

You read my mind, CZ!

jimglas | January 18, 2020

left left right right up down worked for me

rdr1rx | January 18, 2020

... plus B, A, then Start.

Qwiksilver | January 20, 2020

@Zap. +1

akikiki | January 20, 2020

CZ, maybe we need them to implement the anti-time mode.