Forums

Phone Key Disconnected

Phone Key Disconnected

My Samsung 7 phone gets disconnected so often from my Model 3 so I have to use the card key to drive the car. The Tesla service center technician rebooted my phone and it worked for a few hours then disconnected again. He thought it's my phone's problem. I wonder if anyone has similar issue like mine? My car is 3 weeks old, the Phone Key worked during the first week then quit.

andy.connor.e | 20 februari 2018

Try deleting the cache. Delete the app and reinstall it. Delete your playstore cache and data, then reinstall it. Use troubleshooting techniques like you would to fix your home internet before calling tech support.

drew | 20 februari 2018

It may be a bit early to rejoice, but so far I am 5 days in with the 3 and have had no phone key issues. I have 5 people's various Android and Apple phones connected to the app - so far so good. (I added the M3 to our business fleet, hence all the drivers / phone keys). I will report back as time goes on.

Drew in MI

drew | 20 februari 2018

In a twist with some karma, I learned the hard way in a downpour today that the 3 will not unlock if you have the Tesla app swiped over to one of your other Tesla’s.

The karma comes into play due to the reason my app was on the Model S, which my wife drives. You see, I noticed that she was at home but in the car and decided to turn her heat to max...and then to super cold after she adjusted it back to normal. Followed by random flashing of the headlights and horn honking. I then closed the app and ran out of the office to my 3, which refused to unlock. I quickly found myself standing in the rain wishing I hadn’t just posted above about my perfect record with the phone key. As soon as I opened the app and swiped to the 3, the mirrors folded out and it unlocked.

I tested this outcome several times in my dry garage this evening...I probably didn’t pay attention to this during delivery. Well deserved, I suppose :)

hmgolds | 21 februari 2018

I'm not a fan of this feature as I think it creates an unnecessary 3rd party dependency. So I asked someone who's an EE with a focus on cellular communications.

I asked how strictly the bluetooth standards were and how strictly they were complied with across phone and manufacturers. The answer was very strict. That's a positive.

But there's a bluetooth antenna in every phone. And that antenna's performance can vary from model to model and sometimes phone to phone of the same make/model. That might explain varying performance from one phone to the next.

And of course that doesn't address how the phone's OS treats to Tesla app. Too many fingers in that pie (Tesla, Android, the phone manufacturer, the carrier). But that's the world we live in.

rxlawdude | 21 februari 2018

I can tell you that my app (on Samsung G7edge) shows "connecting" and "connected" from 10-30 feet away; even with "connected," the car only unlocks upon near proximity to the M3.

rtanov | 21 februari 2018

Samsung Galaxy S8 - has been working most of the time but failed several times in the last couple weeks. Tinkering with app background settings did not seem to help any. When phone fails to work as key the app is showing "Disconnected" or "Connecting" for a long time. Turning the phone Bluetooth off and on seems to fix it consistently - phone key connects right away.
My wife iPhone 7 seems to be more robust as she has not complained.

Bri | 21 februari 2018

@hmgolds I agree and hope Tesla gets some bandwidth after M3 production gets closer to meeting to demand to build their own remote hardware interface, perhaps in the form of a watch. Something that would act as a fob, plus the additional configuration capabilities of the app.

rxlawdude | 21 februari 2018

@rtnanov, same here re iPhone 7. My wife has not complained about having to dig out her phone and play with it to act as a key for her M3. Android seems to be far more problematic because of myriad versions and manufacturers that customize the OS.

Haggy | 22 februari 2018

"The karma comes into play due to the reason my app was on the Model S, which my wife drives. You see, I noticed that she was at home but in the car and decided to turn her heat to max."

I haven't played tricks like that, but I have called my wife and said "don't park under that tree. There are birds in it." It really freaked out my wife's co worker who wondered how I knew that she had parked there, that there was a tree, and that it had birds in it.

rxlawdude | 22 februari 2018

@Haggy "... freaked out my wife's co worker who wondered how I knew that she had parked there, that there was a tree, and that it had birds in it.

How DID you know there were birds in the tree? ;-)

rxlawdude | 22 februari 2018

Another interesting "aha!" moment today, not related to the phone connection on the Model 3, but the calendar app in the Model S.

This morning, I unplugged my S and pulled my phone out to switch the app to my wife's M3, which I plugged in and started charging.

On my way to work today in the S, I knew I had a busy day and wanted to check which conference room my first meeting was going to be. I pulled up the calendar on the S' screen and it was blank. That's odd. I pulled out the phone, went to the Tesla app. It was still "pointing" to the M3. I swiped the screen to "point" to the MS, and the calendar popped up immediately.

So there are some other interesting side effects for those with both a M3 and an X or S.

Thom EM | 23 februari 2018

Have we all realized yet that it’s normal to be disconnected when our of Bluetooth range! Yep, that’s all it is,,,

GCM3 | 24 februari 2018

I feel this is caused by the last update of Tesla app in early Feb. Or Android update on early Feb. They happened at same time. I never had problem for 2 months with my phone as key but after those updates, I frequently get "Bluetooth has stopped" error message on my phone. Then, Bluetooth immediately restarts. If I stopped Tesla app, from bkground, Bluetooth works great. No problem.

Azred50 | 25 februari 2018

The OP reporting that a Tesla service rep suspects his smartphone has issues is an illustration of my biggest frustration with Tesla service. While they have been taught to try to be helpful, I don’t think most of them are “car guys” like the independent mechanics many of us use for our other vehicles. When I have pointed out some issues, they often seem to be clueless that the issue exists even though I have read here about many others experiencing the same issue. For example, issues with the phone key. My wife and I both experience those issues with our iPhones and yet when I have mentioned the issue on three visits I mostly get blank stares.

I have learned to never mention hearing about others experiencing my problem on this board. Twice I got smarmy responses like, “Yeah, everything you read on the Internet is true.” I guess they assume most of us inherited the substantial money required to buy these cars and lack common sense.

Bri | 25 februari 2018

Try contacting the phone manufacturer if the phone isn’t connecting.

Haggy | 26 februari 2018

"How DID you know there were birds in the tree? ;-)"

Because I've cleaned the car enough times after it's been parked there.

eggnet | 27 februari 2018

@Bri

I have a Pixel XL.

The problem is, the phone is connecting to Bluetooth generally for the car. Calls, music, contacts... standard features are working fine.

But this Key thing, not working reliably. None of us knows how the feature works or is supposed to work at a low level. It's something Tesla and Google and/or Samsung etc, have to work out.

mefischer134 | 28 februari 2018

We've created separate Tesla accounts for each car so that the choice of current vehicle in the app isn't an issue. We've also made sure that the Tesla app isn't subject to power saving. I'm using a Samsung Note 5, fully updated, with my Model 3. I've reverted to carrying the access card between the phone and the protective phone case, for easier access when needed. After rebooting the phone, the BT access will work for a day or a few days and will then be unresponsive. A reboot of the phone is then required. My wife is the primary driver and is getting to be very frustrated. I'm becoming very disappointed that she isn't able to own this car without it causing her so much trouble. It seems that the Tesla app needs to be revised to ensure that the phone's BT is functioning and if it's not initiate a reboot of the BT functionality. Is this possible?

Paul.r.freedman | 28 februari 2018

My problem is different. On my iPhone 7+, the unlock/lock always works. But if I want to pre-warm or cool my M3 up, the Application almost never connects over Cellular. I get a "Vehicle Connection Error"

I am hoping for a software update for either my App or the Car.... Is the 2018 M3 Update push not far behind?

sal0311 | 28 februari 2018

My android phone disconnects on a regular basis. If I turn off bluetooth for a few seconds and then back on it works until I get out of range and then will not reconnect without turning off/on bluetooth again.

mefischer134 | 28 februari 2018

My wife further adds: "She doesn't want her phone fixed! She wants a goddamn FOB."

mefischer134 | 28 februari 2018

My wife further adds: "She doesn't want her phone fixed! She wants a damn FOB."

Mark | 28 februari 2018

Just picked up the M3. Sure enough, my wife--primary driver--is having sporadic phone key connectivity problems (Samsung Galaxy S6). I've tried all the tricks mentioned in this Forum and, at the moment, the phone key is functional but I am not confident it will continue to work. For my wife, the problem has tended to sour what should have been a great delivery experience for an otherwise great car.

As Tesla owners since 2013, we can deal with this. I--like most of you--am a Tesla fan. But when 400,000 reservation holders get their M3, they won't be as patient if they have to deal with phone key problems. The vast majority have not yet developed their allegiance to the company and the noise will be LOUD. Bottom line, a FOB is required, quickly. The coming Tesla M3 mass production plan requires it.

stevenmaifert | 1 mars 2018

Consumer Reports now has a test car and they have published their "first impressions" article. Mostly positive but they will publish a more detailed report after they've had the car for a while. I'll be curious to see if they have any trouble with the reliability of the smartphone-app-as-key among their testers. A down check from CR might motivate Tesla to offer a FOB for those of us who want one.

rxlawdude | 1 mars 2018

I'm fascinated by those who say that they must REBOOT their phones to get the BT-as-a-key to work.

For those in that situation, please try this if you also have a Model S or X. "Swipe" the app to display the S or X, then swipe back to the M3 and see if that doesn't force the BT connection.

It does seem that Samsung Galaxy phones are having the most issues.

Tesla-David | 1 mars 2018

@mefischer134 +1. agree totally with your wifes comment. After reading all these problems with smartphone access to M3, it underscores my recent comment to Tesla, we want a Key Fob option for our M3. We have never had an issue with our MS Key Fob over past five years. We have had serious issues with the M3 Key Card over last 3+ weeks. We do own a smart phone, and have no plans to get one preferring our flip cell phone.

Tesla-David | 1 mars 2018

Oops, "do not own"

stevenmaifert | 1 mars 2018

rxlawdude - Just tried that. Once connected to the MS I switched back to the M3 and the UI still said Phone Key Disconnected when it connected to the M3. Like I said in a previous post, after the reboot which restores the phone key connection, the app acts as if it is performing a periodic validation that the phone is a properly authenticated phone and if it sees a parameter/setting it doesn't like, it then disconnects the Phone Key function while allowing everything else in the app that requires a data connection to still work.

Azred50 | 6 mars 2018

My iPhone 7 opened the 3 for the first month as long as the Tesla app was displaying my 3 and not my S when I closed the app. But now it will only open the car if I open the app. This is stupid. There must not be an anyone in authority who can challenge any newfangled way of solving problems that didn't exist. (I still can't believe it is best to use my left hand to open driver's side doors and right hand to open the other side. Who thought that was a good idea?)

Azred50 | 6 mars 2018

My iPhone 7 opened the 3 for the first month as long as the Tesla app was displaying my 3 and not my S when I closed the app. But now it will only open the car if I open the app. This is stupid. There must not be an anyone in authority who can challenge any newfangled way of solving problems that didn't exist. (I still can't believe it is best to use my left hand to open driver's side doors and right hand to open the other side. Who thought that was a good idea?)

Azred50 | 6 mars 2018

Sorry about double post. Tesla's forum editing tools are a blast from the past.

rxlawdude | 6 mars 2018

For Android users, some reported a new version of the app solves the issues. I uninstalled the Tesla app and downloaded from the Play Store.

After setting up the phone-as-key (that info was wiped during the uninstallation of the app), it indeed seems to be much better. In fact, I haven't opened the app since re-installing last night (app is displaying the M3 rather than our S), and the morning both cars enthusiastically welcomed me (in that Tesla way) into the garage. The app never did that before after 12 hours not opening the app explicitly.

I was an early fan of the phone-as-a-key, but it's clear that because of all the variables with different phones, OS builds, etc. that a fob option is absolutely required.

lilbean | 6 mars 2018

@lawdude, Do you think a fob option is feasible or is different hardware required?

stevenmaifert | 6 mars 2018

Tesla has been using a BLE FOB with MS/X for quite some time. I think it's absolutely doable: https://electrek.co/2016/09/05/tesla-key-fob-bluetooth-low-energy-ble/

robgoodin | 7 mars 2018

Iphone disconnected about 3 times in month seemed to happen when IOS updates happened. Was always able to use app to unlock and start car, Always reconnected when turned phone off completely and back on.

linda | 8 mars 2018

I have an Android phone (Galaxy S8) and have experienced many of the issues described here. I recently received the firmware update for the M3 to 2018.4.9. Once this new update was installed in the car, to my surprise, there were multiple phone keys assigned to my android phone (the result of multiple attempts to delete the app and reinstall it no doubt). There is now a feature in the "Locks" menu on the car that let's you see this, and delete the duplicates. I also discovered that the original phone key entries for my and my wife's phones could not be deleted. A Tesla tech was also unable to delete these, even with his laptop and in consultation with the Tesla design engineer. Apparently this is a known glitch that is being worked on by Tesla. It is possible that the multiple duplicates could be part of why the phone works inconsistently, and Tesla is going to issue a patch to allow for all phone keys to be cleared in a future software update. I have also not only excluded the Tesla app from "optimization" as previously suggested, but also did so for the 3 Bluetooth system apps. (Settings->Device Maintenance-> Battery->Battery Usage->3 Dots in upper right->Optimize battery usage->All Apps->Deselect Bluetooth/Bluetooth MIDI Service/Bluetooth Test. So far at least, this seems to have worked. Wish me luck!

dingsheng.li1987 | 1 april 2018

I tried everyone's suggestion here and the only one with consistency is turning the phone's bluetooth off after walked away from car and it locks itself and turning it back on when I am walking towards my car (but not in the distance when unlock should be triggered yet). It's not optimal, but at least it works.

H271 | 1 april 2018

Have there been any improvements with the most recent OTA? I'm surprised at how many complaints there are around the Pixel 2 given that it is pure Android. Has anyone messed with bluetooth scanning options?

Paul.svehlek | 2 april 2018

After the 10.5 update my phone (pixel 2) is not unlocking and locking my car anymore. It worked for a bit, when pulling the door handle. Now it will not open or lock it. I have to manually lock it from the app. Rebooted the car multiple times. Phone shows it is connected to the car. Anyone else have this issue after the 10.5 update?

H271 | 2 april 2018

This is not good

crobert5 | 2 april 2018

Two weeks ownership - two Tows to service for being locked out. Both times neither the phone nor the card key would work. Turned bluetooth on and off, closed and opened app, swiped from S to 3. Interesting the phone would flash the lights and turn the air on, but would not unlock door. Both times occurred on a hot day after sitting in sun, running on 10.x version of software. 1st trip to service they loaded version 4.6 and it worked until update 10.5.

SD Supercharger | 2 april 2018

iPhone 6- locking/unocking from phone worked for 3 months. Went to car today--bluetooth connects phone to car but no locking/unlocking function. Tried reboot, iPhone bluetooth reset, still get music but have to use the card for entry/driving--bring back the FOB and auto lock.

SD Supercharger | 2 april 2018

No new phone or car updates---just stopped working

H271 | 7 april 2018

Any other feedback on this? What happens for those of you locked out of the car?

MarylandS85 | 7 april 2018

My suggestion for those of you who find the phone stops working as a key is to get in the car with the keycard, delete your phone as a key (go to the Locks menu to do this), then add the phone as a key again. I’ve never done this, but I know it’s worked for some others.

joe | 14 april 2018

Had my model 3 for a week. For the first time today, Tesla app on my iPhone X showed key “disconnected” in area where there was almost no cell reception. My wife’s iPhone, authorized as a key, also showed disconnected. had to use the key card. Worked fine, both phones connected, when we got home. Maybe cellular IS required for a phone unlock, despite statements around to the contrary?

israndy | 14 april 2018

This thread makes it seem like phone keys are an issue. I have not had any, and it makes me wonder if most people's phones work as well as mine does and it's only when you have issues you come here. I love the phone key. I often will go to my Volvo and realize that I don't have my fob, but I have NEVER gone to my Tesla and not looked down at my hand and there was my phone. I know Tesla is correct, phones are the future. Sure there may be some issues, especially for Android apparently, but there is a LOT on the Model 3 that isn't done yet. Where is my summon already?

In the short run, we got the first Model 3's, so there are a few growing pains but don't start a campaign to go backwards to those horrible fobs. There was a time when I could carry all my keys all the time. Now each key is GIGANTIC. Slowly I'm moving to iPhone based access, got the house and the one car now on the phone. Very nice.

-Randy

petemelster | 15 april 2018

The phone key is ridiculous for me. Works about 0% of the time. I even set up a service center appointment, where they "fixed" it, but not really.

The only reliable way to actually get the phone key connected is to uninstall the app, reinstall, sign in again, pair with the car's bluetooth, then connect the key. This will finally make the phone key connect and work as I walk in and out of range. But if I go park somewhere for an hour, let's say, then come back, well, the phone key is now permanently disconnected, even if I'm standing right next to the car.

In fact, pressing the phone key area on the app does nothing. The button literally becomes unresponsive. The only fix is to uninstall and reinstall the app. So I've been using the key card 100% of the time.

Also, the car has trouble "seeing" my phone 75% of the time. It just searches and searches, but my phone doesn't show up 75% of the time, despite having bluetooth on and searchable. I'm on Android on a rare phone (Lenovo Phab Pro 2), so maybe that's the issue, but bluetooth pairing works just fine with my headphones, computer, and other bluetooth connections I've tried. It's only had issue with the Model 3.

Perhaps another issue is that my home garage gets terrible cell/internet reception.

Currently on Tesla firmware 2018.12. Not sure if 2018.12.1 will fix the issue.

jeseegan | 15 april 2018

Randy, the FOB does not eliminate the phone as a key, it is a safety net until they can somehow get the phone at or near 100%. (The card reader has its own issues when the weather is bad, or if you need to get in on the passenger's side.)

I'm not even sure they can ever reach 100% with the phone, simply due to the wide variables that are out of Tesla's hands.

BENERIK3U7I | 4 maj 2018

ok forum, this is my contribution to the problem with the phone key disconnecting/not opening when in proximity of the car. My phone is Samsung Galaxy S5, software version 6.0.1. The changes I made were on:
settings=>network connections=>more networks=>mobile networks=>mobile data, make sure Mobile Data check box is marked.
Next change:
settings=>Application Manager=>find Tesla app and click on it, select Permissions and turn on Location and Phone (at least those options did it for me).
Other Samsung users might find their options a little differently.
Please post your results for other users to update theirs.

Pages