Dash cam issues after latest update?

Dash cam issues after latest update?

Was real excited to receive 2019.5.4 but my dash cam is not working. I bought a new drive. Formatted FAT 32 a few times. Have “TeslaCam” folder and nothing else on the drive. No luck. Have the camera icon with the grey x. Not sure what’s up

jimglas | 2019年2月25日

might be a bad drive?

badaman | 2019年2月25日

I had the same problems but finally got it to work after reformatted few times.

alisse | 2019年2月25日

I found the same thing, but haven't yet reformatted, which I heard was necessary after the update, unfortunately.

kurtmetcalfe24 | 2019年2月25日

Drive seems to work fine when copying files from a comp. I just bought it 2 days ago. I have reformatted at least 3 times so far after the update. Dang...

badaman | 2019年2月25日

@calfe24 - I also, did the hard reboot.

kensyo | 2019年2月25日

I found I have better luck if I format the drive with a Mac.

slingshot18 | 2019年2月25日

What kind of drive? Needs to be of sufficient speed.

gcklo | 2019年2月25日

Mine seems ok although I haven't checked if the videos are good.

kc4129 | 2019年2月25日

How big is your drive? I have an 8GB drive and it stopped working after the update but got it back to work after reformatting it.

derotam | 2019年2月25日

I had the issue of it going grey x as well... I just deleted the TeslaCam folder and put it back and it's working again... don't know if this will be a recurring thing like it had been in the past.

kurtmetcalfe24 | 2019年2月25日

I have this drive. I have seen others on the forum mentioned they have this one as well. I have a 32GB

SanDisk 32GB iXpand Flash Drive for iPhone and iPad - SDIX30C-032G-GN6NN

Daryl | 2019年2月25日

Some people report better results if they format with the program SDFORMAT. from

kc4129 | 2019年2月25日

My 8GB drive failed to work the second time since the 2019.5.4 update. I took out the drive and see that the drive is full after 3 days of recordings. So I guess a 8GB drive is definitely not big enough for the dashcam. I put in a 64GB drive and will see how it goes.

kensyo | 2019年2月25日

@kurtmetcalfe24 I have the same flash drive. I found that every time I use my iPhone to watch the videos and plug it back tot he car again, it won’t work until I reformat....

alisse | 2019年2月26日

I restarted the car and formatted my previously working 64GB drive 3x and it has not worked since. Grayed out X remains.

I formatted (to fat32) a brand-new 64GB drive and it worked immediately. So the update definitely did some major corruption to it. I've since did a deep format of the previous drive, but have not retried it as the new one is working fine.

EVRider | 2019年2月26日

@kensyo: How are you using an iPhone to watch videos on a USB drive?

CST | 2019年2月26日

I had to switch drives too, can't get the previous one to work in the Tesla anymore. I don't think it is corruption, maybe a lack of transfer speed. I just ordered a new 128GB one with a 300MB/sec read/write, for $25. Once I figure out how to format it FAT32, I'll see how it does.

alisse | 2019年2月26日

@CST I used this one (assuming you're on windows)

Click the image to download the app.

derotam | 2019年2月26日

Yeah, I think with the latest update 5.4 the car is not "ejecting" the thumb drive correctly again, causing the corruption. I have been able to fix mine by just deleting the TeslaCam folder and putting it back, without needing to re-format. I just started doing the pause again when I leave the car so I am hoping that deals with the issue till a new update.

Curious though... I wonder if when the thumb drive is paused, whether you can activate sentry mode from the App and have it re-engage the thumb drive.

gene | 2019年2月26日

I had the red X as well, and when I popped the USB stick into my computer I found that it had been completely filled up with videos from the Sentry Mode. 30GB worth from just one night, when every gust of wind blowing driveway-adjacent plant leaves activated it.
THIRTY GIGABYTES! Seems like there needs to be some kind of tweak to Sentry Mode to deal with this unforeseen circumstance.
And maybe this is why it's not turned on by default.

blue1 | 2019年2月26日

I have the same issue. After enabled Sentry Mode, the shaking leaves at the parking lot caused continuous recording from three cameras for about 20-30 minutes till filled 8G USB drive. Then the stick stops working with a gray X on the icon. Can the Sentry Mode recording be overwritten by itself?

smin73 | 2019年2月26日

@alisse Thank you!! I had a iXpand 64Gig Drive that stopped working after the update. Using that software let me format it as FAT32 and it's working again. I haven't driven the car with it yet but will test it out tomorrow.


kurtmetcalfe24 | 2019年2月26日

Got it working! To clarify my exact situation just in case someone else has it. I did not have this drive installed before the update. I bought this new one the day after 2019.5.4 update completed so I could load sentry mode recording right to my phone if wanted. So it was not corrupted by the update. I tried to format 5 different times from 3 different windows computers. Finally I formatted from my MacBook Pro and voilà. Maybe just an odd coincidence that it finally worked on this format but the Mac switch did it for me. Formatting using disk utility.

kensyo | 2019年2月26日

@EVRider I have the Sandisk iXpand flash drive, it has one lightning connector on one end and one USB connector on the other... You need to install a Sandisk App on iphone to see/copy the files. It works pretty good before the recent update.....

EVRider | 2019年2月27日

Thanks for the link @kensyo!

derotam | 2019年2月27日

I fixed my issue by changing out my old crappy 4GB drive to a 128GB drive. Though it will still probably stop working if the drive gets filled up by recordings.

CST | 2019年2月27日

Tesla's QA is pretty light if they re-introduced corruption with this feature. Additionally, not thinking of how to handle filling the drive is inexcusable. I'm all for the success of these updates, but they are really missing some large-obvious issues here!

smin73 | 2019年2月27日

Just an FYI on the iXpand flash drive and formatting it as fat32. Although it ends up recording in the car, when you plug it into your phone it doesn't detect that it's actually plugged in. Not sure if it's only me or if it's the case with others that have the same drive. Specifically, I have the SanDisk iXpand 64gb flash drive.

kensyo | 2019年2月27日

@smin73 my 32g works fine and I can view video on my iPhone after plugged in. Do you have error from the iXpand drive app?

smin73 | 2019年2月27日

@kensyo Nope. it just will not recognize that it's plugged in. Works fine if I plug it into PC and I have tried going through the troubleshooting but nothing worked. I have the 64gb version and may just send it back and get the 32.

kensyo | 2019年2月27日

@smin73 but with the sentry mode, i think 32M is not enough.....

smin73 | 2019年2月27日

Here is what I ended up doing.

On a Mac, I formated it as MS-DOS (FAT) and a Scheme as Master Boot Record. This ended up working and the drive is starting to record again and i'm able to watch the video's on the phone.

Hopefully it lasts and I should be able to check it again tomorrow.

billlake2000 | 2019年2月27日

CST, like I said, it's a commodore 64 and each new update introduces new memory overwrites.:)

hpn | 2019年2月28日

Did a quick and a complete format USB 128gb still not working...used an old one 64gb i had previously worked like a charm....

abrasha | 2019年2月28日

Folks, I don't think formatting is the issue. All your different formatting schemes, that you think "did it for me" do not seem to solve this issue.

The issue simply seems to be that the drives are filling up and files are no longer overwritten as before. Sooner or later evan the biggest SSD drive will be full. I now have multiple formatted USB drives in my car so I can switch them as soon as I see the grey X again. Files are now in a "Saved" folder even though I never actively saved anything.

Sentry Mode has something to do with it. In my case I had video on my drive from when the car was parked in my garage and Sentry Mode was not activated. Obviously Tesla needs to fix something with the new TeslaCam scheme.

kensyo | 2019年2月28日

@smin73 everytime after I watch the video on the phone, the flash drive won't work anymore with Tesla. I have to reformat it again...

alwgarrett | 2019年3月1日

@abrasha I do believe the formatting is key. If formatted to FAT32 this will only record, I believe 8GB before starting over(approx 1 hour). It then places it on a separate and new area of the USB every time it starts a new recording and deletes the old. The USB can only handle so many read and writes before it loses viability from what I understand. If you have the format to any other, you will record much more than an hour of video, but once filled, it will grey out and stop recording until you pull the USB and delete the data. It will not eat it's own tail and keep recording. That is the reasoning for using the FAT32 format. I'm not an IT guy. Just trying to help.

DB1855 | 2019年3月1日

For me It’s sentry mode that’s causing the thumb drive issue. Dash cam works fine, but when I enable sentry mode it crashes. Granted it’s only a 8gb stick. Wondering if the sentry files do not get overwritten. Also wondering what size hard drive to get to replace the 8gb. 64? 128?

kc4129 | 2019年3月1日

@DB1855 Sentry mode files don't get overwritten. My 8Gb drive used to work fine until sentry mode arrived. I am now using a 128Gb and have another 64Gb in the car just in case the 128Gb gets full.

DB1855 | 2019年3月1日

Thanks! Shouldn’t sentry files get overwritten after some time period like the dashcam? Maybe that will be addressed in a software update ...

Razer011 | 2019年3月2日

Had the grey X problem with my thumb drive after the most recent sw upgrade. Tried multiple times to reformat the drive on PC with no luck. Still grey. Then I formatted the same drive on my wife's MAC using MS-DOS (FAT) and a Scheme as Master Boot Record as someone suggested above. Worked, back to red dot! Maybe Tesla developers like Mac better than PC?

Fatchances | 2019年3月4日

Had the grey x after update. Reformatted 3 times on my 10 year old Dell PC didn't work. Saw this forum suggestion using Mac OS. Use Son's Mac Book Air to reformat and create the TeslaCam folder worked afterward.

tcandmm | 2019年3月22日

HI everyone, just to confirm all the postings, when sentry is activated it won't matter if you get a larger memory usb drive, the gray X will eventually show up once the drive is filled up, correct? I've had the dreadful gray X showed up twice on my Samsung 32gb USB fob, after reformatting to FAT32 on my PC it works about 1 1/2 week then the gray X shows up again. I'm tired of reformatting the USB but don't really want to spend the extra $ to get a larger memory USB if it will eventually also get filled up with gray X. Thanks.

Test-La | 2019年3月22日

Is the car supposed to be off before unplugging the drive?

carabella | 2019年3月22日

My dash cam is recording 24/7 after the update. It adds 2 folders. One named recorded clips & another saved clips.
My 8GB flash drive was enough before but now its full within a couple of hours. Why isn't Tesla addressing this? The owners manual still has the "old" info.

ericbresslermd | 2019年4月5日

Here's another wrinkle. I have been using two USB thumb drives, one with my CD collection in FLAC format and the other an 8 GB with a Tesla Cam folder. This was working intermittently before the update, although often the 8 GB would biff and get the gray x. That seemed to be due to some corrupted files of only a few kb, not filling up the drive. There was never more than one hour worth of files on the drive.

After the update, the gray x was still there, so I rebooted. The software made me choose which USB to make active, so I chose the music drive. Now there isn't even the camera icon present on the screen. I guess I'll have to hope that Tesla techs read this bulletin board because I'm not aware of a way to give direct feedback to the company on issues we owners encounter. Please correct me if I'm wrong about that!

mlspropertiesllc | 2019年4月5日

I wish I had the grey x. As of now I have no dashcam icon, nothing. After the last update it completely vanished. Anyone else out there have his issue? I've done the reset procedure with and without pushing on the brake, but nothing.

Mscottlindsay | 2019年4月9日

@ebressler use the voice control and say bug report.

EVRider | 2019年4月10日

When you say the “last update” or “latest update,” please specify which version you mean, since not everyone gets the same versions, and the latest update is a moving target.

I just tried using the dashcam for the first time in our Model 3 on 2019.8.5, and it seems to be working. I’m using two USB sticks, one for music and the other for video. I haven’t tried Sentry Mode yet.