Cruise Control/Autopilot not working and lines not showing up

Cruise Control/Autopilot not working and lines not showing up

Never have i had this happened, but since updating software to 2019.8.5 it happened today while i was driving on i-5 with clear lane markings. I tried the reboot but cruise control/autopilot and lines are still not showing up. Has anyone had this problem? and should i take it to service?

vts747 | 2019年4月6日

It happened once to me a while ago. I had to reboot it at home, and it was fixed. Do a deep reboot, with the brake pedal.

rsingh05 | 2019年4月6日

I got a cruise control disable warning this morning. As @vts said, brake pedal reset did the trick.

elecfan2 | 2019年4月6日

My entire autopilot system has failed, no cameras, no speed limits displayed, cruise control doesn't work, backup camera doesn't work, emergency braking broken, automatic wipers don't work, it does drive however. I've called Tesla service several times and they said there is nothing they can do, take it to a service center, but they are booked for weeks so basically payouts for FSD for nothing.

JDev | 2019年4月6日

The problem described by the OP happened to me also with same sw version new install, which I believe was a software glitch (maybe requiring recalibration of sensors after update). I rebooted both display (press on both steering wheel scroll wheels and brake until screen blanks) and powered down car for a couple minutes (service menu). Problem resolved after leaving the car charging/sleeping overnight (e.g. next day). Hopefully yours will too.

elecfan2 | 2019年4月6日

I've tried all the rest procedures multiple times over multiple days. Just got off the phone with Tesla and they say multiple people have these issues even though they might not be in the forum. They were off no help whatsoever.

Magic 8 Ball | 2019年4月6日

@ewd7 How do you know your emergency braking is "broken"?

JDev | 2019年4月6日

@ewd7, hard to tell if you are experiencing a sw glitch or a hardware issue, so service sounds like the next step. You might try seeing if you can get a mobile service tech scheduled, in case that is faster than an appointment at a service center (or at a second service center if another one is close enough to work). From what I have read, if hardware, could be out of alignment sensors (or even dirty sensors - so start by washing the car if you haven't tried that already) - or related to the processor/computer which definitely requires service if so. Good luck!

elecfan2 | 2019年4月6日

@magic8ball Tesla told me on the phone that emergency braking was disabled as they were listing off all the errors they were getting in the logs. I love my model three, but this is crazy. I know you see fudsters under every bed, but there are problems. VIN# 5YJ3E1EB6JF082642, version 2019.8.5 3aaa23d

elecfan2 | 2019年4月6日

@dev, Tesla said mobile service can't work on autopilot stuff. I'm on the road a lot, so the earliest service is late next week back on my home state, booked for weeks in north Carolina Carolina I currently am in so that's not an option. This isn't a dirty sensor problem, car is clean, Tesla has confirmed multiple errors and failure. I've also had the cameras already replaced by Tesla. I got a lemon performance model 3.

Magic 8 Ball | 2019年4月7日

@ewd7 So TESLA told you emergency braking was disabled and said you can still drive the car? I believe there is some communication error and misunderstanding.

steveserbalik | 2019年4月7日

I tried the reset, and even a factory reset, with no avail. Service scheduled...:(

kerry986 | 2019年4月8日

I’m having same issues as OP. Mine started a few days ago after a software update that was pushed to my car failed to install. Currently have 2019.8.3, hopefully another software push will resolve the problem.

elecfan2 | 2019年4月8日

@m8b, Tesla told me it was disabled, I already told you that in another to head. They said it was a driver assist feature and not an essential part of the car therefore it was safe to drive. It's their way to weasel out of not towing it to the service center. When I asked about the required backing up procedure at superchargers and lack of a backup camera they said "we'll people have been driving cars for years without a backup camera".

csimgo | 2019年5月6日

I have experienced the same. I was driving on cruise control and it gave me a red message on the screen stating something to the effect cruise control is now off, take control of vehicle. Since then, I'm not able to turn on cruise control or autopilot - when I do, screen states cruise control unavailable. Rear camera works fine, just unable to see the lane lines and cars around me. I tried the 2 button restart with and without brake pedal as well as factory reset. Also left it overnight and still not working. Anyone find a solution for this yet?

alebouc | 2019年5月6日

I have the same problem... Tesla service ask me to wait until tomorrow

bcb2220 | 2019年5月6日

i got off the phone with them and they said i needed to take into service for left and front camera calibrating was working fine for me this morning then 20 min later wasn't working at all.

tried multiple soft and hard reboots and nothing.

bcb2220 | 2019年5月6日

Omg. It’s back for me!! Did another hard reboot via security settings. Let it sit for 3 min. Drove around for 10 min and came back on!

beaver | 2019年5月6日

AP disappeared (no lane lines, no cars) once while driving 12.1.2, I filed a bug report and it returned instantly

-TheJohn- | 2019年5月6日

I've had this happen twice in the last week. Once it fixed itself pretty quickly (minutes) and the other time it was off all afternoon and night. Came back on in the morning though.
The overnight outage happened exactly as it happened to csimgo.

ShaunyD | 2019年5月6日

This happened to my 03/2019 M3 SR+ HW2.5 after updating to 12.1.2 this past Friday. I get cruise control, but it's basic CC as it doesn't slow down for lead cars. I go into AP settings and it asks me to order Autopilot. I have 19 days left on my AP trial.

MMLZero | 2019年5月7日

I have the same issue. I was on 2019.8.5, works fine for a month and it started to happen about 2 weeks ago, when it is not working headlight is always on as well. It comes and goes, took it in for service last week, and of course it was working when I bought it in, nothing they can do but to push an 2019.8.6 update on it. It was working fine (only 2 days) then I got the 2019.12.1.2 update, it also works fine but for 2 days only, and it starts happening again yesterday. As this point I'm not sure if I need to make another appointment for service.

gballant4570 | 2019年5月7日

This happened in my car for one day - no amount or type of rebooting helped. The day in question was the day I was on 12.1.1, and the next day I installed 12.1.2. That fixed it.

Gnahux | 2019年5月7日

This happened to me today, hard reboot twice and not fixed yet, just scheduled service. I call 8777983752 but never got pick up. Anyone same exp of Telsa call? Thanks

Tesla2018 | 2019年5月8日

I got the new update the other day. When driving home in he rain yesterday, I got a pop up warning to take control while using the automatic steering feature. I did not have navigate on autopilot with the single blue line since it was on a 3 lane road and it did not give me the option.

Then I noticed that I had no lane markers, and I could have sworn that it used to have dashes for lanes, but now it is only solid lines on both sides of the car. When I do a lane change, it will do it automatically, and make it a dotted or dashed line until it gets into the other lane. Also had it do an automatic reboot since I had the upgrade, and tried doing a few manually. Does my camera need time to recalibrate, since I have only driven about 30 miles since the update, or could it be because ti is raining and the sensor or camera gets confused about what kind of lane it is?

deezeela | 2019年5月8日

This happened to me last night with No lane marking ( I have the latest 2019.12 hardware version installed). I rebooted twice (don't know what "deep" reboot is with break pedal?), but no help.

But, this morning when I started driving, lane marking was appearing again.

efuseakay | 2019年5月8日

Just happened to me now. Tried two button reset, two button reset with pedal, and powering off in settings. Nothing. Headlights are on with auto setting. AP not seeing cars around me or any speed limit signs. Annoying. Hoping it’s just a glitch. Will file an audio bug report when I get back to the car.

efuseakay | 2019年5月8日

12.1.2 btw.

cnistal1 | 2019年5月8日

Version 12.1.2. This just occurred this morning on my way to work. Mirrors what others have reported. Got the "Cruise not available" error message. Also headlight are now on during daylight hours. Surrounding vehicles no longer displayed. Rebooted twice, no change.

juliette | 2019年5月8日

I had the same problem - fixed by bringing it in to Tesla for service, which I scheduled in the app. They replaced a pillar camera and ran the car through calibration testing, and it's been fine since.

efuseakay | 2019年5月8日

Good to know juliette. But this just seems too weird, with so many other reports of this happening.

Effopec | 2019年5月8日

I've had EAP bail on me 3 times since 8.1.2, one time it completely lost all visual (no cars on display, no speed limit, etc) for about 5 minutes. The other 2 times just the loud squawk and red screen until I started driving. I only had that happen one time prior to 8.1.2, while I passed through an intersection with poor lane markings. Driving in general on EAP seems much smoother, but buggy compared to prior revisions.

cnistal1 | 2019年5月8日

It's difficult to believe so many cameras stopped working around the same time. Sound like a software related issue. Or at least, that's what I'm hoping for!

pdgecko | 2019年5月8日

Last night I was waiting in a school parking lot to pick up my son. Set the lights to off to not annoy other cars. Turned them back to auto for the trip home. Auto brights did not work as they had on the same road coming out. In the morning, unlocked car via phone. Left mirror did not unfold. Cycled mirrors via control panel and they reset fine (this happened once before). Driving in this morning, no lane markings, no cruise control, no identification of cars around the vehicle, no AP. Tried both resets and a power off. Did not fix. Charged at work. When I left work, all was back to normal. Had new software install last weekend. 2019.12.1.2 5c87371

mdelro1 | 2019年5月8日

Had the same problem on5/7/19, spoke to service. They recommended cleaning the cameras, it fixed the problem.

efuseakay | 2019年5月8日

Plugged car in at home for a few hours today and went for a drive. It cleared itself up. Clearly a software glitch of some sort. None of my cameras were dirty.

pdgecko | 2019年5月9日

If it were the cameras, it would be helpful if the car could either 1) Tell you which cameras were in need of cleaning or 2) could give you a soft button like the one for the rear view camera which would give you the on screen view from each one.

chudley78 | 2019年5月10日

Having same issue, I'm able to put it in park at a light or stop sign and all functions return to normal operation. Has never occured more than once per driving cycle

rdh37 | 2019年5月10日

On the way to work this morning, "cruise not available." Looked at the screen, no lines, cars etc. Couple of minutes later, fully working WITHOUT any reboot. At local streets by my office with TACC off, cars and lines disappeared from the screen again. Will do brake reboot when I leave for home this afternoon. Forgot to file a bug report but will this afternoon if it happens again. My guess, a glitch in the matrix (neural net) or communication and the car(s) reacting. Otherwise, to me at least, it seems unlikely that so many cars are having simultaneous hardware failures that would trigger the same problem. Mine is a 2/2019 build with 12.1.2. Have a nice day.

SnakeByte | 2019年5月10日

I'm having the same problem. Worked fine driving down for to my destination for the day. Parked in an underground lot. On my way home, the screen showed no lane markers, no nearby cars, and autopilot was unavailable. Submitted a bug report.

Tried the two button reset while driving, but that didn't work. Parked overnight, still didn't work the next day. Pulled over, and tried the two button reset with brake petal until the "T" shows on the screen -- didn't help. Used the Telsa app to report the problem and schedule a repair. Just now tried "ask a question" from the Tesla website but I just tried that now, and it's after hours.

Model 3, AWD 2019.12.1.2 (installed 05/02/2019) with approx 4000 mi driven. Manufactured 09/2018.

Ejected USB storage from Tesla by holding down on the camera icon until the red record like turned gray.

SaveClips folder on the USB key shows video corruption on all video files from both left and right pillars on 05/08/2019 after using autopilot to drive to the destination. All previous video files going back to March are fine (I don't usually use autopilot).

RecentClips folder shows a bunch of files, all 1k in size. Doing a binary compare of the files show that they are all identical -- even from different cameras. Hex edits shows that Tesla wrote what looks like the header for the video files, but didn't append any video data afterwards.

chkdsk of the usb shows that there are errors, so reran with /f to fix.

Safely dismounted it from the pc and plugged it back into the Tesla. Attempted to turn on sentry mode (it showed blue active), however after leaving the car for a bit and coming back without my phone, the screen didn't show that sentry mode was active and my attempt to open the door didn't set off any alarm.

After unlocking the car, I tried one last thing -- tapped the camera icon to have it save to recentclips, however after dismounted the usb from the car and plugging it back into the PC, it was the same problem with the files -- all just had header info and no video data. I performed another chkdsk on the drive, but it came back clean this time.

This tells me that the entire video system used for autopilot/security (reverse camera which continues to work), is currently hosed.

Rigel25 | 2019年5月12日

That is exactly what just happened to my Model 3 SR+. I just bought mine last April 24th and this happened? Definitely a software glitch in my opinion. Hope it get resolved right away.

beachbird | 2019年5月12日

@efuseakay - exact same story for me. Nothing worked then after I parked for 40 mins meal break and did 15 mins on a supercharger, everything back to normal...

brihoff33 | 2019年5月12日

I'm having very similar issues. My EAP stopped working a few days ago. Unknown as to why. I've tried the resets listed above and still I have no EAP. Cameras are clean. No lane lines show up. Just my car with headlights on. I've got an appointment at a service center for this coming Friday, but hopefully they'll contact me sooner with a resolution.

My two cents being a technician and from all the things I've read here and heard during Autonomy Day makes me think that the NVIDIA card in HW 2.5 is currently reaching a point where on some vehicles it's being overloaded by what it's being asked to do. Perhaps, a failsafe in the software is to prevent AutoPilot from running while the card is busy trying to figure out how to solve a problem it's been asked to solve? It's just conjecture but it makes sense considering the different lengths of times it's taking for AutoPilot to return and why in some cases it's not returning at all even with hard resets.

Model 3 LR AWD 09/2018

nf1951 | 2019年5月12日

I Have the same issue with Cruise and autopilot. Mine is slightly different than what's been posted in that the car drops speed and picks up speed again without cars in front of me. Happens in both cruise and auto pilot mode. Then when it starts working for awhile it will tailgate the car in front of me. I have the autopilot set at 7 lengths. Its become a safety issue as well. It's useless to use the features anymore until they find a fix. Rebooting didn't work for me. I have a Model S and I'm pretty fed up with paying a huge lease payment and not being able to use the features I am paying for. Hopefully they are working on a fix. Surprisingly they took my car in to check it all out and told me it was software related. I was surprised because if so many people are affected, I would have thought they'd just tell me they know what's going on and working on fixing the issues. I wonder if they bother reading these blogs!

Rigel25 | 2019年5月12日

So mine got back to normal again. I did "Power Off" first before the Hard Reboot (Brake pedal and the 2 buttons). And it seems to work. Hope this works for you guys as well.

kelly.maddy | 2019年5月15日

Same is happening to mine 12.1.2 LR RWD purchased on 4/5 with AP.

kelly.maddy | 2019年5月16日

Fixed when support reflashed 2019.12.1.2 to mine, claimed the last attempt bypassed the AP module. Working now.

Teslaowner1717 | 2019年5月18日

We received our model 3 4 days ago. The sensors went out, no cruise control, auto windshield wipers not working, no lines on the road, and no autopilot. All of the same symptoms described by many others posts in the forum. Tried soft reboot, hard reboot, and factory reset. Nothing works. I messaged support, I got a call back and spoke to the rudest person who was of no help. She told me to call the service center which I had already done and said I needed to make an appointment but they are closed all weekend. It’s a Saturday morning, I fly out of town for work on Monday. We drove to a service center and people were there but they said their tech was out but to make an online appointment. When I went to make an online appointment the soonest available appointment was in 4 days which means the car will likely have been broken longer than the time we had it working. Super disappointed at the level of service we’ve received and the quality of the vehicle after a few days of normal use on a $50k+ car. Strongly considering returning the vehicle as we still quality for the 7 day return. Super let down by Tesla.

Magic 8 Ball | 2019年5月18日

@victoria It is no excuse for rude service but recent news may have some employees on edge (everyone reacts different to news). Hopefully you will end up liking the car enough to make up for the shortcomings of a few individuals. I have seen time and time again people come here to voice frustrations only to come back later to extol virtues and help others settle down with their frustrations.

So to get it straight you called roadside service and told them the car is dead and they told you to wait until Monday?

Teslaowner1717 | 2019年5月18日

@magic8ball, what recent news are you I referring to? Regardless, customer service for a consumer vehicle on major issues such as sensors going out should have P0 emergency support. Yes, I called support, spoke to roadside assistance, and went to a service center. All of which were unable to fix a major sensor outage on a brand new vehicle because “it’s the weekend”. Not here to seek consolation from anyone on the thread. Posting here so that others are aware of vehicle issues and the level of service Tesla provides customers. Many of the other comments on this forum have helped me identify that it isn’t only my vehicle having this issue. Also, more reports will only help Tesla resolve their technical and support issues hopefully for future customers down the road whether we decide to remain a customer or not.

jjgunn | 2019年5月18日


Request service for your car & ask them to send Tesla Mobile Service out to calibrate everything. Worked for me so far.