Autopilot stopped working and won't come back

Autopilot stopped working and won't come back

Model 3 SR+ on 2019.16.2.

This morning during my drive to work, I noticed my car suddenly stopped recognizing adjacent cars and lane markings. When I tried using autopilot, it said "cruise control unavailable". it never gave me any warnings about autopilot, poor visibility, or anything else. The display only shows my car, with the headlights on, even though they are off.

I tried to fix it by resetting the display, holding both scroll wheels and nothing. Once parked, I tried resetting by holding both scroll wheels and pressing the brake at the same time. I still can't use autopilot. no error messages come up. The car is clean and camera visibility is good.

Is there anything else I should try? Anyone had similar issues?

khoa | 2019年5月29日

This happened to me recently for the first time ever (owned Tesla M3 since 11/2018). Coincidentally, I just got firmware 2019.16.2, so it’s likely buggy AP in this version.

Apparently, if AP computer crashes a few times in a row,
It gets taken offline and no Autodrive or any lanes or close by vehicles will show up on the. Isualizer. Additionally, auto high beam will no longer work.

Reboots soft or hard doesn’t seem to clear this problem. It seems that the Tesla must be completely off to fully reset and for AP to work again. To do this, I turned off Sentry mode and parked the car. Came back hours later and AP worked again, no problem since.

Now, I turn off auto-enable of Sentry Mode since having it on will keep the Tesla awake, and not give it a chance to turn off and reset AP degraded mode caused by AP computer crashes.

You might also want to try “Turn off car” in the service menu, this might be the same as parking and waiting. I haven’t ran into this problem again to try this.

tjringle23 | 2019年5月29日

I've had this problem before, and I had to have one of my front sensors replaced. That was a few months ago, and it's been fine ever since. Happened again today on my way to work. Wouldn't sense lines and no autopilot available. Hoping it's not an issue with the sensors again, just a software bug.

kris.tritz | 2019年5月29日

I had this happen to me a few days ago, 16.2, and ended up calling tesla support. They were no help. I noticed my usb was full of corrupt dashcam videos and no sentry recordings. So I kept the usb out and tried turning the auto sentry off, and autopilot is back. I did let the car go to sleep for a couple hours after I turned off auto sentry, so that may have helped her "reset." Prior to this discovery, I tried countless soft reboots, hard reboots, charging, sleeping, turning off, everything, and nothing helped until I turned off auto sentry. Now, I took a chance and plugged back in my usb (after less than a day of autopilot coming back), turned auto sentry back on, but left off at home, and it's still working great. Day two of this experiment with no issues.

tesla88919 | 2019年5月29日

This same thing happened to me today. My car is not noticing any cars around me. I upgraded to 16.2 two days ago.

Gregg Ray | 2019年5月29日

Same here, tried powering down in (safety and security I believe), also the scroll wheels, to no avail, that was this morning, tried again just before coming here...

ALDONY | 2019年5月29日


Same for me.

I tried everything, I even hit the factory reset button.
Nothing worked, I called tstal and they told me to schedule a service appointment.
I did but had to wait until 2nd week of June.

I went shopping and decided to click the sentry mode of and play around .

When I came back everything was back to normal. So I canceled my service appt

stopnair | 2019年5月29日

This is very weird you guys going thru the issues... I have a 03/19 build LR RWD and I used AP flawlessly today.. Loved it..

kcheng | 2019年5月29日

Day after my car updated to 16.2, AP and TACC stopped working after 4 miles, and came back after 25 miles. It rebooted on its own.

gieseker | 2019年5月30日

Mine has done this twice. The first time it resolved after powering down and letting the car sleep. This last time was different and I stopped by the Service Center for them to review the logs. They saw something unusual and checked it in for service, so there may be a HW issue with a similar list of symptoms.

My car had the following behavior:
Ultrasonic Parking sensors worked for parking operations
Collision avoidance and sensing to detect cars around me stopped working
No lane or object animations on the screen
No TACC or AP (Cruise Control Unavailable message)
Headlights defaulted on even during the daylight (menu setting cannot turn them off either)

The technician mentioned that the car may not sleep with my Anker USB hub and memory card inserted into the front USBs. Apparently, these USB ports are not isolated and can cause SW issues/bugs to appear.

My suggestion is to try unplugging USB devices, turn off the Tesla App on your phone, disable BT on your phone and power down the car via the safety and security menu to get it to sleep. I also logged out of Remote S to make sure nothing was trying to "talk' to the car and prevent full sleep.

giriadhikar | 2019年12月12日

This happened to me this morning, autopilot suddenly stopped with the warning "not going to support for the rest of the navigation!
This is Wired :(

Tootallone | 2020年2月17日

Had this problem today as I attempted a 7 hour road trip. No Cruise or AP. Unsure of any other associated problems since we returned home and did a couple soft boots with no fix. I've powered down to see if this helps and will update when I can road test.
I wish that there was a troubleshooting page on our wonderful computer/car that could provide some clue as to how we might address the problem. When this happened on the road several weeks ago, I discovered a bug accumulation on the sensors that running through the car wash immediately resolved. This was not today's problem and we were very disappointed to loose our trip because of our very expensive model X.

EVRider | 2020年2月17日

@Tootallone: Not sure what you mean by losing your trip, but have you scheduled a service appointment? Since rebooting hasn’t helped, you might have a hardware issue.

Goldie | 2020年2月17日

I too have been having these intermittent problems during and after cold rainy weather. "Autopilot Safety/convenience features unavailable Features might be restored on next drive" error. You don't realize how much you miss autopilot when its not available and actually have to drive manually :)
I have scheduled service (2 weeks out unfortunately). Others have said it might be a condensation or calibration issue. I will post after service.
Anybody else have any feedback on this issue?

pjwheeler83 | 2020年2月17日

I've been getting these issues as well. It appears to be due to a bit of condensation on the inside of the glass. 7 degrees outside the car and 71 inside can have that affect. Inspect the cameras.

As far as i know its easily remedied by turning on the defrost/ windshield vents for a few minutes.

Good old Michigan!

Tootallone | 2020年2月17日

I did the shutdown after turning off the sentry mode and also removed the USB video stick from the forward USB plug. After about an hour of down time, the cruise and AP returned with no issues. Thank you to those who figured this out months ago and I wish I could have discovered this earlier. We love our model X and we"were" going to see a Space X launch today. Oh well, maybe next time...