Dashcam: USB Drive is too slow to save

Dashcam: USB Drive is too slow to save

Hello ladies and gents,

I updated to the latest software and now all of a sudden the computer says that the USB is too slow to save. It's a "quality" PNY 3.0 stick with 128 gigs of space. It worked flawless before this update. Anyone experience the same issue?

EVRider | 2019年8月11日

I didn’t mention this in my previous reply where I listed the drives I’ve used without problems, but they’re plugged directly into the USB ports, no hub or cables involved.

EbiPeople | 2019年8月14日

SOLUTION: I spoke with Tesla support and had a service appointment for this issue (overkill I know, but curious to see what they said). The Tesla rep reported that they had some information to suggest that the issue occurs with USB drives LARGER than 32GB. Seemed hard to believe that this was the issue, as I was using a very high write speed USB 3.1 solution previously. However, I bought the $9 Samsung MUF-32AB/AM FIT Plus 32GB drive on Amazon and is is working perfectly several days in (whereas I always got the alert within an hour previously). I'm holding on to my 128 GB USB drive in hopes that the next update solves the problem, but for $9 this was a good work around. Only problem is that the drive obviously fills up very quickly if using Sentry Mode. Hope this is helpful.

SteveWin1 | 2019年8月14日

I'm using a 128GB SSD and I don't get any errors. I do get some artifacts on some of the recordings and sometimes, especially with the right repeater, I get 0 byte files with nothing in them. It would be AMAZING if Tesla would sell a drive from their own store that is guaranteed to work with their cars. There are tons of threads on the forum about what drive to get. This would be extra revenue for Tesla and would save us all money, rather than having to buy several drives (I'm on #3) to try to find one that works well. | 2019年8月14日

On various drives and how well they work - first the read speed often has little relation to write speed. Sometimes they are similar, but unless write speed is specified, expect the drive's write performance poor. Even when specified, this is the peak data rate,

The drive design has a huge effect to how writes are handled. Many "fast write" drives use a tiny cache to meet some fast specification. As soon as that tiny cache fills, write times become a tiny fraction of the "rated" write speed. I suspect that's why the SanDisk Extreme Go, 3.1, with a fast write time, performs so poorly. A drive can use a larger cache to hide a crummy flash memory, but with high-volume data as occurs with dashcam video, it will run out and then problems occur such as missed frames or corrupted data.

There are some flash drives and SSDs that will work, but right now microSD cards are the best solution. The right micro SD cards are rated for both high temps, endurance and continuous write speed.

I've changed my recommendations for various memory choices: and I'll continue to update as I do more tests.

jayhawk_1994 | 2019年8月14日

So I started experiencing the same problem in my Model S the other day. I was using a SanDisk 64GB cruzer fit USB. Worked successfully although sometime the Right Repeater would be blank for my recordings. Then started getting the Too Slow to Write message about the middle of July. I did some various readings including this thread. I settled by buying a Samsung PRO Endurance 64GB Micro SDXC card ($17.99 on Amazon) and placed it into a Geekgo SD Card Reader,Micro SD TF USB Memory Card Reader ($16.92 on Amazon). This solved all my problems. Recording flawlessly now. No missing Right Repeater video. No error messages about write speed. This Geekgo will fit in the USB slot and still allow me to close the cover in my Model S with no problem. And, the great part is I can pull it out and plug it into my iPhone to watch the videos instantly with the iUSB app that you use with the Geekgo stick.

jayhawk_1994 | 2019年8月14日

Oh - and I should add - I downloaded and used GuFormat.exe to do the FAT32 format on the memory card in Windows 10.

BradPDX | 2019年8月14日

I'm using a Samsung 3.1 128GB USB stick with no problems for music or Dashcam in my M3. I was suspicious about formatting, as the original (ancient and slow) FAT32 spec is limited to 32GB, and so while you can format a drive with FAT32 that is larger it doesn't always work.

I use only Mac computers for work and play, and so used Apple Disk Utility to partition to drive into 2 parts - 32GB for music, 96GB for Dashcam. I made sure that the root of the drive was formatted with a Master Boot Record, then created 2 partitions that used macOS HFS+. After the HFS+ partitions each checked out, I converted each one to FAT32. Both music and Dashcam work fine, and I note that I have plenty of space for recordings when using Sentry mode.

USB drives are often heat sensitive, and any car interior certainly gets hot. My old SanDisk drives routinely overheat and give up during large transfers, and so I chose this Samsung for it's better temperature performance. So far, so good.

Ab_m | 2019年8月15日

I also had the same error "drive too slow to save" after the update on my Long Range Model 3. My 64GB SanDisk Cruzer 2.0 USB Flash drive worked fine until the update. Although, some of the footage would occasionally be scrambled. Thanks to Tesla.Tap, I got the RMPrepUSB tool they mentioned in one of their posts on fake USB drives and found out that the SanDisk Cruzer had terrible write speed at <1 MB/s. I ended up testing several 2.0 and 3.0 USB flash drives w varying write speeds and it seems that the minimum write speed needed to avoid the error should be =>6 MB/s w either 2.0 or 3.0 USBs.
Bottom line, minimum requirements to avoid the "too slow to save" error with USB flask drives are:
1. Write speed no less than 6 MB/s
2. USB 2.0 or higher

MDMatt | 2019年8月19日

I also started getting this issue, but I think I tracked down our issue. We had been using a SanDisk 128GB thumb drive, one of those that is barely bigger than the USB port. The issue was that the drive was heating up too much due to the constant writes. When it would stop recording/error, I could pull it out and put it back in and get the same error. But if I pulled it out, and put it in the AC for a little bit, it was fine for a while again.

I changed to using an SSD, have not had any issues. So I think that you can have a good quality Thumbdrive without any issues, but because of the heat of constant writes, it just can not keep up. Some drives that do work are probably larger, and so they have more space for heat dissipation.

This is just my experience and what we found that works. I would have tried a physically larger thumbdrive, but were on a trip in a place where Walmart was the only place for things like that, and they only have 16GB thumb drives or an SSD, so I went with the USB based SSD. Two more days of driving almost all day, and no more issues.

Hope that this helps someone else.

EVRider | 2019年8月19日

@MDMatt: I was using one of those tiny SanDisks (UltraFit) but didn't get the error. I've owned two versions of that SanDisk, and the newer one, which I was using for video, has more plastic and less metal than the old one, and doesn't get as hot. I still use the old one for playing music.

rbagaco | 2019年8月22日

I also had the same error "drive too slow to save" I am using a Samsung Pro High Endurance micro SD 128GB write speed 30MB/s. I was also using a SanDisk 128GB worked for a while then started getting same error message. | 2019年8月22日

@rbagaco - I've had good luck with the same micro SD card, no error messages yet. You might try erasing all the files. Writes may get slower as the drive gets near full. Mfg write speeds are often done on an empty drive, and depending on the controller and design, it may take longer to fit in data when it is near full. | 2019年8月22日

I wasn't clear, but I've used both the Samsung Pro High Endurance 128 GB and the SanDisk Extreme Plus 128 GB. SanDisk makes quite a few variants, many not deigned for continuous video writes. The Extreme Plus is the only one I would use of the SanDisk variants.

p_dahlgren | 2019年8月22日

Me too, I have been using the Samsung Pro High Endurance 128 GB SD card based on TeslaTap's recommendations and so far no problems.
Also, since I only use Linux computers for work and home, as an experiment, I created an ext4 Linux file system on the SD card instead of fat32 and surprisingly it works perfectly even though the user manual says that only fat32 is supported. I consider ext4 superior to fat32.

TexasBob | 2019年8月22日

FWIW I have the Samsung MUF-128AB/AM FIT Plus 128GB - 300MB/s USB 3.1 Flash Drive and it gave me same error after upgrade to 28.2 (!). I pulled the drive, reformatted, and no issues since (1 week). | 2019年8月22日

@p_dahlgren - I just tested out the ext4 format as well and worked perfectly for me. I agree it's a more robust file system, but I expect few have the ability to create/view ext4. Somewhere in the long past, I do remember Tesla saying they support ext4. Considering it's the native file system for Linux used in the car, it makes sense.

EVRider | 2019年8月22日

@p_dahlgren: Funny you should bring up ext4 today — see this thread I created yesterday:

p_dahlgren | 2019年8月22日

@EVRider, Thanks, that's a cool thread, how could I have missed that? Good to see interest and native support of ext4.
@TeslaTap, I remember reading that someone had tried out ext4. As you say it should work since the infotainment system itself runs Linux but there was always a possible that the software would block based on file system type but I'm glad it did not.

p_dahlgren | 2019年8月22日

@TeslaTap, by the way thanks for your excellent guides on dashcams and flash drives (and on many other Tesla topics as well) at:

HoustonM3 | 2019年8月24日

Might want to update the list of USB drives that work and take off the Jetflash from Transcend. Mine won’t work at all. I’m on 2019.28.3.1. I have a handful of Transcend high endurance micro SD cards and will try those next. Will report back.

dnasserian | 2019年8月26日

After my first USB drive stopped working, I bought a SanDisk 64GB Ultra Fit USB 3.1 Flash Drive. Worked for about 3 weeks and today it stops working while I'm on the way to work.

I'm on 2019.28.3.1.

This is getting really frustrating...

cybergrafx | 2019年8月26日

I was using SanDisk 64GB Ultra Fit USB 3.1 Flash Drive. They work good but do not last very long. I have gone through 2 in the last few months.

@TESLATAP Thank you so much for posting this information:
I purchased one of the 128GB micro SD cards you recomended with the USB adapter. I had an issue converting it to Fat32 on my Mac so I downloaded the guiformater for my pc.
It's working fine so far...

I just read that we can now start using ext4. What's the best converter for that?

EVRider | 2019年8月26日

@dnasserian: What do you mean when you say the drive stopped working? If you mean it stopped recording video, did you check if the drive is full?

EVRider | 2019年8月26日

@cybergrafx: ext4 won’t help you if your computer doesn’t support that format, since you won’t be able to view the videos.

p_dahlgren | 2019年8月26日

@cybergrafx, to be able to use ext4 formatted sdcards for dashcams smoothly and without issues you really need to have some session on your computers that run Linux. Then, you can just use the regular video players that come with Linux natively such as Mplayer or VLC to view the dashcam videos, and formatting the sdcard to ext4 of course is much easier on Linux since it's the native file system. I wouldn't trust converter or additional layers of software just to access ext4 but there probably are converters available. I run Linux on all my systems.

dnasserian | 2019年8月26日

@EVRider it's not even close to full. It literally worked for 3 weeks with no issues and this morning it gave me to error about write speed even though it has a ton of video on it already.

I unplugged it and plugged it back in and it worked for a bit then went off again.

Tesla needs to patch this because I'm tired of buying USB drives.

BradPDX | 2019年8月26日

Some experiences and pointers:

- The super-tiny SanDisk UltraFits are not good for this - they heat up badly due to their small size. Even on regular computers, they often shut down during large transfers. Too bad.
- You don't need to download any software to do proper formatting on a Mac, which is after all a Unix machine.

Recommended sequence using Apple's Disk Utility:
1. Format the drive to be a native Unix format (e.g., HFS+) using a Master Boot Record (don't use a GUID map)
2. Partition the drive if you like (HFS+ is partitionable).
3. Erase the partitions you wish to use using FAT32.
4. Done. You have have a disk with multiple FAT32 partitions of any size that are readable on Linux, macOS and Windows.

The reason for this hullabaloo is to format the Master Boot Record. Such a thing isn't necessary for macOS, but is still part of how other systems read legacy formats like FAT32. Once the MBR is in place, everything should work fine and be as fast as FAT32 can be (which isn't great).

All Tesla videos are natively viewable using the native QuickTime framework - you don't even need to open QuickTime.

Chuyinzki | 2019年8月30日

Same thing happened to me with my "SanDisk Cruzer CZ36 64GB USB 2.0 Flash Drive, Frustration-Free Packaging- SDCZ36-064G-AFFP". Maybe it got tired of writing, but it seems to be pretty correlated to an update. Meh, figured I'd put that out to pasture and get follow the recommendations in "" mentioned here with a micro SD and adapter.

mwk | 2019年9月2日

I quite certain this is a Tesla bug. Before the software upgrade I had a 256G USB that worked fine, formatted exFAT. Then after the upgrade dashcam failed with the USB too slow warnings. I reformatted the 256G drive to FAT32, still had the same error.

On the forum someone said Tesla support told them it's a problem with drives larger than 32G. Sure enough, I switched to a 32G drive -- with identical performance specs -- and it works fine.

I think Tesla just broke their support for FAT32 drives > 32G. I've had one upgrade since the bug appeared (I'm now running 2019.28.3.1) but it's still not fixed. | 2019年9月2日

@dnasserian & @nwk

Nothing wrong with Tesla - it's your drives. Many drives use really cheap flash memory with a tiny RAM cache. When the RAM cache fills, drive writes slow down dramatically. Also when the drive gets near full, drive writes can also suffer greatly. You really need to go with a drive designed specifically for continuous video writing. See my list of recommendations:

While I've had reasonable success with a few flash drives, high-endurance micro SD cards for dashcams work the best. In addition, these have the temperature range normally encountered in a car. Most flash drives are intended for the home and are not rated for extreme cold or heat. Remember, these drives need to work with Sentry mode, so the cabin can easily be 150F when parked in the sun. It's no wonder drives designed for the home die or have performance issues in the brutal heat of the car. | 2019年9月2日

For those that use Windows and want to use ext4 without Linux, I've had good success with Paragon's Linux File System for Windows. Allows you to mount and unmount ext4 drives so it can be used by Explorer and other Windows programs. Unlike Windows FAT32/NTFS you have to remember to unmount the drive after writing to it, or the changes may not take effect. This includes creating the file folder "TeslaCam" and/or deleting old videos from the drive. I'm not sure it's worth the bother for those without Linux, but it is an option.

mwk | 2019年9月2日 That's a great article and good advice.

But my problem appears to be a Tesla bug:
- It's not temperature. It fails the same way even with a new drive in a cool car.
- I benchmarked the USB sticks myself using big (2GB) writes. They have loads of speed. So it's not a RAM caching issue
- It's not endurance as they are new drives
- I have two USB drives that are same model and performance. The 32G drive works perfectly, the 256G drive fails.

Tesla support said there's a bug with USB drives larger than 32G. That's what it looks like to me.

Mde0509 | 2019年9月2日

I had that error, and it would come up half an hour into the drive every time I replug the usb. I reset the Tesla and the error went away for good.

AAAA3 | 2019年9月2日

Tesla creates two sub directories under the "TeslaCam" directory. They are called "RecentClips" and "SavedClips". Every time you use "SENTRY MODE" and if it gets activated, it creates sub directories under"SavedClips" directory. These sub directories grow over time. Under FAT32 there can be only 65,534 directories within another directory. For those who have large 120 GB USB drive, I think that the error comes when the number of sub directories reaches the 65,534 limit. For those who have smaller size drives, the drive is simply full.
So to resolve the issue, go to the "SavedClips" directory and delete all unwanted sub directories. You can also delete any unwanted clips under the "RecentClips" too. Plug back your USB drive and it should be good to go.

EVRider | 2019年9月2日

@AAAA3: Do you know how many years it would take for Sentry Mode to create 65,535 directories? Do the math — that isn’t the problem.

betesami | 2019年9月3日

Same issue here. Started with 2019.28 update for me

edwpang | 2019年9月3日

I can also see corruption with some of my USB drives. I don't know how Tesla do with the video exactly. As a multimedia driver dev, I assume the video is compressed internally already which should take very little bandwidth to just copy out from internal storage of some kind. I really don't understand why 5Mb/S or 635KB/s data copy needs so picky about USB drive.

Dumped one of higher bitrate clip info as follows:
Codec ID/Info : High Efficiency Video Coding(HEVC)
Duration : 46 s 425 ms
Bit rate : 5 060 kb/s
Width : 1 280 pixels
Height : 960 pixels

bernhard.connemann | 2019年9月9日

Tried using the Samsung MUF 256 GB AB/AM Fit Plus, getting alerts about write speed all the time, and scrambled sentry videos, especially from the left repeater. SanDisk Cruzer Fit 64 GB did somewhat better (despite USB 2.0), but unpredictably overall. Of course, this is a software issue; otherwise the right repeater shouldn't do better than the left. Also, I never had any problem with the front camera, and normally there is no problem at all with the dashcam, it is just the sentry mode.

bernhard.connemann | 2019年9月9日

Tried using the Samsung MUF 256 GB AB/AM Fit Plus, getting alerts about write speed all the time, and scrambled sentry videos, especially from the left repeater. SanDisk Cruzer Fit 64 GB did somewhat better (despite USB 2.0), but unpredictably overall. Of course, this is a software issue; otherwise the right repeater shouldn't do better than the left. Also, I never had any problem with the front camera, and normally there is no problem at all with the dashcam, it is just the sentry mode.

bernhard.connemann | 2019年9月9日

Now trying the Supersonic Rage 256. Comes with FAT32. Again, scrambling with the left repeater and, in addition, down-regulated exposure on the front camera, and again, no problem at all with dash cam mode. I don't believe this could be hardware malfunctioning.

bernhard.connemann | 2019年9月9日

@AAAA3: Ok, nice thought. As the errors appear to be starting with file #1, there would be no need for accusing the allocation table, or stacks, or anything ;-). No, this must be something really simple. Like the driver's mirror not folding out, or the door handles not fully retracting. Just bugs, nothing more. Shouldn't be a big deal.

bernhard.connemann | 2019年9月9日

And I hope, Tesla are reading here, because this is annoying, and unnecessary.

jimglas | 2019年9月9日

tesla not reading here, its a user forum.
Contact tesla

dnasserian | 2019年9月9日

Mine worked until the update and now multiple drives aren't working for me. This is a Tesla issue 100%.

LostInTx | 2019年9月10日

This error started on my 3 today. Have used a Samsung Pro High Endurance 256 GB 3.1 for months - it's a very good USB and has worked flawlessly for 6+ months.

USB had 170 GB of data so wiped it all out, down to the TeslaCam directory. Plugged in and worked - for about 20 minutes. Ugh. This after receiving 2019.32.1.53f03e4 over the weekend.

For all the good things Tesla does, things like this are very frustrating.

LostInTx | 2019年9月12日

After receiving 2019.32.1.53f03e4:

Three high-quality USB's having 256GB, even those that have worked previously, now fail to record.
Three USB's of 32GB, of varying levels of quality, record flawlessly.

Results are consistent using both center console USB ports.

I have a geophysical software development company and we exhaustively perform regression tests prior to releasing updates. Things still slip out. Even with Tesla, things slip out. ..and so it goes.

WheninSF | 2019年9月14日

This is an extremely irritating new issue. I had one drive fail (maybe the drive? maybe the car?) and now this incessant slow speed warning. I’m using a Samsung 3.1.

Will try two things based on some notes in this thread:
Changing the master boot record to HFS+
Partitioning the TeslaCam to something under 100 GB. Maybe it needs to be under 32? We shall see.

TexasBob | 2019年9月14日

@Lost @WheninSF Just to share an update from my post above: I had the same thing happen after 28.2 (Samsung MUF-128AB/AM FIT Plus 128GB - 300MB/s USB 3.1) in mid August. I reformatted and it has continued to be fine. for 4+weeks.

sandysimon45 | 2019年9月14日

EVRider. Bought the Samsung High Endurance microSDXC 128gb card and the Scandisk Mobile USB just like you. Plugging it directly into the right side front port. It is formatted correctly as a FAT32. I do not get the Dashcam icon at all, not matter how many times I reformat. So I plugged it in for Sentry mode today. Screen said 6 incidents. Put it in my computer and looked into the TeslaCam folder and nothing there. Ideas? Service? Thanks.

sparky123 | 2019年9月16日

I am also seeing the issue after the update but did not have the issue previously. The current drive is working intermittently (more often than not) which means it's fast enough most times. Has there been any solution?