Annoyance with lane changes and FSD

Annoyance with lane changes and FSD

A gripe about FSD lane changes. (I think lane changes are only enabled for FSD, right?)

Push indicator stick. After a few seconds, it changes lane, usually. great.
Sometimes, it chooses not to, because there is potentially dangerous traffic. Also a good thing.

SOMETIMES, though.... it initiates the lane change... gets literally halfway across... then freaks out and goes back.


Most of the time it seems to be triggered by a car coming up behind me. In which case there is zero point in aborting the lane change.
half the time it is a car in the ORIGINAL lane. so it would be SAFER to complete the lane change!!

really annoying.

stingray.don | 2020年2月4日

Submit a bug report when it happens so they can improve the performance. I have noticed significant improvements with auto lane change but it is not perfect. It will continue to improve.

EVRider | 2020年2月5日

If you’re just using Autosteer rather than Navigate on Autopilot, you need to hold the turn signal lever long enough to complete the lane change. If you release too soon the lane change will abort.

RickD | 2020年5月6日

I had the same experience a few times @phil. But usually it was on NoA, and when I drove the area again I saw a distinctive pattern in most of my cases: NoA asks me for a lane change to "follow the route". I confirm the change with the turn signal, but before the change is completed NoA figures out that the lane it was in before was actually the one it should be in to follow the route. In this case NoA will cancel the change.

hgmichna | 2020年5月7日

EVRider wrote: "If you’re just using Autosteer rather than Navigate on Autopilot, you need to hold the turn signal lever long enough to complete the lane change. If you release too soon the lane change will abort."

I don't think that is true. I have never held the turn signal lever until the lane change was completed, yet I do lane changes successfully.

Sometimes the autopilot aborts a lane change, but so far this has apparently always happened to me because another car came too close or cut into the destination lane from the other side.

By the way, I am under the impression that, when autopilot proposes a lane change, then it suffices to push the turn signal lever only to the first stop, not all the way. When I want to initiate a lane change, however, I have to push the lever all the way. Can anybody confirm or deny this?

RickD | 2020年5月7日

@hgmichna I have a Raven Model S, and in my case the lane change always needs a push to the first stop only. All the contrary, if I push the lever all the way, the lane change won't happen at all.

hgmichna | 2020年5月7日

Strange. One should think that different Tesla models have the same autopilot behavior.

EVRider | 2020年5月7日

@hgmichna: For lane changes in Navigate on Autopilot, you don't have to hold the turn signal stalk up or down, but for Auto Lane Change with Autosteer, you do. That's how it works for me, and it's consistent with the operation of the turn signal. In other words, if you push the stalk partway up or down and then release, the turn signal flashes 3 times and then stops, but if you press it all the way up/down, the turn signal stays on until you make the turn or cancel it. Auto Lane Change will abort as soon as the turn signal stops.

RickD | 2020年5月7日

@EVRider I just tested that yesterday evening, and my Model S definitely behaves differently. Even on Autosteer (I tested it on a highway without a destination in the navigation system, so no chance for NoA to kick in) a short tap on the turn signal is enough to initiate the lange change and keep the turn signal on until the change is done. (Which was 12 flashes in my test yesterday.)

EVRider | 2020年5月8日

@RickD: I’ll try that the next I’m on the highway. It didn’t used to work that way, so I haven’t tried releasing the turn signal stalk before completing the lane change. That would be an improvement. The manual just says you have to move the turn signal stalk all the way up or down, but if you do, you have to manually cancel the turn signal afterwards, at least on the S. The 3 has a different type of turn signal stalk.

EVRider | 2020年5月19日

@RickD: I finally had the opportunity to try Auto Lane Change in my Model S. You're right, it does work differently now. If I press the turn signal stalk partway, once the car starts the lane change I can release the stalk and it will complete the change. However, if I press the stalk and release it before the car starts changing lanes, it won't do it. Definitely an improvement.

I'm on 2020.16.2.1, which I just installed yesterday. | 2020年5月20日

Nov 2016 build, P100D. Mine worked slightly differently on 2020.16.2.1. When I merely tap the signal stalk the car will change lanes. No need to hold for the car to begin the lane change. Autopilot seems a bit smoother following the lane markers.