Firmware update 4.3 breaks USB/Micro SD 64GB drive functionality?

Firmware update 4.3 breaks USB/Micro SD 64GB drive functionality?

Based on recommendations I read here, when I took delivery of my Model S, I purchased a Micro SD thumb drive and a 32GB Micro SD card.

I filled it with music and it worked flawlessly. I later upgraded the 32GB card to a 64GB card, and that worked just fine as well.

However, immediately after applying the 4.3 firmware update, I noticed that the 64GB drive was no longer showing up under Media.

I tried rebooting the dash and touchscreen, with no luck. I then tried going back to the 32GB card. It mounted immediately and I was able to play music from it. When I went back to the 64GB card, however -- nothing. It doesn't show up. That same card mounts fine on my computer, so the card hasn't gone bad.

I called Tesla, and they hadn't heard about this problem. Has anyone else had a similar experience? Is anyone successfully using a 64GB card with the 4.3 update?

cgiGuy | 2013年3月27日

Does the 64 still work on your computer?

Tâm | 2013年3月27日

Just a clarification: Do you mean:

Big USB flash drive

Or tiny Micro SD Card

Or you mean all kinds of USB flash drives/cards... should work the same on Tesla?

Tâm | 2013年3月27日

Oops! Big & Tiny mentioned on captions didn't match with pictures. Sorry!

LeeU | 2013年4月5日

I reformatted the card as FAT32, filled it back up, and it's working fine. It was previously formatted at exFAT, which is how these cards ship. Curiously, though, prior to the Tesla 4.3 update, it was working fine in the car.

Regardless, reformatting has solved the problem.