Can't 'Manage' my Model S. Service says it's an issue with all MSs. Is it?

Can't 'Manage' my Model S. Service says it's an issue with all MSs. Is it?

For the last two weeks, when I log into my Tesla Account and click the 'Manage' button on my car, it just takes me to a blank page. I've talked to support and service about this, and they keep telling me it's a known issue that all Model Ss have, but I haven't seen anything about it online.

This has been particularly irksome as I wanted to purchase FSD before the increase, and that's the only place you can do it. I tried having support and service allow me to purchase FSD online/over the phone, but they all refused, telling me my page would get fixed before the May 10th increase. Low and behold, last Friday rolled around and the cost went up by $1,000. I happened to have mobile service out last Friday for a rebooting MCU issue, and I convinced the tech to let me purchase FSD through him at $5k, but he was super reluctant and worried it wouldn't get done correctly.

Here it is, May 9th, and I /still/ don't have access to the page. Is this actually a widespread issue, or is Tesla just pulling my leg? Is a typical experience?

GHammer | 2019年5月9日

Both of mine work fine, have you tried a different browser or computer.

spineeric | 2019年5月9日

My account works fine also. Perhaps just in your city/area? I'm in California, using a Mac, and Chrome, Safari and Firefox all work.

sr.smr | 2019年5月9日

Chrome on Windows 10 works for me.

drift | 2019年5月9日

I have the same problem. Am able to manage my Model 3 but get a blank page when I try to manage my Model S. Have contacted support and they say they're working on it.

Aerodyne | 2019年5月9日

Works for me. SoCal, Android, chrome...

egonzo21 | 2019年5月10日

Mine seems to work......however, with the one exception being my referral link section is gone.

EVRider | 2019年5月10日

The Manage links are working for sone people (including me) but not others. The referral information was gone for everyone, but this morning it’s back for me.

egonzo21 | 2019年5月10日

Oh cool! thanks @EVRider, I just checked and mine is back as well. All is right with my Tesla world.

heidiho | 2019年5月10日

S is blank and 3 is working fine.

zachwilljohn | 2019年5月10日

@hammer @OR-US - I've tried several browsers and machines. Definitely not a client issue.

TranzNDance | 2019年5月10日

It worked on iPhone and Mac Chrome browsers for me this morning. The referral section was gone until today. | 2019年5月10日

Just tested - working for me on Chrome.