Forums

Cannot Schedule Service Appointment through Tesla App

Cannot Schedule Service Appointment through Tesla App

I am having issues scheduling an appointment through the "Schedule Appointment" button on the Tesla App.
This problem has just started about a week ago. I have booked 4-5 appointments before through the app with no issues.

Expected Result:
1. Open Tesla App
2. Click "Schedule Appointment"
3. Enter appointment details

Actual Result:
1. Open Telsa App
2. Click "Schedule Appointment"
3. See loading screen for "Looking for appointments"
4. See loading screen for "Getting appointment details"
5. Loads details from a previously completed appointment. There is no option to schedule new appointment.

I have tried the following things with no success:
- Restarting my Android device
- Signing out of the app and signing back in
- Clearing Tesla App cache
- Reinstalling Tesla App

I have not been able to reach Tesla customer service regarding this issue. I tried following the the customer support links on the website, but it only takes me to the FAQ, which doesn't give me any useful information. I have tried e-mailing CustomerSupport@tesla.com but received an auto-reply stating that the e-mail address is no longer monitored. I have tried calling my local Tesla service center (Vancouver), but any appointment-related query gets an auto-response to "use the app to make an appointment".

I am running the most up-to-date Android version of the app: 3.10.2 (8bd2dc0ef).
Any help you can provide on this matter is appreciated.

normtoystoys | 2019年12月12日

Sounds to me like your cellphone app is "pinging" you and Elon is "ponging" you.

andrebowen | 2019年12月12日

I have this exact same issue, using the Tesla app on an iPhone.

edow | 2019年12月12日

Yep, same problem. Cannot schedule an appointment through the app.

rehutton777 | 2019年12月12日

Possible fixes: Make sure you have the most current phone app (V3.10.2). Delete app and re-install.

surfpearl | 2019年12月12日

Sorry to hear. My app is the same version as yours but works fine, was just recently able to set up a service appointment.
How far is your local Service Center in Vancouver? Make it a fun trip and have a side visit with them in person, schedule your service and inquire about the app issue. If that's not an option, get a carrier pigeon :)

chaomon | 2019年12月13日

@rehutton777, I've already tried those steps and more. I think it's something on the Tesla side.

@surfpearl, I do plan to go to the Vancouver Service Center when I get the chance. The tricky part is that my issue is related to a leak that is happening when it rains, and finding a day that isn't raining in Raincouver is not exactly easy ;)

The last service I booked was a mobile service, and they tried to fix the leaking issue that I had. But the problem still occurred so I tried to book another appointment. That is when I ran into this problem.

jodyhess | 2019年12月13日

I've got the same issue. I've logged out and back in, turned phone off and then back on and deleted and reinstalled most current phone app. No such luck. Apparently this is the only way to schedule an appointment. I'm at a loss.

amodp123 | 2019年12月13日

Same here in SF Bay Area! Can't see the option to schedule service appointment in online account, and the app link shows old appointment with no way to schedule new one! Tesla, pl fix ASAP.

chaomon | 2019年12月13日

I found another e-mail that was referenced in an older discussion thread: ServiceHelpNA@tesla.com.
I e-mailed the address with the issue to see if I'll get a response. At least this one did not immediately return with an auto-reply saying that the address was no longer monitored, however I'm not holding my breath.

yangjian888 | 2020年1月10日

same problem. tried multiple times. no luck. also no customer service available for help. very frustrating...

fras | 2020年1月14日

Same problem here, using iPhone

wvisser | 2020年1月14日

Same problem here..... on Android

patrick1120 | 2020年1月14日

same problem on iPhone

stingray.don | 2020年1月14日

Do you have the latest app version - V 3.10.3?

jackting88 | 2020年1月15日

same problem on iphone. app version 3.10.3

suryakumarirajt | 2020年1月21日

same problem on iPhone

lilbean | 2020年1月21日

Same problem on my flip phone.